X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Youtube videos on other sites not loading

Posted

I can't play Youtube videos imbedded on other websites. When I click to play one, the video never loads. If I click the "Watch on Youtube" button on the video's control bar and open Youtube's site, the video then loads and plays normally.

Chosen solution

Yeah, it's Adblock Plus for me too, even if it's not blocking anything on the page. If I disable it for the page in question, the video loads. Adjusting my Adblock filter preferences seems to have fixed it.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • VLC media player Web Plugin 2.0.2
  • McAfee MSS+ NPAPI Plugin
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • SiteAdvisor
  • McAfee Virtual Technician plugin for Mozilla (Gecko Version: 1.8b1)
  • 4.1.10329.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

finitarry 157 solutions 2178 answers

I have that problem as well. Watching on YouTube works, so that is acceptable as a workaround. That problem does not occur with Opera or Safari.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Make sure that you aren't blocking cookies.

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.
finitarry 157 solutions 2178 answers

I doubt that it is a cookie issue. I allow cookies for the forum where I usually see the embedded videos from YouTube, but not for YouTube. That works fine with Opera, not with Firefox, and I use the same cookie settings for the same sites with both.

It is Adblock Plus causing the problem. If I disable it on the page where the embedded video is, the video plays. I would rather use a workaround than disable Adblock Plus.

Chosen Solution

Yeah, it's Adblock Plus for me too, even if it's not blocking anything on the page. If I disable it for the page in question, the video loads. Adjusting my Adblock filter preferences seems to have fixed it.

finitarry 157 solutions 2178 answers

What did you change? I presume there was some URL that it normally blocks that has to be unblocked?

Question owner

Tools>Add-ons>Adblock Plus, then the Filter Preferences button. From there, the Custom Filters tab, and in the Ad Blocking Rules category I had youtube.com/crossdomain.xml entries. After unselecting those and saving, the problem seems to have been resolved.

finitarry 157 solutions 2178 answers

Got it. Thanks, it works.

If you have the Adblock Plus toolbar button on the main toolbar or on the addon bar, you do not have to open the add-ons window to change the filter preferences.  All you need to do is right-click the button and choose Filter Preferences.
Itchan 0 solutions 1 answers

Helpful Reply

I'm having this problem too, but its not adblock... I disabled it, but still doesn't work.