X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Middle click not opening link in new tab. Windows 7 Firefox 17.0.1

Posted

Middle click suddenly stopped opening new tabs when links are clicked on. I was running 16, but updated to 17 (latest) to try to fix the problem. I am using a Logitech mouse and keyboard. Worked until this week.

I really need this working again.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Google Update
  • Microsoft Lync 2010 Meeting Join Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • NPWLPG
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

I have disabled all add-ins, restarted and restarted into safemode. None of these have made a difference. IN about:config the following are set for middle:
middlemouse.openNewWindow;false
browser.tabs.opentabfor.middleclick;true
middlemouse.contentLoadURL;false
middlemouse.paste;false
middlemouse.scrollbarPosition;false
Have also tried with the following set:
middlemouse.openNewWindow;true
Have also tried both settings of:
browser.display.focus_ring_on_anything;true

cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96840 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.