X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why has Yahoo! installed itself as default search engine behind Firefox 'front page' and how do I turn it off?

Posted

Yahoo search engine seems to have imposed itself as default search engine whenever I open a new tab or use the small search pane on top right of screen. Is this a Firefox default setting and, if not, how can I switch it off?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • iTunes Detector Plug-in
  • McAfee MSC FF plugin DLL
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • SiteAdvisor
  • 4.1.10329.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

In order to change the default search engine or the order of search engines in the top right search box in Firefox, please perform the following steps:

  1. Move the mouse cursor inside the search box at the top right of the Firefox window and click the down arrow next to the provider's logo.
  2. If you would like to select another search engine, simply pick the engine from the dropdown list.

In order to change the order of the search engines, do this:

  1. From the dropdown list, select Manage Search Engines....
  2. In the upcoming window, you have all your search engines listed. To change the order, simply click one search engine and then select Move up or Move down from the buttons on the right side in order to change the order of the search engines.
cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96850 answers

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

You can look at this updated version of SearchReset that resets the search engine used on the about:home page:

Modified by cor-el

marnie1951 0 solutions 1 answers

Helpful Reply

Yahoo has taken over my search engine also. so far I have removed the Yahoo choice from Manage Search Engines. I have Google as the first choice but it still opens in Yahoo.

As the screen shot shows ....you can clearly see that Google was my choice but it came up on Yahoo.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96850 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
bob6003 0 solutions 2 answers

I've tried all the above mentioned solutions. I still have the same problem. whenever typing in an invalid url in the address bar I always get the Yahoo Bad Search screen (see attached). when I use chrome I will get the Google 404 page. what has happened in firefox that I now default to Yahoo? Can this be fixed?

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96850 answers

This can be caused by corrupted cookies or cookies that are blocked (check the permissions on the about:permissions page).

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"
bob6003 0 solutions 2 answers

Thanks for replying but clearing the catch and deleting the cookies did not help.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96850 answers

Can you go do a Google search if you type the Google URL in the location bar?