Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

after updating to latest version of Java (7.10) it no longer works and JRE has disappeared from my plugins list

  • 13 replies
  • 56 have this problem
  • 6209 views
  • Last reply by n1msr

more options

On checking my add-ons and plugins I attempted to update Java Run Time to latest version as firefox said it was outdated.

I tried installing new version JRE 7.10 manually and through firefox (which said the installation was successful). When testing it, I get told that Java is not working and that a plug in is missing. Can not check whether the new plugin is enabled as JRE has disappeared from the plugins tab (Only Deployment Toolkit appears).

The Java control console says that it was successfully installed in all browsesr. I have tried uninstalling and reinstalling Java 3 times and keep getting the same result. Java is working fine on chrome and IE so problem must be with FF.

All Replies (13)

more options

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

more options

Do you see the Java plugin on the "Tools > Add-ons > Plugins" page?

If the plugin shows there, but is disabled then try to delete the pluginreg.dat file in the Firefox Profile Folder and maybe addons.sqlite as well to reset the plugin registry databases and to force Firefox to rescan for plugins.

more options

the Mozilla plugin check site does not show the JRE plugin only the Java deployment toolkit which it says is up to date.

more options

as previously stated the JRE plugin no longer shows on the "Tools > Add-ons > Plugins". before attempting the update it did list it but said it was outdated hence why I attempted to update it. The only plugins listed are for Acrobat, Flash, Silverlight and the java deployment toolkit, all of which are up to date.

more options

Did you try to remove the pluginreg.dat file like I posted above?

more options

I can't find a file called pluginreg.dat on my computer

more options

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
more options

finally found pluginreg.dat and addons.sqlite (both hidden files) deleted both but didn't make any difference. Tried re-installing JRE again after deleting files but no change. As far is firefox is concerned JRE is not installed.

more options

Java SE7U10 works fine with FF 3.6.28.

The trick is to download the offline installer for Java and install/reinstall the program. It shows up in the add-ons menu and works successfully on the Java test page.

more options

i have already tried installing the offline version but Java SE7U10 does not show in the add-ons menu and Java doesn't work

more options

Seems odd. I've been playing around with installing and uninstalling various versions of FF this past week, and Java has always installed and worked without any problem.

If you're up to it, I'd uninstall both FF and Java, being sure to delete any remaining hidden folders/files and any remaining registry entries relating to both programs. The install FF 3 followed by Java 7:10. I can't imagine why you wouldn't see Java as being installed for FF after this. but maybe something else is going on that I can't think of at the moment.

more options

I eventually resolved the problem here (FF 17.0.1, Win 7, Java7u10) with darkrats suggestion, but with a few sidenotes:

- Just uninstalling FF (while keeping settings), uninstalling Java7u10, reinstalling FF, Java7u10 did NOT solve the problem

- On the second try, I uninstalled FF (also remove settings), Java7u10, JavaFX, and a Java 7 JDK. Looked at c:\Program Files (x86)\Mozilla Firefox, was not completely empty so manually deleted. Then reinstalled FF, Java7u10 and java worked again in FF, also after installing the JDK.

So I don't know whether the uninstall w/ remove settings, removing the leftover program folder or the JavaFX/JDK was the solution, or perhaps both.

I did read that JavaFX is now supposed to be included in the JDK so that needed to go anyway, but I'd still guess it was the personal settings or folder b/c I doubt our customers reporting this problem have the JDK/JavaFX.

more options

I just uninstalled JavaFX and then was fine. FF 20.0, JRE 7.0.170.

On the most recent occasion (today) the plug-in message did not appear. I re-installed JRE but that did not work. Before going for the fill unsintall of all Java components (JDK, JRE and JavaFX) I tried uninstalling just JavaFX. That did it this time.

In the past when this has happened I have sometimes had a plug-in message in Firefox, and clicking on the option to use and allow it has "fixed" the problem. I did not get a plug-in prompt today.