X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Java installed but not working

Posted

Hi, after updating to Java 7 update 10 Java stopped working. Plug in checker indicates Java Deployment Toolkit 7.0.100.18 is installed correctly, but Java test page says plugin needed and Java Runtime Environment 1.7 u10 is available. Install fails. Uninstalled Java and tried manual install (including as administrator) but no resolution. All old Java versions have been uninstalled. Thank you for your time.

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.10411.0
  • DivX Web Player version 1.5.0.52

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2.1
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
deskCut
0.6.0.3
true
{9125C9CB-BE2B-4389-A0C7-46A4BDD46AEA}
FireGestures
1.6.19
true
firegestures@xuldev.org
RightToClick
2.9.4
true
{cd617375-6743-4ee8-bac4-fbf10f35729e}
WOT
20120926
true
{a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20121128204232
browser.startup.homepage_override.mstone
17.0.1
browser.tabs.onTop
false
browser.tabs.warnOnClose
false
extensions.lastAppVersion
17.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1355446620
places.history.expiration.transient_current_max_pages
104858
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce 210
Vendor ID
0x10de
Device ID
0x0a65
Adapter RAM
512
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
9.18.13.1070
Driver Date
12-3-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 300
WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce 210 ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

fastdad 0 solutions 1 answers

scrumpyjoe's solution worked for me. Thank you so much for saving me!

For the version number I ran the Java Control Panel, selected the Java tab, clicked on "View", and a panel popped up indicating version 1.7.0_11 which I used when creating the New Key. I don't know if that makes any difference and I don't care because Java is working in Firefox finally. Yay!!!

Modified by fastdad

peter2013 0 solutions 8 answers

I am having this problem as well. What is the fix?

stocktic 0 solutions 5 answers

Peter2013 - the Java fix in Firefox is easy - wait for Oracle to patch the security holes in Java to Mozilla's satisfaction. Firefox is restricting the installation of the Java plugin because the threat that a "bad guy" will take over your machine is real. The Java security hole is real.

If you must run Java for a specific application, use another browser to run Java against that application; that is, dedicate IE or Google for Java apps. Do NOT use the browser for any other browsing needs. Close the browser when your task is completed. Java will install on IE and Chrome I understand (but do not know for sure).

Continue to use Firefox as your principle browser for all other needs.

sabelotodo33 0 solutions 1 answers

A working solution for me:

Check HKEY_LOCAL_MACHINE/SOFTWARE/MozillaPlugins Look for @java.com/JavaPlugin,version=10.13.2 Replace "Path" with the true path to npjp2.dll, for me: "C:/Program Files/Java/jre7/bin/plugin2/npjp2.dll"

Java is working again in chrome!!!

ChickenPants 0 solutions 8 answers

There's a new update for Java and FF18 seems to place nice with it. See Java Update 13