X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Java installed but not working

Posted

Hi, after updating to Java 7 update 10 Java stopped working. Plug in checker indicates Java Deployment Toolkit 7.0.100.18 is installed correctly, but Java test page says plugin needed and Java Runtime Environment 1.7 u10 is available. Install fails. Uninstalled Java and tried manual install (including as administrator) but no resolution. All old Java versions have been uninstalled. Thank you for your time.

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.10411.0
  • DivX Web Player version 1.5.0.52

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2.1
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
deskCut
0.6.0.3
true
{9125C9CB-BE2B-4389-A0C7-46A4BDD46AEA}
FireGestures
1.6.19
true
firegestures@xuldev.org
RightToClick
2.9.4
true
{cd617375-6743-4ee8-bac4-fbf10f35729e}
WOT
20120926
true
{a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20121128204232
browser.startup.homepage_override.mstone
17.0.1
browser.tabs.onTop
false
browser.tabs.warnOnClose
false
extensions.lastAppVersion
17.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1355446620
places.history.expiration.transient_current_max_pages
104858
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce 210
Vendor ID
0x10de
Device ID
0x0a65
Adapter RAM
512
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
9.18.13.1070
Driver Date
12-3-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 300
WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce 210 ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

abcron 0 solutions 11 answers

Mega dittos to your comment...nothing is working...one suggestion was Pale Moon browser for 64 bit, problem is just as bad or may be worse, does not look for plugin at all...

nuwon 1 solutions 20 answers

Java plugins are blocked:

https://addons.mozilla.org/en-US/firefox/blocked/

ChickenPants 0 solutions 8 answers

@nuwon - I was suspecting this may be the root of it. In my case I cannot use the workaround found here:

https://support.mozilla.org/en-US/kb/how-to-use-java-if-its-been-blocked#w_always-activate-java-for-a-site

It's not installed as a plugin, so I cannot allow it. I can't install it.

ETA: This site indicates that JavaFX may be the root of the issue:

https://service.parachat.com/knowledgebase/265/Java-doesnt-work-in-Firefox-after-installing-Java-7-Update-10.html

I have managed to get it installed, but it seems so far not be be operating like it should - and, unfortunately, I run applications which make it necessary to use this Java Junk.

2nd Edit - ok - the issue is resolved. I removed JavaFX as instructed in the link above and then removed all instances of Java. Then I reinstalled both the 32bit and 64bit versions of the latest Java found on their site. From there I have allow each site wanting to use Java to access the plugin, the instructions for which are found here:

https://support.mozilla.org/en-US/kb/how-to-use-java-if-its-been-blocked#w_always-activate-java-for-a-site

I have spent the better part of a day looking for a fix. The registry stuff is nonsense. Get rid of JavaFX, uninstall all your installations of Java, reinstall the latest version of this cursed program and then you will be good.

Cheers!

ChickenPants is not so angry now.

Modified by ChickenPants

stocktic 0 solutions 5 answers

Chickenpants - I recognize an immense amount of work in order to "tip-toe thru the tulips" in Java. There has to be an easier, more universal fix to get Java to work. We both know that there are many more frustrated Java users (like us) out there frantically searching for a fix..

Oracle - time to get engage as owners of Java & present the community with a Java fix.

ChickenPants 0 solutions 8 answers

Hi Stocktic,

Java seems like some ancient monster no one can really tame or kill off for good! I'd not waste my time with it but I use online shipping software daily and it's forced on me.  :(

Java likes to say "3 billion devices run Java"...I'd bet many don't do it well or really piss off their operators.

For software in 2013 to be a pain like this should be an embarrassment to Oracle. Maybe one day they will listen to the user base. The irony is that I found the workaround on a site unrelated to both Oracle and Mozilla O.o - what's that about?

Nathan2055 11 solutions 110 answers

Guys, Mozilla has automatically disabled all versions of Java 7 for safety reasons after the recent vulnerability discovery. You should either downgrade to Java 6 or wait for Oracle to fix it.

abcron 0 solutions 11 answers

The problems started in Java 6.

flavier 0 solutions 1 answers

This worked for me (32-bit WinXp) : I just uninstalled JavaFX and didn't even need to reinstall the jdk.

Java is still globally disabled, but you can enable it on a site-by-site basis: cf.

https://support.mozilla.org/fr/kb/why-do-i-have-click-activate-plugins#w_how-to-always-activate-a-plugin-for-a-trusted-website

Hope this helps...

Modified by flavier

abcron 0 solutions 11 answers

deleted FX java files, and I can now run my java apps...

Nathan2055 11 solutions 110 answers

Wait, you guys were running the JDK?

ChickenPants 0 solutions 8 answers

Yes - Java has been disabled globally. However, the issue with the J7-10 update is related to JavaFX. I'm not running Java SDK - just plain old Java for consumers.

It's still necessary to enable the plugin to work with each site, but the trouble wasn't related to that. The trouble was with the fact that Java Runtime was not being seen by Firefox as an installed plugin. Removing JavaFX clears the roadblock.

Do what I've outlined in my solution, and the problem goes away.

abcron 0 solutions 11 answers

I do need the JDK sometimes, but if necessary, I will use a different computer for that. Where I am using the JDK, I do not use the latest JRE or JDK and I have no current problems...

Oracle, get these problems fixed or Java will be dropped by a lot of users...

Nathan2055 11 solutions 110 answers

Well, at least until the vulnerability is patched, it might be better to uninstall the JDK and load the standard JRE. It will still be Click to Play blocked, though.

ChickenPants 0 solutions 8 answers

More strangeness. I run the latest version of Thunderbird (updated today) and the latest version of Firefox (update yesterday). Firefox gives me a warning, but Thunderbird doesn't.

cor-el
  • Top 10 Contributor
  • Moderator
10747 solutions 96719 answers

Oracle has released a Java 7 Update 11 to address security vulnerabilities and you should update to that version.

See also:

You can find the latest Java version on the Oracle website.

See Java Platform > Java SE 7U11

abcron 0 solutions 11 answers

I think I will wait a little while...I do not believe this is a fix yet...I have heard the update to 12 is in beta and it has the problems as well...

ChickenPants 0 solutions 8 answers

@Cor-El - thank you for the update information.

ChickenPants doesn't press his luck - he may be a birdbrain, but he has enough to sense to stop when he's ahead :) No V11 for him! In fact, no more Java updates at all!

Modified by ChickenPants

sheaton 0 solutions 1 answers

Installed Java 7 update 10 today (13th Jan 2013). Firefox reports no Java installed (grey box where Java content should be) and clicking on install text results in a failed automatic installation. Manual install of online or offline JRE fails. Looking at Add-ons does not include Java (™) Platform. Probable cause: Java plugins are blocked see list at: https://addons.mozilla.org/en-US/firefox/blocked/ Solution: Navigate to C:/Program Files/Mozilla Firefox/ and locate blocklist.xml Rename to blocklist.old Return to non-functioning webpage and click install text in greyed out area. Java should now work (may need to reboot Firefox). Reame blocklist.old to blocklist.xml

Modified by sheaton

stocktic 0 solutions 5 answers

Sheraton - appreciate the Firefox work-around so as to gain access to Java apps thru Mozilla's browser. However, tweaking does not negate the security issue inherent in the Java code which is why Firefox is blocking Java's update.

I think it is inherent on Oracle (Java's parent) to act quickly. I have my Java turned off and only turn it on when I trust a site which I need access to.

ChickenPants 0 solutions 8 answers

I have only two sites for which Java is required. Those are trusted sites. I haven't needed it otherwise.