X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why is Mycroft Project asking JavaScript be enabled to install a search plugin?

Posted

When I try to install any of the search engine plugins from http://mycroft.mozdev.org/index.html, I get the following msg: «JavaScript must be enabled to install a search plugin. If you have installed NoScript, you will need to allow this page to run scripts.»

I'm using Ubuntu 12.10, Mozilla FF 17.0.1 and JavaScript is already enabled in it. The same plugins create no whatsoever problem in Windows7, so why can't I use them in Ubuntu too?

P.S. I've noticed that all the problematic plugins (most of the good ones out there!), are all preceded by the OpenSearch "A9" icon for Mozilla FF v. 2/3. The ones preceded by the Mac Apple icon, are swiftly added to the list of search engines and give no problem at all. However, these are few in number and the ones I want, are mostly OpenSearch compatible. Any way to fix this issue?

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • Shockwave Flash 11.2 r202
  • DivX Web Player version 1.4.0.233
  • The Totem 3.4.3 plugin handles video and audio streams.

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Wow! That solved my problem. Now, how do I get it to work without going into Safe Mode? Or do I have to always switch to Safe Mode every time I want to add a search engine plugin from the Mycroft Project?

Modified by grasshopper

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

If it works in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

See also:

mudzhyj 0 solutions 2 answers

Same problem with Ubuntu 12.04 and Firefox 19. Solution proposed by cor-el does not work for me. Is there anything else I could try? Thank you in advance.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

mudzhyj 0 solutions 2 answers

Thank you cor-el for your help but it turned out I had to install Firefox search engine plugins with root privilege. Then the pop-up window showed up and I could add the needed search engine. Still not sure if this is a Firefox or Ubuntu issue, let alone if this can be called an issue at all. I hope this helps someone to install Firefox search engines too!

viordiasko 0 solutions 1 answers

Helpful Reply

For Ubuntu 12.10 users: Disable the Unity Desktop Integration Plugin & restart the browser. Then you can add search engines from the Firefox website.

As I'm using Gnome Shell, I haven't renabled it since. Unity users should try.