Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Running Firefox 10.0.2, cannot add new search engines from Mycroft Project. Error message: "you will need a browser which supports opensearch to install this plugin" Please help with steps on how to fix this issue in Firefox, thank you

  • 3 replies
  • 12 have this problem
  • 12 views
  • Last reply by cor-el

more options

Can't add new search engines from Mycroft Project in FF 10.0.2. Error message states: "you will need a browser which supports opensearch to install this plugin"

Chosen solution

Can you install Sherlock plugins or does that fail as well?


Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Read this answer in context 👍 3

All Replies (3)

more options

Chosen Solution

Can you install Sherlock plugins or does that fail as well?


Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

Thank you very much Cor-el! I started FF in safe mode to rip the add-ons out of the mix, and the new search engines I wanted to add installed perfectly. I like my mix of add-ons so I'm keeping them, but will use this workaround whenever I add new search engines going forward. Excellent advice, thanks again C!

more options

You're welcome.

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

Modified by cor-el