X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

yahoo mail extremely slow on Firefox 17

Posted

I am using Firefox 17. Since Yahoo new email launch, it is very slow in response in typing email. I have no problem open Yahoo mail using Chrome or IE9. Please advise!

Chosen solution

have you tried disabling proxy, as I described earlier?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Google Update
  • Foxit Reader Plug-In For Firefox and Netscape
  • 5.1.10411.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3015 answers

Please go to help -> About firefox to update to 17.0.1 to see if it helps.

If that doesn't work please see the following;

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Question owner

I tried but still no go! The strange thing is only Yahoo email is affected. All other email account or other application that I open (include reply to this email) does not have a problem. This slow yahoo email does not happen on Chrome or IE9.

artmedeck 0 solutions 1 answers

Helpful Reply

I had the same problem. Opening Firefox in Safe mode cured it, so I knew it had to be a setting or plugin of some sort....I did all the recommended fixes and nothing changed the typing being real slow and behind when running in normal mode.

What fixed it for me is turning off the hardware acceleration option in Firefox. Here's how: Click on Firefox->Options->Advanced->General tab. Then uncheck the checkbox "Use hardware acceleration when available". Click OK. Hope it works for you. Good luck!

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96644 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

I did all that and still did not work. I end up reload my pc Win7 software from original and reinstall Firefox and this resolve the slow issue.

Thanks for all the suggestion and reply on this

wfraga 1 solutions 1 answers

I had the exact same problem. Very slow to get keys to show up as I typed in Firefox 17.0.1. Worked fine in Chrome. Tried removing all extensions but no change. Upgrade to Firefox 18.0 fixed the problem.

Question owner

Actually after I uncheck "use hardware acceleration when available" under option. That help. Now I upgraded to 18 seem to work as well as check "use hardware acceleration when available" works!!

thanks!

paganiniv 1 solutions 4 answers

I had some problem with very slow Firefox, tried everything above without success

other browsers were fine, then I thought there must be some problems in how FF connects to network

so the following solved the problem: Firefox - Options - Advanced - Network - Connection Settings tick "No Proxy"

Modified by paganiniv

Question owner

update to Firefox 18 resolve the slowness problem.

SkyFeather 1 solutions 4 answers

I have the same problem, every feature in Yahoo mail takes ages to proceed i.e: making new folder, emptying spam and/or trash folder. I have disabled all extensions, nothing changed. Yesterday the Firefox upgraded to 18.0.2 and *still* nothing changed.

Note on the attached screenshot: I had already emptied the trash folder, I clicked on 'Inbox' but it didn't load. It would load *only* if I refreshed the whole tab...

-S

What is happening with Firefox lately, the Kaspersky visual keyboard also is not functioning since many updates ago.

Question owner

I have the same problem. But since upgrade to Firefox 18.0.1. The problem goes away. I just have the fonts keep getting larger after each carriage return. Also, the right click mouse for "copy" does not work. Control "C" works!!

paganiniv 1 solutions 4 answers

Chosen Solution

have you tried disabling proxy, as I described earlier?

SkyFeather 1 solutions 4 answers

I am not using any proxy m8.

paganiniv 1 solutions 4 answers

I'm not saying you are using proxy m8 those settings are default: "Use system proxy settings" need to be changed to "No proxy"

SkyFeather 1 solutions 4 answers

Today --btw I haven't changed anything-- and yahoo mail works perfect! Finally!!! :D