X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop a new tab from opening when I click a link?

Posted

Whenever I click a link, it opens in a new tab. This just started almost a week ago, but I didn't change any settings or click anything--it just started doing it by itself. It is extremely irritating, because it just increases the number of tabs I have.

Additional System Details

Installed Plug-ins

  • Facebook Video Calling Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • SiteAdvisor
  • 5.1.10411.0
  • iTunes Detector Plug-in
  • Shockwave Flash 11.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

nmd12 1 solutions 15 answers

Did you try to reset Firefox? You can do this by going to "Help">"Troubleshooting Information", and there should be a button near the top right.

Helpful Reply

Okay, so I tried that, but it didn't work. Any other suggestions?

nmd12 1 solutions 15 answers

Could something be causing your Control button from being in a "on" or "stuck" position? And when is the last time you have restarted your PC? Sometimes a reboot helps, but if the Ctrl button was like that you would probably be experiencing problems in other programs too. If you are sure the button isn't in a "stuck on" position and a reboot didn't work I have no idea what is going on but contact me again and I will try to get your problems resolved.

Ralph Daub
  • Administrator
58 solutions 431 answers

Hi Hannah,

I have something like that happen to me sometimes, but I'm not sure it's the same issue that you're experiencing.

My wireless keyboard sometimes has connection problem and acts like the "Ctrl" key is constantly pressed. So, when I click on a link, Firefox receives the "Ctrl + Mouse Click" shortcut, which makes it open a new tab.

This is a very unorthodox suggestion but it might be worth checking: try unplugging or disconnecting your keyboard, and then clicking on the link. If it works normally, then you're probably having a similar issue as me.

Perhaps the strangest troubleshooting step I have ever given, but I hope it helps! :)

- Ralph

Question owner

Both of my Control buttons are fine (I just tested them), and the last time I started my computer was this morning--I turn it off every night, and on every morning. Thanks for the suggestions, anyway!

Ralph Daub
  • Administrator
58 solutions 431 answers

Helpful Reply

Hi Hannah, try this:

  1. Click on your address bar
  2. Type "about:config" without the quotation marks
  3. Press Enter, then click "I'll be careful, I promise"
  4. Search for browser.link.open_newwindow
  5. The default value should be '3' for this property
  6. If it's already '3', change it to '1' and restart your Firefox.

Does this help?

robbglass 0 solutions 6 answers

Neither rebooting nor adjusting the " browser.link.open_newwindow " from 3 to 1 allowed me to click on a page link and stay on the same tab.

I have my tabbed icon clusters arranged in Mission Control. Clicking on tabs in an opened icon works very well. However, clicking on links within an opened tab results in opening a new tab. I wish to preserve my predefined tabs without additionally populating my tab bar.

I will investigate "freezing" and "pinning" my tabs so see if I can inhibit tab duplication.

Side Note: I've never tried Thunderbird, but do like the editing capacity of iMail. The iMail/FF relationship was tedious ( opened email appeared as a new tab on my FF homepage ) By configuring iMail to open in Safari as a separate Mission Control icon, iMail is fully functional.

'09 iMac/FF

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
robbglass 0 solutions 6 answers

As suggested by writer cor-el, Safe Mode start up restored my FF satisfactorily. Rather than keep fiddling with settings, I chose the "Reset" option. Works like a charm !

Thanks !

Rob


'09 iMac/FF/Noscript/AdBlocker

Question owner

How do I switch to DEFAULT mode? It says disabled.... I'm not really good with computer stuff, so I could be doing something completely wrong and this could be a dumb question, but I don't know what to do!

robbglass 0 solutions 6 answers

Dear Hannah,

Clicking down the FF/Tools/Add-ons/Appearence/Default only told me I have "Default 21.0" installed. Whoopie Doo !

cor-el responded with the most effective advice which I paste below for your prompt relief ( hint, hint Reset ! )

Hi robbglass,

cor-el commented on a Firefox question on support.mozilla.org:

How do I stop a new tab from opening when I click a link?

cor-el wrote:

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

   Do NOT click the Reset button on the Safe Mode start window or otherwise make changes. 
   https://support.mozilla.org/kb/Safe+Mode
   https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

See the comment.

If this comment is helpful, vote on it.

Help other Firefox users by browsing for unsolved questions on support.mozilla.org.

You might just make someone's day!

Hannah,

The first link will guide you to booting up in Safe Mode which disables extensions and add-ons, a common source of interference. If everything is fine in Safe Mode, then extensions and add-ons are the problem.

The second link, which you may have to copy and paste, contains a lot of technical stuff, but if you can temporarily bear losing some functionality until you reenter passwords etc, go directly to the "Reset" section and proceed on those steps.

Good Luck !

Rob