X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how do i turn off smart address bar

Posted

I do not want the address bar to generate a google search. I want to navigate to the address I type in. Firefox just updated to 17.0.1 . Tonight I typed in the web address of Project Guttenberg and endup on a google search page. This is no acceptable. If i typed the address incorrectly an error message would be my preference

Chosen solution

P.S. To turn off the Google search from the address bar, see this article:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • VLC media player Web Plugin 2.0.2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Shockwave Flash 11.4 r402

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Reset Firefox to its default state
If you're having major problems which you can't resolve, start fresh with only your essential information.
Troubleshooting Information
This page contains technical information that might be useful when you're
trying to solve a problem. If you are looking for answers to common questions
about Firefox, check out our support website.
Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
DownThemAll!2.0.15true{DDC359D1-844A-42a7-9AA1-88A850A938A8}DownThemAll! AntiContainer1.2trueanticontainer@downthemall.netFireDownload3.1.0truefiredownload@mozilla.orgFlash Video Downloader Youtube Downloader3.8.1trueartur.dubovoy@gmail.comForecastfox2.2.2true{0538E3E3-7E9B-4d49-8831-A227C80A7AD3}FreeHDSport.TV1.1truefreehdsport@freehdsport.tvNoScript2.6.3true{73a6fe31-595d-460b-a920-fcc0f8843232}
Important Modified Preferences
Name
Value
browser.cache.disk.capacity1048576browser.cache.disk.smart_size.first_runfalsebrowser.cache.disk.smart_size_cached_value849920browser.places.smartBookmarksVersion4browser.startup.homepage_override.buildID20121128204232browser.startup.homepage_override.mstone17.0.1browser.tabs.onTopfalseextensions.lastAppVersion17.0.1gfx.direct3d.prefer_10_1truenetwork.cookie.prefsMigratedtrueplaces.database.lastMaintenance1355279424places.history.expiration.transient_current_max_pages104858privacy.donottrackheader.enabledtrueprivacy.sanitize.migrateFx3Prefstruesecurity.warn_viewing_mixedfalse
Graphics
Adapter DescriptionATI Radeon HD 5700 SeriesVendor ID0x1002Device ID0x68beAdapter RAM1024Adapter Driversaticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64Driver Version9.2.0.0Driver Date9-27-2012Direct2D EnabledtrueDirectWrite Enabledtrue (6.1.7601.17789)ClearType ParametersClearType parameters not foundWebGL RendererGoogle Inc. -- ANGLE (ATI Radeon HD 5700 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)GPU Accelerated Windows1/1 Direct3D 10
AzureCanvasBackenddirect2dAzureFallbackCanvasBackendcairoAzureContentBackenddirect2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum versionVersion in useNSPR4.9.24.9.2NSS3.13.6.0 Basic ECC3.13.6.0 Basic ECCNSS Util3.13.6.03.13.6.0NSS SSL3.13.6.0 Basic ECC3.13.6.0 Basic ECCNSS S/MIME3.13.6.0 Basic ECC3.13.6.0 Basic ECC

AliceWyman
  • Moderator
191 solutions 1969 answers

You can set the Location bar autocomplete feature to suggest "Nothing" in the Firefox Options window - Privacy panel. See this article for details:

Modified by AliceWyman

AliceWyman
  • Moderator
191 solutions 1969 answers

Chosen Solution

P.S. To turn off the Google search from the address bar, see this article:

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97065 answers

You can set the keyword.enabled pref to false on the about:config page.

Helpful Reply

Thanks to Corel and AliceWyman. That little tweak in the config settings was what I was seeking.