X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When I type into the address bar, yahoo search results appear. this just started happening, it was showing google search results previously. how do I get google results instead of yahoo?

Posted

If I type "NBA" into the address bar, I will get results from yahoo. I don't want yahoo results, I want Google results. This just started happening today. How do I get Google search results to show after typing into the address bar?

Modified by apostlejw

Chosen solution

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference keyword.URL, right-click on it and choose Reset

This will restore it to Google.

Read this answer in context 25

Additional System Details

Installed Plug-ins

  • Image Control Plugin for viewing images on Ancestry.com. Version 1.0.0.1
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPTURNMED
  • 6.0.12.1675
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • npdivxplayerplugin
  • npdnu
  • npdnupdater2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • Default Plug-in
  • Google Update
  • Shockwave Flash 10.1 r102
  • DivX Web Player version 2.0.3.4
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.51204.0
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Chosen Solution

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference keyword.URL, right-click on it and choose Reset

This will restore it to Google.

Question owner

Thank you!!!! it worked.

TonyE
  • Moderator
1041 solutions 8840 answers

You're welcome

will.stuivenga 0 solutions 1 answers

I have this problem, but my keyword.URL is set to http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= And the "reset" option is grayed out, presumably because I already HAVE the default setting. Nevertheless, I'm still getting results from Yahoo. When I type "Yahoo" into the about.config filter, I get a huge list of Yahoo related settings, none of which I have a clue about. I do have the Yahoo toolbar installed in Firefox, which I use from time to time, but I didn't want Yahoo taking over my URL based searching. Any ideas on how to fix this?

Helpful Reply

1. type "about:config" into the address bar (without the quotes) and hit enter. 2. type "keyword" in the find field 3. double click keyword.URL 4. replace that URL with this:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&q=

That will make it give you Google results.

If you put in this:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

then you get the "I'm Feeling Lucky" behavior.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

See also:

williemyers 0 solutions 3 answers

TonyE and apostlejw, tried both of your solutions with no luck. *STILL* giving me Yahoo Search results every time I type in to address bar. FWIW, my problem only began on the day that I switched ISP's (from DSL to Insight Cable). I'm wondering if the ISP is intercepting my searches and causing me to get "Yahoo Search' results, whether I like it or not?

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

You can try alternative DNS servers.

SerryJW 0 solutions 8 answers

I have tried it both ways including manually entering your google string ....NOTHING is changing it back to google. When I open a window I get google BUT when I open a tab, I get yahoo! Help!

skaukatt 0 solutions 2 answers

I've tried the solutions noted here to no avail. Yahoo always comes back even if I manage to get a few google searches (via keyword.url editing) after a few searches, Yahoo returns.

Can anything be done?

Hyacinth Bucket 0 solutions 1 answers

TonyE's solution worked with NO problems. You must type in the colon!

I love you TonyE.  Thanks for your help!  :-)
williemyers 0 solutions 3 answers

this topic should not be marked "Solved"...when an ISP (like Insight) is hijacking your search, reseting keyword.URL will not fix it