X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Missing options of "Enter Private Browsing" "Open new tab" and "Open new window" when right click (right context menu) firefox icon on taskbar

Posted

Missing options of "Enter Private Browsing" "Open new tab" and "Open new window" when right click (right context menu) firefox icon on taskbar.

i already tired complete uninstall and reinstall, but the options are still missing. print scr: http://www.freeimagehosting.net/9znkp

Thank You in advance for help. Best regards

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPWLPG
  • 4.0.50401.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Gingerbread Man
  • Top 25 Contributor
219 solutions 899 answers

Those jumplist items can be removed through a hidden preference. Make sure it hasn't been customized by following these steps:

  1. Type about:config in the address bar and press Enter.
  2. Press the big button to bypass the warning.
  3. In the Search bar, paste browser.taskbar.lists.tasks.enabled
  4. In the search results, right-click browser.taskbar.lists.tasks.enabled and choose Reset. If the option is grayed out, then that preference hasn't been customized and is already at its default value.

Question owner

Thank You for the fast reply

I followed the steps above, and found that the Reset options was grayed out print src: http://www.freeimagehosting.net/yz341

Is there any other reason to cause this problem? As i'm having this issue since firefox 15

Gingerbread Man
  • Top 25 Contributor
219 solutions 899 answers

Apart from browser.taskbar.lists.tasks.enabled

browser.taskbar.lists.enabled also has to be set to its default value of true

And for whatever reason, browser.taskbar.lists.recent.enabled can affect the whole jumplist.

If the above 3 preferences at their default values don't help, try toggling them one at a time and checking for a change (it should be immediate), then back again. If that doesn't help either, make sure all 3 preferences are reset back to their defaults in the end.


Lastly, if none of the above helps, the file storing your Firefox pinned jumplist items may be corrupt. You can delete it as follows:
1. Press the Windows logo orb on the taskbar.
2. In the search box, paste the following, then press Enter.

%AppData%\Microsoft\Windows\Recent\AutomaticDestinations
3. In the Windows Explorer window that opens, delete the file named
969252ce11249fdd.automaticDestinations-ms

4. If the above file is missing, then you either don't have any items pinned to the Firefox icon, or you don't have a release version but one of the test versions (beta, aurora, or nightly). In the latter case, you can find out which one is the appropriate file by pinning an item to the icon, then sorting the files in the folder based on Date Modified.

Question owner

Tried toggling 3 of them but nothing change either immediately or after restart the browser.

I don't have any items pinned on the Firefox icon, and the version that i'm using which the latest 17.0.1 yet it download from official site. As mentioned above i uninstall and reinstall it.

So i try to pin some items to the Firefox icon, it do appear when right click (right context menu) firefox icon on taskbar. But my issue still remain, right context menu is missing of "Enter Private Browsing" "Open new tab" and "Open new window" options.

webweweave 0 solutions 2 answers

I have repeatedly taken ALL the steps suggested and the truth is that the options appear and disappear seemingly at random in FF17.0.1. I thought I was on to something when I cleared the cache because the right click options then appeared immediately afterwards. However, in the several days since, the options have come and gone without my doing anything in particular to remedy the problem. That is, I have been opening or closing FF, restarting PC, deleting the AutomaticDestinations file, emptying the cache, clearing history, or simply doing nothing fancy but using FF and going about my business reading emails, searching Google, looking at Facebook, etc. One moment they are not there (shows only Mozilla Firefox, Unpin this program from Taskbar, and Close), and then next moment, these plus the private browsing options and recent history jumplists are all present and accounted for.

What the devil is going on?

Gingerbread Man
  • Top 25 Contributor
219 solutions 899 answers

webweweave wrote:

next moment, these plus the private browsing options and recent history jumplists are all present and accounted for.

Firefox's jumplist doesn't display your recently visited pages by default. Like I said above, browser.taskbar.lists.recent.enabled seems to affect the whole jumplist for no apparent reason. Therefore, if you've configured that preference, you can probably expect bugs — it may be why it's set to false by default in the first place.

Have a look at the attached screenshot. As you can see, I can reproduce and fix the problem described in this thread by following these steps:

Part I

  1. Right-click the taskbar and choose Properties.
  2. Click the Start Menu tab.
  3. Check “Store and display recently opened items...” (which was unchecked before).
  4. Click the OK button.
  5. In about:config, switch browser.taskbar.lists.recent.enabled to true. Presto, instant botched jumplist.

Part II

  1. In about:config, right-click browser.taskbar.lists.recent.enabled and choose Reset. Jumplist back to normal, complete with frequently visited pages.

Part III

  1. Right-click the taskbar and choose Properties.
  2. Click the Start Menu tab.
  3. Uncheck “Store and display recently opened items...” (which was checked before).
  4. Click the OK button. Jumplist still normal, frequently visited pages appropriately no longer showing.
webweweave 0 solutions 2 answers

Hi Gingerbread_Man, Thanks for your note as it was very helpful to understanding the behavior of the jumplists/recent items. It gave me a good insight in further understanding the issue at least regarding the jumplist/recent items. But the problem being addressed in this Forum question was really about the presence/absence of the open new tab, open new window, and private browsing Tasks portion of the menu resulting from the right-click on the Firefox icon in the Windows Taskbar.

I'm sorry if I confused the issue by mentioning the jumplist items as well as the Task items. The problem is really with the right-click the taskbar firefox icon to get to private browsing.

Since making my posting of 12/8/12 I completely uninstalled FF 17.0.1 and all of its components and profiles etc etc and installed FF 16.0.2 and so far the problem of the missing Task menu items has not occurred again. Of course, one has to block FF from automatically updating itself, which isn't really desirable, but in the interests of figuring out if the issue is related only to v17.0.1 (which seemed to be the case for me) I have disabled the automatic update. Time will tell whether v17 is the problem or if it also occurs in v16 (which I had not previously observed when I used v16).

Regards,

  Webweweave
bugged 0 solutions 1 answers

I have this problem as well with Firefox 17.0.1

It seems to randomly not display those 3 options on the jumplist. At first I thought it was related to the number of windows open or opening new windows. I may have had this issue in Firefox 16 as well

jstavene 0 solutions 1 answers

Hello I too have this problem but more severe? can find nothing under the tools menu for private browsing? (I did not remove this option but am suspicious a hack or other user? I checked addons and plugins nothing even from safe mode seems to have been changed?)

Modified by jstavene

Gingerbread Man
  • Top 25 Contributor
219 solutions 899 answers

Helpful Reply

Hello,

jstavene wrote:

can find nothing under the tools menu for private browsing?

Then it's not the same issue.

If Firefox is set to Never remember history, then you're in “permanent private browsing” mode, in which case the menu item Stop Private Browsing will be grayed out. Perhaps that's the case, and you don't find the menu item easy to see?

If that's not the case, then menu items can be hidden using the userChrome.css file. Check if it exists, and if it's there, rename it, then restart Firefox.

In Firefox Nightly (what will become Firefox 20), per-window private browsing has been added, so the menu item under the Tools menu is gone. It's been replaced by New Private Window under the File menu. I don't suppose it's very likely that you're using such a cutting-edge test version of Firefox though.

If that doesn't solve the problem, since it's a different issue, it would be best if you would ask a new question.

Anita 1 solutions 3 answers

Helpful Reply

I was having the problem with missing conceptual menu items missing with FireFox 20.0.1. Changing the name of the UserChrome.css worked for me.

WatchinIt 0 solutions 1 answers

I regained use of the right-click conceptual menus by setting browser.taskbar.lists.enabled to FALSE. The recovered menu items include: open link in new tab, open link in new window, open link in new private window....