X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Text is always bold in Gmail and Google search in Firefox 17, why?

Posted

Title. I've tried reinstalling the Arial font and that didn't work. I only noticed it when I updated to 17, so that must've been it. It is really annoying. How can I fix this?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • iTunes Detector Plug-in
  • 5.1.10411.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
4
browser.search.update
false
browser.sessionstore.restore_on_demand
false
browser.startup.homepage
http://www.google.com/
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
extensions.lastAppVersion
17.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1353529756
places.history.expiration.transient_current_max_pages
98742
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) HD Graphics
Vendor ID
0x8086
Device ID
0x0046
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version
8.15.10.2622
Driver Date
1-10-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

dumdidadida 172 solutions 1436 answers

Hi,

You can try pressing Ctrl + 0 (zero) on the keyboard when on a problematic page.

Page zoom

Keyboard shortcuts

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

Question owner

Neither of these solutions have helped so far. Any other suggestions? This is really irritating.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

This can be a problem with the font that is used to display the text.

You can use this extension to see which fonts are used for text that is selected (right-click context menu: Show fonts in selection).

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

Helpful Reply

Well, I tested Arial, and everything came out bold on every page I tried when I unchecked the box you described above in options. I've already reinstalled it, what do I do now? Thanks.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Did you verify that Firefox is using the regular Arial font and not a bold variant?

Does this still happen if you temporarily remove other Arial fonts?

Did you refresh the currently installed Arial font or downloaded a fresh file or restored it from the installation DVD ?

Question owner

I turned off the setting that websites can choose their own font, then set my default to Arial, and everything was bold. I think that answers the first question.

How do I temporarily remove other Arial fonts?

I downloaded a fresh Arial font.

echteinfachtv 0 solutions 1 answers

"This has been fixed with the Release of Firefox 17.0.1 today :)"

Edit: Nope, I was wrong :(

Modified by echteinfachtv

Helpful Reply

Anyone? This is REALLY annoying, Mozilla.

Tahoua 0 solutions 3 answers

I had this problem for about a year, and just stumbled on a solution that worked.

Check your Arial font files. You are probably missing Arial Regular font (arial.ttf) If so some programs like Firefox will default to Arial Bold others like MS Word will default to Arial Italics. In any case, you will need to restore the arial.ttf file.

You can either use your system restoration or you can download an update file from Microsoft at: http://www.microsoft.com/en-us/download/details.aspx?id=16083

Question owner

Still didn't work...any other suggestions?