X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 17 is not retaining cookie settings.

Posted

Firefox 17 is not retaining cookie setting for websites. Besides removing all existing exceptions I had, it will no longer retain exceptions for cookies. I have the basic cookie setting as unchecked for accepting cookies (that is the default is not to accept cookies), but when I add an exception, it does not retain it when I close my browser. This is very serious stuff. I will have to move from my beloved Firefox to something that *does* work. I can't believe you haven't been flooded with complaints. Or maybe you have.

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.5 r502
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Windows Activation Technologies Plugin for Mozilla

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Windows 7 Premium. Just got the 17 update today. Now nothing works...well, some sites will work and others wont but this sucks.

Question owner

Hello Matt_G--

There is not much to say "clear and crisp." This is Axis who started this thread. For a second time I tried a completely fresh installation, during installation I re-imported back to Firefox 17 what I had imported to Chrome from Firefox when I first downloaded chrome. (A while ago...bookmarks, history and cookies). I added the toolbar so I could see the preferences, etc., menu. Set it up the way I had previously had, no password manager, not to accept cookies, I think I disabled smooth scrolling and hardware acceleration. I then went to one of my own sites, made an exception through the page info tab, entered my PHPBB and I was "logged in" to my surprise. Clicked the PHPBB's ACP to get to administration. Was shown a completely blank page. Went back to the User index and was logged-out. This is exactly what happened the last time I tried a fresh install. Firefox would not retain exception permissions. I had not installed any add-on except those installed by default in a fresh installation.

As I said above, I am on Windows 7 Premium, and running Microsoft Security Essentials as anti-malware, anti-virus. I am sorry to say that there is nothing clear and crisp to say except making exceptions when you have set the default to not accept cookies does not work. I would provide more data but that is all I can say. My old beloved Firefox is destroyed and completely removed before both re-installation attempts.

So this is happening to me repeatedly with Firefox 17. I can't use it!

Regards and Good-luck! Axis

Stephen_C 0 solutions 3 answers

In response to Matt_G, I can say only that I had an immediate cookie problem (exceptions not being retained) when I upgraded to FF 17. When I followed the procedure recommended in the linked post referred to in my previous posting I commented out two entries. One was a line which read:

host popup 1 scheme:file

and the other was, I think, a complete red herring. I'm 95% sure the line referred to above was the problem. Unfortunately my technical knowledge is such that I have no idea from where it came or why commenting it out solved the problem. Nevertheless, I hope this is of some help.

Stephen

mvlad 0 solutions 1 answers

I have the same issue after installing firefox 17.0 on both Ubuntu and Windows. After deleting permissions.sqlite and creating new this issue disappeared. See below a difference between old file and new created. I hope this can help.

  1. sqlite3 permissions.sqlite.backup .dump |grep support.mozilla.org

INSERT INTO "moz_hosts" VALUES(4333,'support.mozilla.org','cookie',8,0,0,NULL,NULL);

  1. sqlite3 permissions.sqlite .dump |grep support.mozilla.org

INSERT INTO "moz_hosts" VALUES(16,'support.mozilla.org','cookie',8,0,0,0,0);

Colin B 0 solutions 1 answers

Thanks for all the research. I found a slightly easier solution to do the clean up that did not involve reverting the firefox version. I downloaded sqlite browser from http://sourceforge.net/projects/sqlitebrowser/. Shutdown firefox 17.0. Made a backup of my permissions.sqlite file in my profile. Opened permissions.sqlite in the browser. Did a search on contains "scheme". and fond one with "scheme:file" as expected. Deleted the row. Did a visual check for any other strange entries; none for me. Saved the changes. And firefox was fine.

I will keep the backup for a while though ;-) Colin B

dzeleznik 0 solutions 4 answers

Terrific, thanks for the clue colin!! In FF16.0.2, took a look at my cookie exceptions and noticed three that might be suspicious: scheme, scheme:about, and scheme:file. Using SQLite Manager, I searched the moz_hosts table of permissions.sqlite for "host Contains scheme". Found 4 matching rows that I deleted. You can see the screenshots I attached. I then upgraded to FF17 and everything seems to be working as expected. Very happy so far. Needless to say, I backed up the original permissions.sqlite in case I find a problem and need to downgrade again to FF16. So far so good though....

Question owner

This is Axis again...just to make everything incredibly weirder. I had tried installing FF 16.1 like others had reported but go nowhere...as reported earlier I had deleted everything when 17 first failed me so I was installing straight out of the box. Finally I installed FF 15...did not import anything from Chrome or any other browser. Set up the menu, and set my preferences. Have not yet made it my default browser. I left out maintenance and password manager, set my option to not accept cookies by default (i.e., I used the page info tab to make exceptions) and began going to my pages and making those exceptions.

Surprisingly they "held". Got most things set up and upgraded to 16.01, things still held. Thought I'd push my luck until the whole thing broke or worked and went to 17. My exceptions still work. Stranger than Science. So unless future exceptions will not work it seems I have 17 working now and unless you the FF people have changed something without changing version names, I am completely confused as to the whys of all this. Still need to see if future exceptions will hold.

Axis

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96634 answers

Only the presence of cookies with scheme:file or cookies that are otherwise corrupted usually cause this issue with the cookie exceptions not working properly.
If you didn't yet had such an exception in Firefox 15 or 16 then you won't have any problems with using that profile in Firefox 17.

Question owner

cor-el--

Whatever...with your scheme:file and corrupted cookies. This started because I had 16 and got smeared in 17.

I am only trying to show how weird this problem is. I am not going to download an add-on to manipulated databases "anywhere on my computer" to fix a browser. My box is a server as well as used as a user and is used with many browsers to check things and fix things.

I guess it is a testament to how much I like FF that I persisted this long. So far I have negotiated every exception I need to make....now that that is possible...and am about to turn FF 17 back into my default browser.

But cor-el, with all due respect, this is one of those things that seems just plain weirder than pat answers about databases and cookie corruptions as I had a "working fine" FF 16.01 and upgraded to 17 and everything stopped. Now by rebuilding from the 15 up, step by step, it does.

Twelve ways to try and fix but no definitive answer as to why it occurred in the first place.

Regards,

Axis

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96634 answers

I posted that extension to make it possible to inspect the permissions.sqlite file and not to modify its contents.

This is a bug that makes Firefox stumble over some specific entries in that database file.
If you happen to have those then you are affected by the update.
If you do not have those then you are not affected and you won't notice the loss of exceptions.

  • bug 814554 - Firefox 17 silently stops processing permissions.sqlite when rejecting rules valid under Firefox 16

(please do not comment in bug reports)

justdroppedin 0 solutions 2 answers

Update: I fixed the problem by resetting Firefox. I did this by clicking the "Reset" button after starting Firefox in Safe Mode.

Afterwards I had to reinstall my add-ons and readjust some settings, which took about 30 minutes. Luckily, bookmarks were preserved.

I am still using Firefox 17.0 with the same add-ons but somehow resetting Firefox fixed the problem. Firefox now retains cookie exceptions.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96634 answers

Deleting the permissions.sqlite file in the Firefox Profile Folder should be enough to recover from this problem.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
medman928 0 solutions 1 answers

I had the same issue.

After tearing my hair out trying to fix this issue & finally downgrading to 16.02 for a while I have finally found how to fix this problem.

It is the “scheme:file” entry in the "permissions.sqlite" database that is causing the problems.

The fix can be found here:

http://www.ghacks.net/2012/11/22/firefox-not-saving-cookie-exceptions-anymore/#comment-1689519

[quote]

Chris says: November 28, 2012 at 11:13 pm

I have a lot of permission rules so I didn’t want to lose them by deleting the permissions.sqlite file.

Based on what I read in a mozillazine topic (1) & a bug report (2), I used SQLite Database Browser Portable (3) to delete a “scheme:file” record from the permissions.sqlite database, which solved the problem for me.

quote

Modified by medman928

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

this should now be fixed in firefox 17.0.1 - for anyone still affected, please go to firefox > help > about firefox and apply the latest update... &thanks for all of you who responded in the thread & helped troubleshooting the issue!

dzeleznik 0 solutions 4 answers

I confirm that 17.0.1 and the fix for https://bugzilla.mozilla.org/show_bug.cgi?id=814554 works for me. I updated to 17.0.1 and restored my problematic ff16 permissions.sqlite. Works as expected.

jmnsouthpaw 0 solutions 3 answers

Axis and OldRacer:

As an IT professional myself, I too have a hard time swallowing the rapid lifecycle that mainstream FF follows. Stability is gold in my book when you're using a critical TOOL and not a toy (to paraphrase). Choosing FF as your browser shouldn't require an implicit contract to be willing to do post-release-QA.

You folks might want to consider looking into Firefox ESR (Extended Support Release).

To quote that landing-page:


  • Who is it for? Firefox ESR is intended for groups who deploy and maintain the desktop environment in large organizations such as universities and other schools, county or city governments and businesses.
  • Who is it not for? Individual users who always want the latest features, performance enhancements and technologies in their browser without waiting for them to become available in ESR several development cycles later.

Not much middle ground there, as the support model is conservative by the deployment model is constrictive. Clearly the "deploy and maintain [in] large organizations" statement considers the cost of a rapid release cycle as key, but isn't it also a consideration for individuals who require stability over "latest enhancements" and who cannot accept the cost of monthly upgrades? Check out the FAQ on that page.

OldRacer 0 solutions 5 answers

Thanks, jimsouthpaw. I have to laugh a little bit though:

What they are essentially saying is that there are two FF releases, a beta for individuals, and a tested version for people who actually need the thing to work reliably.

I guess they have implicitly passed judgment themselves on whether the release-of-the-week strategy produces quality results or not.

Maybe, since it's free, we shouldn't criticize. But it's really not free if it creates time-wasting problems for users. So then what?

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8005 answers

What they are essentially saying is that there are two FF releases, a beta for individuals, and a tested version for people who actually need the thing to work reliably.

The ordinary release is not intended to be a beta version !
(I must, unfortunately admit all recent releases have required unscheduled 'Chemspill' fixes)

For many large users ESR is probably suitable. Many such users probably use Firefox with a limited and approved set of applications.

Individual users however probably take advantage of the many customisations and software extensions available for Firefox. The problem in this thread is one that will have affected only some of the Firefox user base.

What would be helpful is if more of the advanced individual users would try out the Beta, Aurora and Nightly channels. More & varied real life user testing is what potentially helps Firefox in finding, reporting and solving problems before they get to the Release version.
An advanced user on one of the pre-release channels also has a secure downgrade path, whereas a user on the Release channel may only have ESR as a secure downgrade option.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96634 answers

Note that it is good practice to always have the current release installed and install beta and test versions via a custom install in their own program folder and make sure not to launch after installing, but first create a new profile.

OldRacer 0 solutions 5 answers

john99, what you are essentially saying is that if we are not participating in testing of betas, etc. we should not be complaining about broken features.

Given the nature of FF, I don't think that is a totally unreasonable position. But it does raise the question: "How do I know if my useage is outside the mainstream?" I wouldn't have thought that controlling cookies was that sort of thing, but apparently it is.

I am grateful for the product and the efforts made to produce it, but IIRC my first computer program was punched onto oiled paper teletype tape for loading. My first spreadsheet was Visicalc. My first 'net email account was on Arpanet, long before HTML. So, while getting the latest thing was fun for a while, I have long since learned that the guy out front is the one with arrows in his chest. So, betas are no longer for me. Sorry.

Thanks again.

Modified by OldRacer

jaman57 0 solutions 18 answers

This also happens in FF 18 - cookies that are supposed to be retained are not.

I tried the SQLite Database Browser tool, but found no questionable entries like the ones outlined above.

I tried deleting site preferences - no change. Tried deleting permission.sqlite. Still no change.

What this is showing up in is my online banking. It asks you to register the computer, and supposedly puts a "secure cookie" in the browser. This no longer works - everytime I have to go through the process of asking for a new code via email. This works fine in IE, and used to in Firefox. What is odder is that if I ask it to show cookies, it shows it with an expiration of Jan. 2100. But it does not seem to be accessble to FF anymore, while it used to be. Any other ideas?

Modified by jaman57