Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I set the bookmark library window to automatically close upon selecting a bookmark?

more options

I want the Bookmark Library screen to close upon clicking (activating) a bookmark in the library. When I click a bookmark, Firefox moves the browser window to the front and opens the page as it should. The problem is that it leaves the bookmark window open in the background. That takes up resources I don't want to expend. How do I get the bookmark library window to close once I've opened a bookmark instead of the bookmark library window remaining open behind the browser window?

All Replies (6)

more options

Why not use the bookmark menu? That does close when you select an item. The bookmark window is there to allow manipulation of properties of bookmarks, so that kind of behaviour would not be useful if someone wants to edit bookmarks or move them.

more options

"Why not use the bookmark menu? " Because I don't want the toolbar to puke up a drop menu with 200+ bookmarks in it or a forest of folders that I'd have to navigate. This is specifically about quick use of newly created (and unsorted) bookmarks.

I want to be able to launch the bookmark from the library screen and then have that screen close when the browser takes over. That's not an unreasonable desire imho and it is how FF used to work in the past. Minimizing clicks and navigation time/effort while reducing background resource use is the ultimate goal here. That one bit of simple functionality solves all those issues in one shot. Can FF be set to do that?

more options

Going all the way back to Firefox 3.0 versions, the Bookmarks Library window didn't automatically close when a bookmark was launched from that window. What it has always done for me is to go behind the main browser window when a bookmark was launched, not actually close the Library window.

Is the Library window now staying on top for you?

more options

"Going all the way back to Firefox 3.0 versions, the Bookmarks Library window didn't automatically close when a bookmark was launched from that window." Yes, it did.

"Is the Library window now staying on top for you?" No

I think I've laid the issue out pretty well in this thread. If this is simply something that FF is no longer capable of doing, that's fine. I can probably find other software that can do it or write a script to handle it but I wanted to see if there was just some setting I was missing. Unfortunately, It appears that I didn't.

Thanks for your assistance

more options

If you have the menu bar visible then you can do this via the Bookmarks menu.

If the menu bar is hidden then you can have a Bookmarks Menu button on a toolbar to access all bookmarks, except bookmarks in the unsorted folder.

Firefox 4+ versions have two bookmark buttons with a star in the Customize window.
One star button has a drop marker that open a Bookmark menu.
The other star button without the drop marker opens the bookmarks in the sidebar.

You can drag the Bookmarks menu button with the drop marker in the Customize window from the toolbar palette on a toolbar (e.g. Navigation Toolbar or Tab Bar or to the left side of the Bookmarks Menu Items).

You only see the Bookmarks Menu button if the Menu bar with the Bookmarks menu is hidden (View > Toolbars or Firefox > Options).
If the Bookmarks Toolbar is visible then the Bookmarks Menu button is displayed on the Bookmarks Toolbar as part of the Bookmarks Toolbar Items (bookmarks), but you can move it from the right side to the left side of the Bookmarks toolbar if the Customize window is open.
Otherwise the Bookmarks Menu button will appear on the right side of the Navigation Toolbar.

Modified by cor-el

more options

bigralphsmith has already stated that he doesn't want "a forest of folders to navigate" through.

My thought is that he has an add-on installed which is causing the Library window to close when he loads a bookmark. I suggest that he try the Firefox SafeMode, and then troubleshoot his add-ons if necessary.


Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.