X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

i can't copy translate from google traslator, ctrl-c ctrl-v don't work

Posted

I have Fixefox 16.0.2 Win7 x64 . but the same problem on Ubuntu I can't copy translate from right panel in google translator, but in other browers is fine. Ctrl-c,ctrl-v and context menu didn't help me.

Chosen solution

You can set the Boolean pref dom.event.clipboardevents.enabled pref to false on the about:config page.

  • Bug 807599 - Can't copy and paste from Google Translate since Firefox 16.0.2

(please do not comment in bug reports)

Read this answer in context 18

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Google Update
  • 5.1.10411.0
  • VMware Remote Console and Client Integration Plug-in
  • Reader Library Helper Plugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

thebigchief 1 solutions 7 answers

I'm having the same issue, which I posted about in this thread:

https://support.mozilla.org/en-US/questions/940871

Here are some more threads about copy and paste not working after the last update:

https://support.mozilla.org/en-US/questions/938242

https://support.mozilla.org/en-US/questions/940975

Hopefully, the Frefox developers will realize that this is a problem and fix it in the next update (preferably today)

dumdidadida 172 solutions 1436 answers

Also, please see this.

You can also install a Firefox add-on YesScript and temporarily Add translate.google.com via Firefox Tools (Alt + T) > Add-ons > Extensions, YesScript Options.

Modified by dumdidadida

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96759 answers

Chosen Solution

You can set the Boolean pref dom.event.clipboardevents.enabled pref to false on the about:config page.

  • Bug 807599 - Can't copy and paste from Google Translate since Firefox 16.0.2

(please do not comment in bug reports)

Question owner

dom.event.clipboardevents.enabled

This option helped me in Firefox 16 , but on other computer we have Ubuntu, this Firefox 11 and this option is absent. How can i fix bug this google translator. I haven't possibility to update firefox

peterjay274 0 solutions 3 answers

I have the same problem. If I use Google Translate I am unable to copy and paste the translated text anywhere - into a forum, to a new text document, a new Pages file.

I have tried resetting Firefox, to no avail. I have no Add-Ons. I don't have this issue using Safari.

It has started recently, I believe with the recent update of Firefox.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96759 answers

Helpful Reply

If you can't use the dom.event.clipboardevents.enabled pref then try to hold down Ctrl+C until the translate selection disappears and the text on the left starts flashing.

peterjay274 0 solutions 3 answers

Thank you cor-el, that has helped me.

Regards, peter

TheTexan1984 0 solutions 4 answers

I am having this same issue!

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Hi TheTexan1984, this seems to be an incompatibility with the scripts on Google Translate. Two workarounds have been documented in this thread, and a third in another thread. To summarize:

Hold Ctrl+c

Holding Ctrl+c seems to bypass or overload the script. Hold Ctrl+c until the large textbox to the left starts flashing, which may take 5-7 seconds.

Disable sites from intercepting clipboard commands

You can prevent websites from intercepting and/or canceling cut/copy/paste actions by changing a setting in the about:config preferences editor. Unfortunately, this is a global setting, so if some site is doing something positive by intercepting and canceling or replacing your cut/copy/paste action, you will lose that benefit. Still, if this Google translate problem is a major issue for you, it's probably worth a try.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste clipb and pause while the list is filtered

(3) Double-click dom.event.clipboardevents.enabled to switch its value to false. You're done with this tab.

You might need to reload the Google translate page in order for this to take effect.

Use a bookmarklet to copy the translation text

Instead of using Ctrl+c or right-click>Copy, you could use a bookmarklet -- a script that you save as a bookmark and click when you want to run it. This one is specific to the Google Translate site as of today (changes to the page could break it).

(1) Copy the following line of code (it's all one line):

javascript:void(window.prompt("Copy translation result (e.g., Ctrl+c Enter):",document.getElementById("result_box").textContent));

(2) Right-click the Bookmarks Toolbar and choose New Bookmark

(3) Paste the code in as the Location

(4) Name the bookmark as you wish (for example, CopyGoogTrans)

Now, to copy, instead of selecting the result text, click the bookmark and follow the instructions.

rvmanmb 0 solutions 1 answers

Hey Fellow Google Translators!!

I Hear You and I was also having the same problems that You are now having with trying to copy & past a Google Translation using Firefox!!! But just between You and Me, I don't believe this is because of Mozilla latest Up-Date, but rather that Google is Blocking the copy/past routine when in Using Firefox!!! For after all, the copy/past routine is working within ALL OTHER BROWSER'S, just not Firefox and We all know that Firefox is far, far better than "Chrome"!!! Yet again, when visiting the Google Translator via of Firefox or any other Browser other than Chrome, We all get this most annoying pop up window that say, "Try a new browser with automatic translation. Download Chrome Now or Dismiss" Well since the Google Translator Web Page knows which browser that we are using, I'm putting my last dollar on this one, It's not Mozilla Firefox's latest up-date, but Google that is blocking the coping and pasting routine of their translation via of Firefox!! And if this is true, this has got to be an all time NEW LOW for Google!!!

However, I have two ways to over come this problem for all of You and they both work!!! Solution #1, rather than just highlighting the translation within a Firefox Browser and then trying to copy it, if You highlight the (3) buttons above the translator box along with the translation and then select copy and then paste it into a "Note Pad", this does work!!! And While you will not see the (3) buttons, they are there, so just re select just the translation from "Note Pad" and then paste it where You would like it!! And while I agree this extract step is more or less a big pain in the You know what, it does work to over come this problem be it Via Firefox's latest up-date or Google Blocking it!!! Solution #2, and if it is Google Blocking this one, your going to love this one, I'm now using the Bing Translator, it works the same way that the Google Translator Works within Firefox, with the exception that you CAN COPY AND PASTE the translation with no problem!!! Hoping this information is if of some help...(Brent)

peterjay274 0 solutions 3 answers

Thank you jscher2000, I have made a bookmark of your Javascript solution and will see how it goes.

Thank you also, rvmanmb, I have added a bookmark for the Bing Translator.

Regards, peter

thebigchief 1 solutions 7 answers

This seems to be working correctly after updating to the newest flash player this morning.

creeem 0 solutions 11 answers

For me it does not work on Google+ so I came here looking for a solution I just upgraded 20 and restarted my browser.

1. NO my "match case" is not checked.(BTW you can access it from the edit menu>>Find.) 2. I have the latest version. 3. All control function are not working in google plus Strangely it works here(EDIT it does not work here. What It just pastes whats in my clipboard. It does not copy new text from this very page) These keys are working with other browsers and otherwise on the PC. Its not like the page or extension is disabling the control F,A,V,C function cause it works in the address bar and search bar on the google plus page Also TAB does not work anywhere Even in the address bar

There is a serious problem here with 20. update but all I see is denial of any problem. The standard response is "uncheck the match case". Its like a unreliable Internet service provider who know their Fiber is down simply tells the customer who call in to change some network setting and restart the computer so they can buy some time before the problem gets fixed

Modified by creeem

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Hi creeem, you are replying to a post from November 2012, so no one was even thinking about Firefox 20 at that time, much less denying anything.

This thread was about copying and pasting from Google translation results, but you are referring to Google+. Could you give the URL of the page that is causing problems for you? If it's not Google translation, I suggest actually starting a new question and including your system information.

https://support.mozilla.org/en-US/questions/new/desktop/websites


First, though, you might try this general advice: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r (Mac: Cmd+Shift+r) to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced
(Mac: Firefox > Preferences > Advanced)

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove your google.com cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In that dialog, you can remove the individual cookies.

Then try reloading the page and logging in again. Does that help?