X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I cannot remove search.babylon.com as the search engine for the mozilla firefox start page

Posted

I've almost completely removed search.babylon, but cannot get the last bits of it to leave. Search.babylon remains the default search engine of the about:home page for firefox, and no mater how many times I reset the babylon entries in about:config, they just go back babylon afterwards.

I know that there are a lot of people having problems with Babylon, and lots of answers. I've tried every suggestion I could find, without success.

The things I've tried:

1. Babylon toolbar was never in my firefox extensions, so there's nothing to remove there. 2. I've uninstalled Babylon via the windows control panel. 3. I searched the entire C drive for any file containing the word babylon and deleted both the files and the containing folders. 4. I've removed search.babylon from my "manage search engines" list. 5. I've reset my home page. 6. I've reset every result containing "babylon" in about:config about a dozen times. 7. In the web developer scratchpad I executed "javascript:{localStorage["search-engine"]="{\"name\":\"Google\",\"searchUrl\":\"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a\"}";void(0);}" 8. Thoughout this process I've restarted firefox countless times.

Nevertheless, whenever I open a new tab or page, and try and use the search on about:home (the default mozilla home page, with the firefox logo in the center and "Downloads, bookmarks, history, addons, sync, settings" at the bottom), I'm taken to search.babylon.com

Chosen solution

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Read this answer in context 5

Additional System Details

This happened

Every time Firefox opened

This started when...

Unsure

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 4.1.10329.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

See description

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Chosen Solution

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Question owner

That did it! Thank you!

Babylon.Ltd 3 solutions 52 answers

amfeuertein Please try the follow :

Go to Control Panel, click Programs (software).

Uninstall "Browser Manager" + "Bprotector" + "Object Installer" + "Babylon Toolbar on IE"

> Open a new Firefox window (website)

> Go to Tools> Options> and go to change your order, the Home. ( f.e www.google.de) and click OK.

> Remove the search engine of Babylon by clicking the small arrow next to the icon of Babylon

> Manage Search Engines

> select Babylon and Remove

> Close Firefox and open again

> write in the address Bar "about:config " and click Enter

> Write in the search engine "Babylon."

> Click on any 'Babylon' preferences with the right mouse button and select "Reset"

In the following video you can see how to change TAB URL :

http://www.youtube.com/watch?v=4yPX-ZJ5fQc&feature=related


Restart your Computer and see if it worked

for more info you can click here :

http://www.babylon.com/uninstall_search/firefox

Cheers Babylon Support

ChiloMata863 0 solutions 2 answers

I cant see the reset option when I right-click Right-click the browser.startup.homepage_override.mstone on step 3.

ChiloMata863 0 solutions 2 answers

Plz help I want to get rid of babylon search engine and the home page for babylon

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Check the browser.search.defaultenginename pref on the about:config page and make sure that it is set to the default value Google.

Babylon.Ltd 3 solutions 52 answers

Remove Toolbar (from Extensions)

1. Open Mozilla Firefox. Go to FF menu button.

2. Select Add-ons & than select Extensions. (delete excess text)

3. Remove/Disable the Babylon Toolbar 1.5.0.

4. Restart your browser.

Remove Toolbar (from Add/Remove Programs)

1. Click the Start button on your computer.

2. Select Add-ons & than select Extensions. (delete excess text)

3. Select Programs and Features.

4. Select Babylon Toolbar from the Programs list.

5. Right click to uninstall.

6. Press YES on the popup message.

Remove Search Provider

1. Open Mozilla Firefox. Click on the Search bar, located on the right side of your address bar

2. Press the F4 key and select Manage Search Engines from the drop down list that appears.

3. Select Search the Web (Babylon) and click on the Remove button.

4. Click OK to save your changes.

Remove/Change Home Page:

5. Open Mozilla Firefox. Click on the FF menu button.

6. Select Options.

7. Now select the General tab.

8. In the section of the popup labeled "Home Page," insert the URL of your desired Home Page.

9. Click OK to save the changes.

Remove Babylon Search from New Tab

If when you open a new tab in Firefox, Babylon Search still appears:

1. Type in the address bar line about:config and press enter.

2. Confirm the popup message.

3. In the search field, type "browser.search.selectedEngine". (remove excess text here)

5. Restart your Browser.