X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why is Firefox lagging so badly and performing so slowly? Reset did absolutely nothing.

Posted

I have Firefox 16.0.1, and as of lately, it's become too unbearably slow for me to continue using it. Even when typing this message, at certain points it will lag. When switching to new tabs or clicking links, it lags HORRIBLY. At least 4-5 seconds of wait time. And now it's started to screw up my enjoyment of YouTube videos by lagging when scrolling down the page (as it does with other sites) and lagging the video itself. I've tried the reset feature. That did absolutely nothing for me.

The only add-ons that I have are AdBlock Plus 2.1.2 and the FTDeepDark 4.8.3 theme. And I've already tried disabling (even removing) them to no avail.

What must I do for Firefox to run properly and quickly? I've been a huge fan up until now, and I'm seriously fed up with it. I have a very quick laptop (Win7, i7920XM, 8 gigs of DDR3, 256GB SSD, dual 5870 GPUs, etc.), and Firefox has always run great up until the past few month.s

Additional System Details

This happened

Every time Firefox opened

This started when...

A few months ago.

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Google Update
  • VLC media player Web Plugin 2.0.2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • 4.1.10329.0
  • Facebook Video Calling Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24386 answers

Try the Firefox SafeMode to see how it works there.
When in Safe Mode...

  • The status of plug-ins is not affected.
  • Custom preferences are not affected.
  • All extensions are disabled.
  • The default theme is used, without a persona.
  • userChrome.css and userContent.css are ignored.
  • The default toolbar layout is used.
  • The JIT Javascript compiler is disabled.
  • Hardware acceleration is disabled.

A troubleshooting mode, which disables most Add-ons.
(If you're not using it, switch to the Default Theme.)

  • You can open the Firefox 4.0+ SafeMode by holding the Shft key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item, click on Restart with Add-ons Disabled... while Firefox is running.

Don't select anything right now, just use "Continue in SafeMode."

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

Try to disable hardware acceleration in Firefox.

Question owner

Running in Safe Mode resulted in less lag at the beginning, but over the course of a few minutes of browser use, it started lagging more and more.

Running with Hardware Acceleration disabled seemed like it was working somewhat at first, but soon went back to lagging just as bad as before.

Modified by Revartr

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

bnikolai 0 solutions 1 answers

I'm also having lag problems with the latest version of Firefox ... I'm running XP with a second monitor (primary monitor is a laptop screen). My issue is this: when I open Firefox in the second monitor, it (i.e., the cursor) lags badly, especially when mousing-over links on web pages. However, Chrome works very well on the same monitor and both Chrome and Firefox work fine on the laptop screen. This is a bizarre problem ... not sure what I can do about it. (It's bad enough that I think I will at least temporarily switch to Chrome.)

mayamiabi 0 solutions 1 answers

I am also having this issue with the latest version (18.0.1). I do have a fair amount of tabs up, but much less than usual and never had an issue. There is no issue with flash (I have nothing with flash up in the first place). But for some reason, it starts just lagging like crazy out of nowhere. I have tried one of the solutions given through the support pages that says to rename one of the files--while this works...it only works temporarily. It's not long until it starts lagging ridiculously bad again.

It isn't even anything with my computer. Other browsers are fine, games are fine, literally the ONLY thing lagging for some reason is firefox.

eric72 0 solutions 1 answers

Firefox 20 has been doing this for me too. After a while the browser gets extremely laggy. Clearing out ALL History doesn't work. The only thing that does is to quite the browser and relaunch. Pretty inconvenient when you have to restart the app every few hours, especially when you have downloads in progress. When this happens, I usually just switch to Safari or Chrome to browse the internet. I may just scrap Firefox all together and stick with Chrome. No issues with Chrome (or Safari). So I know it's not my Mac Pro. It's the browser. I'm guessing it some sort of memory fragmentation with the browser.