X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I need to change the search engine that the Firefox homepage search bar uses

Posted

I installed the Anti-virus program AVG not too long ago. When I open up Firefox (I have the default homepage, the one with a search bar under the Firefox symbol) and search with the search bar, It uses AVG Secure Search. I would like it to search with Google. I tried installing and then uninstalling AVG Secure Search, that didn't work. I even tried uninstalling AVG itself, but when I clicked uninstall nothing happens. But I'd like to solve my searching problem first. Please help me!

Chosen solution

I'm pretty sure AVG Secure Search is an optional component that you could remove or disable without changing your antivirus.

I've adapted the following from a post in AVG's forums on removing AVG Secure Search. Apparently it gets into several places. You might not need all of these different changes. Does this work?

(1) Firefox search bar / search box

  • Click the small arrow next to the search provider icon and select Manage Search Engines…
  • Select the AVG Secure Search and click Remove

(2) If AVG Secure Search has made itself your home page, you can change that here:

orange Firefox button or classic Tools menu > Options > General

(3) Firefox address bar or home page search

  • In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.
  • In the filter box, type or paste search and pause while the list is filtered
  • Right-click browser.search.defaultenginename and choose Reset.
  • In the filter box, type or paste keyword and pause while the list is filtered
  • Right-click keyword.URL and choose Reset.
  • In the filter box, type or paste startup and pause while the list is filtered
  • Right-click browser.startup.homepage_override.mstone and choose Reset.

Note #1: You might have to restart Firefox before these changes take full effect.

Note #2: If you have AVG software installed on your computer, it could put these changes back into Firefox, so check your AVG software and make sure you've turned that off.

Read this answer in context 17

Additional System Details

This happened

Every time Firefox opened

This started when...

I installed AVG

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Nexon Game Controller
  • Pando Web Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 4.1.10329.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Sorry, I'm not sure what to put here.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Chosen Solution

I'm pretty sure AVG Secure Search is an optional component that you could remove or disable without changing your antivirus.

I've adapted the following from a post in AVG's forums on removing AVG Secure Search. Apparently it gets into several places. You might not need all of these different changes. Does this work?

(1) Firefox search bar / search box

  • Click the small arrow next to the search provider icon and select Manage Search Engines…
  • Select the AVG Secure Search and click Remove

(2) If AVG Secure Search has made itself your home page, you can change that here:

orange Firefox button or classic Tools menu > Options > General

(3) Firefox address bar or home page search

  • In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.
  • In the filter box, type or paste search and pause while the list is filtered
  • Right-click browser.search.defaultenginename and choose Reset.
  • In the filter box, type or paste keyword and pause while the list is filtered
  • Right-click keyword.URL and choose Reset.
  • In the filter box, type or paste startup and pause while the list is filtered
  • Right-click browser.startup.homepage_override.mstone and choose Reset.

Note #1: You might have to restart Firefox before these changes take full effect.

Note #2: If you have AVG software installed on your computer, it could put these changes back into Firefox, so check your AVG software and make sure you've turned that off.

Question owner

THANK YOU SO MUCH!!!!! This help alot!

Question owner

"helped" alot