X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

FireFox won't let me right click to edit bookmark names

Posted

I recently bought a new computer and downloaded FireFox. When adding my favorite sites to my bookmark, the names are automatically added. They're too long, and I'd like to edit them, however FF isn't letting me right click to edit the name.

When I right click, it just goes to that bookmark as if I used left-click. The right click on the computer itself works, but not when trying to edit anything in a toolbar.

Any suggestions?

Chosen solution

Un-checking the "use hardware acceleration" was the solution for me. I'm able to right-click on those bookmarks now.

Thank you!

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPWLPG
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • 4.0.50401.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24389 answers

Try the Firefox SafeMode to see how it works there.
When in Safe Mode...

  • The status of plug-ins is not affected.
  • Custom preferences are not affected.
  • All extensions are disabled.
  • The default theme is used, without a persona.
  • userChrome.css and userContent.css are ignored.
  • The default toolbar layout is used.
  • The JIT Javascript compiler is disabled.
  • Hardware acceleration is disabled.

A troubleshooting mode, which disables most Add-ons.
(If you're not using it, switch to the Default Theme.)

  • You can open the Firefox 4.0+ SafeMode by holding the Shft key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item, click on Restart with Add-ons Disabled... while Firefox is running.

Don't select anything right now, just use "Continue in SafeMode."

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.

If it is good in the Firefox SafeMode, your problem is probably caused by an extension, and you need to figure out which one.
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

When you figure out what is causing that, please let us know. It might help other user's who have that problem.

Question owner

Thanks for the suggestion- I was able to edit the tabs in SafeMode.

I literally just installed FF an hour or so ago, so I don't think I have any extensions or themes, but I'll play around with that to see if I can figure it out.

Chosen Solution

Un-checking the "use hardware acceleration" was the solution for me. I'm able to right-click on those bookmarks now.

Thank you!

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96699 answers

Did you try to click the yellow highlighted star at the right end of the location bar to open the Edit This Bookmark dialog?

You can also edit the names in the Bookmarks Manager (Library) if you can't do this via the right-click context menu.

  • Bookmarks > Show All Bookmarks