Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't set home page to about:blank, it keeps loading google search page

  • 11 replies
  • 7 have this problem
  • 4851 views
  • Last reply by NotTooOld

more options

After trying out a little utility, I got stuck with the Babylon toolbar and home page.... Yes... I didn't spot the little checkpoint to disable installation... Without any problems, I managed to remove all that... But since then, I can't get my home page to stay set to about:blank.... it keeps starting with the Google search page. I did manage to link the homepage button to about:blank, but when I add a new page (by clicking the + next to the most right tab) I keep getting the Google search page... Thanks in advance. Lody J. Claessen

Chosen solution

hello l.j.claessen, please perform the following steps - they should remove the remaining bits of babylon:

  • go to firefox > help > troubleshooting information > profile folder - "show folder", then a new window will open up. in this window look out for a file named user.js, delete or rename this file and restart firefox afterwards. this will get rid of the file that is overwriting your custom set homepage.
Read this answer in context 👍 3

All Replies (11)

more options

Chosen Solution

hello l.j.claessen, please perform the following steps - they should remove the remaining bits of babylon:

  • go to firefox > help > troubleshooting information > profile folder - "show folder", then a new window will open up. in this window look out for a file named user.js, delete or rename this file and restart firefox afterwards. this will get rid of the file that is overwriting your custom set homepage.
more options

If you have removed the rogue software you now need to reset the Firefox settings that will have been messed up:


I do not think the SearchReset deals with the user.js and that could need attention if it has been modified or created unecessarily, but try the SearchReset first of all.

The user.js file may be used to reset firefox preferences, and sometimes that is the cause of a preference resetting itself unexpectedly.

more options

Hey Madperson... Brrrilliant...your suggestion did it right away. Thanks a million.! LodyJ

more options

Note that you have the Browsing Protection extension installed and that extension will most likely block changes to some of the prefs that you try to change, so check that out if you can't make a permanent change.

more options

Hi Co-rel, You're that I have Browsing Protection installed... But I switched it off, some time ago. Thanks anyway. Regards LodyJ

more options

I have the same exact problem, but I don't have a Babylon toolbar or a user.js file. SearchReset didn't solve the problem but didn't kill my extension either.

I'm using Ubuntu 10.04 LTS - the Lucid Lynx and Firefox 20.0

perf.js parameters:

user_pref("searchreset.backup.browser.startup.homepage", "about:blank");user_pref("browser.startup.homepage", "about:blank");

user_pref("browser.startup.homepage_override.buildID", "20130329042733");

user_pref("browser.startup.homepage_override.mstone", "20.0"); user_pref("browser.startup.page", 3);

user_pref("pref.browser.homepage.disable_button.bookmark_page", false);

user_pref("pref.browser.homepage.disable_button.restore_default", false);

user_pref("toolkit.startup.last_success", 1365644389);

What is going on here?

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
more options

I started in safe mode (all extensions and themes disbled). No change. My home page setting still said about:blank.

I started in normal mode after manually disabling all extension but left default theme enabled. No change

https://support.cdn.mozilla.net/media/uploads/images/2013-04-10-21-30-59-aa597c.png

Also, the web sites displayed haven't changed for at least two or three days .. hmmm!

more options

I found that "New Tab" has an icon to toggle the web site display on and off here https://support.mozilla.org/en-US/kb/new-tab-page-show-hide-and-customize-top-sites. Problem "solved" except that about:blank should display a blank page! Grrr!

So tell me it's a feature and not a bug :)

more options

Hi NotTooOld

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)

You seem to have two issues:

  • the New tab page (pref: browser.newtab.url)
  • the home page (pref: browser.startup.homepage)

If you set one or both those prefs to about:blank then you should get a blank page.

You can hide the content on the new tab page via the 3x3 grid icon in the top right corner like you've noticed (pref: browser.newtabpage.enabled).
This will have the new tab page present in a new tab and this is not about:blank as you can see in the page code (right-click: View Page Source).

more options

Bingo, cor-el. I opened another browser window, put about:config in the url bar. and set the New tab page (pref: browser.newtab.url) to about:blank instead of about:newtab.

The home page (pref: browser.startup.homepage) was set to about:blank, but it looks like that's not enough.

BTW,when I first opened the new window to edit config, New Tab was blank (no toggle icon). Curious, I opened another New Tab, but it had the toggle icon.

Solved! Like the fictional detective Hercule Poirot, you used the "little gray cells" to solve the case!

Thank you.