X
Tap here to go to the mobile version of the site.

Support Forum

When I open Facebook in Firefox, I can't view messages or use the drop-down menus in the top toolbar.

Posted

These problems only occur when I access Facebook in Firefox. The same problems don't occur in Chrome.

I can view my Facebook message inbox, but when I try to open a message/message thread, it doesn't load. I just see the loading icon.

Similarly, if I try to use the icons in the top menu bar (notification icons on the left, arrow on the right), I don't get a drop-down if I click on them. If I click the notification icons on the top left, I should get a drop-down showing the recent activity, but instead it just switches to the icon showing that I don't have any new activity. If I click the arrow on the right, I should get a drop-down with account options, but instead it just takes me straight to the "General Account Settings" page.

These problems only occur when I access Facebook in Firefox. The same problems don't occur in Chrome. I can view my Facebook message inbox, but when I try to open a message/message thread, it doesn't load. I just see the loading icon. Similarly, if I try to use the icons in the top menu bar (notification icons on the left, arrow on the right), I don't get a drop-down if I click on them. If I click the notification icons on the top left, I should get a drop-down showing the recent activity, but instead it just switches to the icon showing that I don't have any new activity. If I click the arrow on the right, I should get a drop-down with account options, but instead it just takes me straight to the "General Account Settings" page.

Modified by fordprefect

Chosen solution

You need to go to Privacy Show cookies, then search for Facebook.

Shift-select all Facebook cookies and click Remove Cookies, Not Remove ALL.

Then click on exceptions, type in facebook.com and set to allow

Read this answer in context 13

Additional System Details

Sites Affected

http://www.facebook.com

Installed Plug-ins

  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • 5.1.10411.0
  • iTunes Detector Plug-in
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

dumdidadida 155 solutions 1440 answers

Hi,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

If the problem persists, you can also try to Disable all the plugins except Flash and Java to check.

Did this fix your problems? Please report back to us!

Hi, The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: ''This will cause you to lose any Extensions, Open websites, and some Preferences.'' To Reset Firefox do the following: #Go to Firefox > Help > Troubleshooting Information. #Click the "Reset Firefox" button. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. Further information can be found in the [[Reset Firefox – easily fix most problems]] article. If the problem persists, you can also try to '''Disable''' all the plugins except Flash and Java to check. Did this fix your problems? Please report back to us!

Question owner

Thank you for the response.

I probably should have mentioned: this problem occurs on multiple computers (my home computer and two different work computer), which led me to believe it was an issue with Firefox generally rather than with my individual machine.

dumdidadida's suggestion didn't exactly solve my problem, but allowed me to isolate the reason it is happening.

After I reset Firefox, I immediately visited Facebook and everything worked properly (drop-down menus, messages, etc.). I thought, "Great, problem solved!" and then went into Tools > Options to set up Firefox with my usual settings. After doing this, I went back to Facebook and it no longer worked properly.

Long story short, I went through all of my settings carefully and discovered the one setting that makes the difference in how Facebook works. Under Tools > Options > Privacy, you can choose how your browser accepts cookies or not. If you choose to accept cookies, you can also choose how long your browser stores them, using the "Keep until" drop-down menu. I discovered that if I choose "Keep until: they expire," Facebook works properly, but if I choose "Keep until: ask me every time," Facebook does not work properly-- even if, when prompted, I choose to allow cookies from www.facebook.com.

Now that I've identified this cookie setting as causing the Facebook issue, I'm assuming there isn't an easy fix-- I can either choose "Keep until: they expire" or I can just choose to use Chrome when I want to use Facebook.

A question for someone who knows more about computers than I do: is this a problem that could be solved by Facebook making changes to their website, or is this a problem that could be solved on Firefox's end?

Thank you for the response. I probably should have mentioned: this problem occurs on multiple computers (my home computer and two different work computer), which led me to believe it was an issue with Firefox generally rather than with my individual machine. dumdidadida's suggestion didn't exactly solve my problem, but allowed me to isolate the reason it is happening. After I reset Firefox, I immediately visited Facebook and everything worked properly (drop-down menus, messages, etc.). I thought, "Great, problem solved!" and then went into Tools > Options to set up Firefox with my usual settings. After doing this, I went back to Facebook and it no longer worked properly. Long story short, I went through all of my settings carefully and discovered the one setting that makes the difference in how Facebook works. Under Tools > Options > Privacy, you can choose how your browser accepts cookies or not. If you choose to accept cookies, you can also choose how long your browser stores them, using the "Keep until" drop-down menu. I discovered that if I choose "Keep until: they expire," Facebook works properly, but if I choose "Keep until: ask me every time," Facebook does not work properly-- even if, when prompted, I choose to allow cookies from www.facebook.com. Now that I've identified this cookie setting as causing the Facebook issue, I'm assuming there isn't an easy fix-- I can either choose "Keep until: they expire" or I can just choose to use Chrome when I want to use Facebook. A question for someone who knows more about computers than I do: is this a problem that could be solved by Facebook making changes to their website, or is this a problem that could be solved on Firefox's end?
bwillnecker 0 solutions 1 answers

I noticed the exact same issue. For security reasons, I do not want to allow cookies to be installed automatically, which is why I choose to use the "ask me every time" option. However, with FF16 (and some versions of FF15) breaking FB compatibility (at least from my perspective), it will force me to use IETab, IE, or Chrome. Any of these three options is an inconvenience for me, as FF is my preferred browser.

Hopefully Mozilla will fix this incompatibility soon.

I noticed the exact same issue. For security reasons, I do not want to allow cookies to be installed automatically, which is why I choose to use the "ask me every time" option. However, with FF16 (and some versions of FF15) breaking FB compatibility (at least from my perspective), it will force me to use IETab, IE, or Chrome. Any of these three options is an inconvenience for me, as FF is my preferred browser. Hopefully Mozilla will fix this incompatibility soon.
SumofallPeers 1 solutions 1 answers

Chosen Solution

You need to go to Privacy Show cookies, then search for Facebook.

Shift-select all Facebook cookies and click Remove Cookies, Not Remove ALL.

Then click on exceptions, type in facebook.com and set to allow

You need to go to Privacy Show cookies, then search for Facebook. Shift-select all Facebook cookies and click Remove Cookies, Not Remove ALL. Then click on exceptions, type in facebook.com and set to allow

Helpful Reply

Thanks! I just did this, and now Facebook messaging and the drop-down menu both work.

To be honest, I'm not sure why this fixed the problem-- I had already gone into my list of exceptions and set www.facebook.com to "Allow," but for some reason adding facebook.com and setting it to "Allow" solved the problem.

Thanks! I just did this, and now Facebook messaging and the drop-down menu both work. To be honest, I'm not sure why this fixed the problem-- I had already gone into my list of exceptions and set www.facebook.com to "Allow," but for some reason adding facebook.com and setting it to "Allow" solved the problem.