Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Ask.com still preference search engine despite efforts to remove when google is the default

  • 6 replies
  • 7 have this problem
  • 4615 views
  • Last reply by porthome

more options

Initially, I did not request ask.com to become the default search engine and I did not ignore the box making the request. I have made the following efforts to return to google as default: Uninstalled ask.com and its automatic update, disabled all add-ons (including those that did not apply), checked extensions anything that pertained to ask.com (nothing was there), re-downloaded the latest version of Firefox, searched about:config for ask.com and reset it to default (google). On the Start Page the ask.com logo is still in the URL and a test search in the box under the logo yields ask.com results rather than google. Any additional recommendations would be helpful. At this point, I am considering the following: (1) restoring my computer to an earlier date; (2) reseting or removing firefox and reinstalling it; and (3) removing AVIRA.

Modified by hittgv

Chosen solution

Found SerchReset and installed it. No change.

I did find a simple solution for this problem. Restore the computer to an earlier date, in this case it was a month. I then uninstalled Firefox, keeping my preferences. I allowed my computer to update for a second time all of the downloads for the previous 30 days. I then checked to determine where the ask.com was loaded, and this time deselected the box. In my instance, there was a second box to deselect in JAVA. I deselected the box, downloaded the remainder of my updates, and reinstalled Firefox. Problem solved.

Read this answer in context 👍 3

All Replies (6)

more options

Hi hittgv

go to about:config, find browser.startup.homepage_override.mstone and reset it (right-click > reset) exit firefox and restart it.


then install SearchReset add-on (the add-on is not permanent uninstalls itself after what makes.


thank you

more options

"browser.startup.homepage_override.mstone" not there.

Also, I continued to read the Helpful Solutions, and tried TonyE's (3/13/2011 5:09:21 a.m PDT). It is a modification of preferences in about:config. One recommendation "keyword.URL" did not have anything under "value" heading. This is where the ask.com link should have been. I modified as instructed (as if ask.com was there) and added the Google link recommended. It did not change ask.com on the startup page. I suspect that when I uninstalled ask.com, it removed the link but no link automatically replaced it. I hope that "keyword.URL" is the only one, but since browser.startup.homepage_override.mstone, is not listed, there could be others. Unfortunately, because "keyword.URL" did not have anything listed in its "value", I cannot filter for ask.com and replace or reset. Further, recommendations and/or solutions would be helpful.

more options

try the SearchReset add-on

more options

Chosen Solution

Found SerchReset and installed it. No change.

I did find a simple solution for this problem. Restore the computer to an earlier date, in this case it was a month. I then uninstalled Firefox, keeping my preferences. I allowed my computer to update for a second time all of the downloads for the previous 30 days. I then checked to determine where the ask.com was loaded, and this time deselected the box. In my instance, there was a second box to deselect in JAVA. I deselected the box, downloaded the remainder of my updates, and reinstalled Firefox. Problem solved.

Modified by hittgv

more options

At next restart, all the old settings have been magically overwritten to their original values, and ASK is again firmly in control.

more options

After trying just about everything suggested on this and other fora, I hit upon "Firefox reset in Safe mode" - which fixed the problem!

>> Close Firefox >> Hold down shift key and click Firefox icon >> When started in safe mode, choose reset >> restart

As far as I can tell, bookmarks, saved passwords, history, and cookies were not harmed in the process.