X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox is running slow, sluggishly, websites take a long time to load, to connect. I've done everything this board has suggested.

Posted

Firefox is really starting to annoy me. Sometimes it runs slow and sluggishly, other times it doesn't. Usually it does though. When I open new tabs, the connection icon will just keep swirling. I constantly get High CPU Useage alerts from my virus protection. I've done everything listed in the below articles. Does anyone have some advice? Firefox didn't use to be like this.

Thank you.

https://support.mozilla.org/en-US/questions/864739?as=aaq

https://support.mozilla.org/en-US/questions/882138#answer-256718

Additional System Details

This happened

Every time Firefox opened

This started when...

This started in the past couple weeks.

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 4.1.10329.0
  • GEPlugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

finitarry 157 solutions 2178 answers

Have you tried this?

Question owner

Hi, thanks for replying.

I don't understand computers very well, can you explain what I do with this information please?

Thank you again.

finitarry 157 solutions 2178 answers

Some people had problems with there being too many open connections to web servers. In the window for about:config is a setting for network.http.max-connections. The suggestion was to reduce that from 256 to 48. Maybe this has already been done for Windows, though? I am using Mac OS, and the number there by default for me is still 256.

Another reason why Firefox might be slow is multiple extensions which make heavy demands on the browser. It might help to check this list:

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96833 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that works.

Question owner

I appreciate you guys trying to help, but I am severely limited when it comes to computer knowledge. I know this is probably very annoying, but can you be more specific?

I've done the things outlined in the two links I listed at the beginning, changing the thing to 48 and all.

Thank you guys a lot for taking the time to help me.

Question owner

Alright, it's getting to the point where I can barely use FireFox anymore. It's getting worse by the day, I don't understand. Web pages take a LONG time to load, but sometimes they don't....it's hit or miss. But when they do take a long time, they take a long time.

It's getting very bad. I don't know much about computers, safe mode, and all that. It would really help if someone could walk me through what to do, like they would a 10-year old... actually a 10-year old probably knows more than me. Well you get the idea.

I really want to keep using this browser, but if I don't get it fixed I will have to stop. Like I said in the initial post, I've done all the things those two links suggested. It got better at first, but now it seems like it's gotten worse.

Question owner

I mean, now my mouse cursor is flickering. Only when on the internet, if I close the internet window and go to my desktop, it doesn't flicker anymore.

Will someone please help me? Much appreciated :)

finitarry 157 solutions 2178 answers

Does this flickering happen if you start Firefox in its safe mode? If not, it could be an extension that is causing the problem.

Does the flickering happen if you disable the Adobe Flash plugin? Flash has been known to cause that. You could try different versions of Flash plugin and see if a different version cures the problem. There are a few here:

Have you tried disabling hardware acceleration? That has been known to cause slowdowns and other problems in some systems. In Options > Advanced > General, uncheck "Use hardware acceleration when available".

Question owner

Ok, I disabled "Use hardware acceleration when available."

We'll see if that helps.

Today was the worst. I couldn't even open the browser - it just kept "Connecting" ... I had to restart my computer, try several times, and then it finally opened my home page.

When I go to put it in Safe Mode, Firefox recommends the Reset Firefox feature. It says it will restore Firefox to its default factory state, and that this may be better than using Safe Mode and trying to troubleshoot on my own.

Should I use the Reset Firefox feature?

finitarry 157 solutions 2178 answers

If you reset Firefox, you will lose any custom settings that you have set up, you will lose all your extensions and themes, and basically you will be back to the same thing as a new profile. If that does not matter to you, it might be the best way to go. You should back up your bookmarks to a directory outside of the profile first.

Question owner

Ok, I reset Firefox, but the problems are still occurring:

Pages take forever to load. But not all pages, sometimes it works like it used to, and opens them fast, but 9 times out of 10 it takes way longer than it should. And I mean sometimes like a full minute to load a page ... the connecting icon will just be swirling around.

It is now taking a long time even to start up Firefox from the desktop.

I am thinking perhaps I should de-frag my computer?

It's getting to the point where I can't use the internet.

Question owner

Around the time this all started happening a few weeks ago, there were a couple of times that I received the following error message:

Microsoft Visual C++ Runtime Library

Runtime Error!

Program: C:/ProgramFiles/Norton Online/Engine/2.3.0.7/ccSvcHst.exe

R6025 – pure virtual function call.


Symantec Service Framework

Symantec Service Framework has encountered a problem and needs to close.


Could this have anything to do with the problem?

finitarry 157 solutions 2178 answers

It might have something to do with it, but I do not know enough about that to be sure. Symantec products have caused problems with Firefox in the past, and might still be causing them.

Question owner

This thread has become so long, I wonder if I should start over with a new one? I'm worried it's being pushed under the rug because it's an old thread with many replies.

??

speedyspeedy 0 solutions 1 answers

I found the problem was hardware acceleration (graphics card issue), which I was able to fix by reducing the level of hardware acceleration on my computer (unlike finitarry's solution of just disabling it altogether in Firefox).

To try this, in Windows XP right click on the desktop, select properties, settings, advanced, troubleshoot and then drag the hardware acceleration slider down to a level that works.

Modified by speedyspeedy