X
Tap here to go to the mobile version of the site.

Support Forum

After upgrading to Firefox 7, sites periodically take a very long time to load.

Posted

Ever since upgrading to Firefox 7, I've experienced an intermittent issue where, upon trying to load a site, the status bar says "Connecting...", and sits there without loading anything for several minutes. This typically happens after several minutes of normal use. During this time, Firefox is unable to connect to any site. It is also unable to check for updates. There are no error messages; it simply displays the "spinning wheel" icon and provides no further feedback.

Closing the tab where the problem initially occurred doesn't help, but completely closing down and restarting Firefox does. However, the problem typically reoccurs after several minutes of normal use following a restart.

No other application is affected. Internet Explorer, MSN Live Messenger, Thunderbird, and other network applications continue to operate normally during the period that Firefox is unable to load sites.

I do not believe that it's a firewall issue. The problem occurs even when all firewall software - including the built-in Windows Firewall - has been disabled.

Additionally, if I just let Firefox "spin" for several minutes, the problem abruptly clears up on its own, and the site I'd originally requested loads normally. As with a restart, when the problem has cleared up in this fashion, it typically reoccurs after several minutes of normal use.

Ever since upgrading to Firefox 7, I've experienced an intermittent issue where, upon trying to load a site, the status bar says "Connecting...", and sits there without loading anything for several minutes. This typically happens after several minutes of normal use. During this time, Firefox is unable to connect to any site. It is also unable to check for updates. There are no error messages; it simply displays the "spinning wheel" icon and provides no further feedback. Closing the tab where the problem initially occurred doesn't help, but completely closing down and restarting Firefox does. However, the problem typically reoccurs after several minutes of normal use following a restart. No other application is affected. Internet Explorer, MSN Live Messenger, Thunderbird, and other network applications continue to operate normally during the period that Firefox is unable to load sites. I do not believe that it's a firewall issue. The problem occurs even when all firewall software - including the built-in Windows Firewall - has been disabled. Additionally, if I just let Firefox "spin" for several minutes, the problem abruptly clears up on its own, and the site I'd originally requested loads normally. As with a restart, when the problem has cleared up in this fashion, it typically reoccurs after several minutes of normal use.

Modified by DavidJProkopetz

Chosen solution

Type about:config in the Location (address) bar and press the "Enter" key. When you see a warning, click I'll be careful, I promise! button.

-> In the Filter bar, type network.http.max-connections

  • Right click the preference network.http.max-connections and choose Modify
  • change the value to 30 or 48
  • click OK

-> Close the about:config tab

  • Restart Firefox.

Check and tell if its working.

Read this answer in context 7

Additional System Details

This happened

Every time Firefox opened

This started when...

Immediately after upgrading to Firefox 7.

Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C)

More Information

Application Basics
Name
Firefox
Version
7.0.1
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
British English Dictionary
1.19.1
true
en-GB@dictionaries.addons.mozilla.org
Canadian English Dictionary
2.0.1
true
en-CA@dictionaries.addons.mozilla.org
DownloadHelper
4.9.5
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
DownThemAll!
2.0.7
true
{DDC359D1-844A-42a7-9AA1-88A850A938A8}
Java Quick Starter
1.0
true
jqs@sun.com
User Agent Switcher
0.7.3
true
{e968fc70-8f95-4ab9-9e79-304de2a71ee1}
Web Developer
1.1.9
true
{c45c406e-ab73-11d8-be73-000a95be3b12}
AcqVPlayer for Firefox
2.0.3.11
false
AcqVPlayer@pod.tv
BullGuard Safe Browsing
1.1
false
antiphishing@bullguard
Fast Video Download (with SearchMenu)
4.1.3
false
{c50ca3c4-5656-43c2-a061-13e717f73fc8}
Java Console
6.0.06
false
{CAFEEFAC-0016-0000-0006-ABCDEFFEDCBA}
Java Console
6.0.24
false
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
RefControl
0.8.15
false
{455D905A-D37C-4643-A9E2-F6FEFAA0424A}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage_override.buildID
20110928134238
browser.startup.homepage_override.mstone
rv:7.0.1
browser.tabs.warnOnClose
false
browser.zoom.full
false
dom.max_script_run_time
0
extensions.lastAppVersion
7.0.1
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729)
network.cookie.prefsMigrated
true
network.protocol-handler.warn-external.steam
false
places.database.lastMaintenance
1317440476
places.history.expiration.transient_current_max_pages
64342
places.last_vacuum
1299793076
print.print_bgcolor
false
print.print_bgimages
false
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_pagedelay
500
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
Samsung ML-1430 Series
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
0
print.print_unwriteable_margin_left
0
print.print_unwriteable_margin_right
0
print.print_unwriteable_margin_top
0
print.printer_Samsung_ML-1430_Series.print_bgcolor
false
print.printer_Samsung_ML-1430_Series.print_bgimages
false
print.printer_Samsung_ML-1430_Series.print_command
print.printer_Samsung_ML-1430_Series.print_downloadfonts
true
print.printer_Samsung_ML-1430_Series.print_edge_bottom
0
print.printer_Samsung_ML-1430_Series.print_edge_left
0
print.printer_Samsung_ML-1430_Series.print_edge_right
0
print.printer_Samsung_ML-1430_Series.print_edge_top
0
print.printer_Samsung_ML-1430_Series.print_evenpages
true
print.printer_Samsung_ML-1430_Series.print_footercenter
print.printer_Samsung_ML-1430_Series.print_footerleft
&PT
print.printer_Samsung_ML-1430_Series.print_footerright
&D
print.printer_Samsung_ML-1430_Series.print_headercenter
print.printer_Samsung_ML-1430_Series.print_headerleft
&T
print.printer_Samsung_ML-1430_Series.print_headerright
&U
print.printer_Samsung_ML-1430_Series.print_in_color
true
print.printer_Samsung_ML-1430_Series.print_margin_bottom
0.5
print.printer_Samsung_ML-1430_Series.print_margin_left
0.5
print.printer_Samsung_ML-1430_Series.print_margin_right
0.5
print.printer_Samsung_ML-1430_Series.print_margin_top
0.5
print.printer_Samsung_ML-1430_Series.print_oddpages
true
print.printer_Samsung_ML-1430_Series.print_orientation
1
print.printer_Samsung_ML-1430_Series.print_page_delay
50
print.printer_Samsung_ML-1430_Series.print_pagedelay
500
print.printer_Samsung_ML-1430_Series.print_paper_data
1
print.printer_Samsung_ML-1430_Series.print_paper_height
11.00
print.printer_Samsung_ML-1430_Series.print_paper_size
6357095
print.printer_Samsung_ML-1430_Series.print_paper_size_type
0
print.printer_Samsung_ML-1430_Series.print_paper_size_unit
0
print.printer_Samsung_ML-1430_Series.print_paper_width
8.50
print.printer_Samsung_ML-1430_Series.print_reversed
false
print.printer_Samsung_ML-1430_Series.print_scaling
1.00
print.printer_Samsung_ML-1430_Series.print_shrink_to_fit
true
print.printer_Samsung_ML-1430_Series.print_to_file
false
print.printer_Samsung_ML-1430_Series.print_unwriteable_margin_bottom
0
print.printer_Samsung_ML-1430_Series.print_unwriteable_margin_left
0
print.printer_Samsung_ML-1430_Series.print_unwriteable_margin_right
0
print.printer_Samsung_ML-1430_Series.print_unwriteable_margin_top
0
print.printer_Samsung_ML-1430_Series_(Copy_1).print_bgcolor
true
print.printer_Samsung_ML-1430_Series_(Copy_1).print_bgimages
true
print.printer_Samsung_ML-1430_Series_(Copy_1).print_command
print.printer_Samsung_ML-1430_Series_(Copy_1).print_downloadfonts
true
print.printer_Samsung_ML-1430_Series_(Copy_1).print_edge_bottom
0
print.printer_Samsung_ML-1430_Series_(Copy_1).print_edge_left
0
print.printer_Samsung_ML-1430_Series_(Copy_1).print_edge_right
0
print.printer_Samsung_ML-1430_Series_(Copy_1).print_edge_top
0
print.printer_Samsung_ML-1430_Series_(Copy_1).print_evenpages
true
print.printer_Samsung_ML-1430_Series_(Copy_1).print_footercenter
print.printer_Samsung_ML-1430_Series_(Copy_1).print_footerleft
&PT
print.printer_Samsung_ML-1430_Series_(Copy_1).print_footerright
&D
print.printer_Samsung_ML-1430_Series_(Copy_1).print_headercenter
print.printer_Samsung_ML-1430_Series_(Copy_1).print_headerleft
&T
print.printer_Samsung_ML-1430_Series_(Copy_1).print_headerright
&U
print.printer_Samsung_ML-1430_Series_(Copy_1).print_in_color
true
print.printer_Samsung_ML-1430_Series_(Copy_1).print_margin_bottom
0.5
print.printer_Samsung_ML-1430_Series_(Copy_1).print_margin_left
0.5
print.printer_Samsung_ML-1430_Series_(Copy_1).print_margin_right
0.5
print.printer_Samsung_ML-1430_Series_(Copy_1).print_margin_top
0.5
print.printer_Samsung_ML-1430_Series_(Copy_1).print_oddpages
true
print.printer_Samsung_ML-1430_Series_(Copy_1).print_orientation
0
print.printer_Samsung_ML-1430_Series_(Copy_1).print_pagedelay
500
print.printer_Samsung_ML-1430_Series_(Copy_1).print_paper_data
1
print.printer_Samsung_ML-1430_Series_(Copy_1).print_paper_height
11.00
print.printer_Samsung_ML-1430_Series_(Copy_1).print_paper_size_type
0
print.printer_Samsung_ML-1430_Series_(Copy_1).print_paper_size_unit
0
print.printer_Samsung_ML-1430_Series_(Copy_1).print_paper_width
8.50
print.printer_Samsung_ML-1430_Series_(Copy_1).print_reversed
false
print.printer_Samsung_ML-1430_Series_(Copy_1).print_scaling
1.00
print.printer_Samsung_ML-1430_Series_(Copy_1).print_shrink_to_fit
true
print.printer_Samsung_ML-1430_Series_(Copy_1).print_to_file
false
print.printer_Samsung_ML-1430_Series_(Copy_1).print_unwriteable_margin_bottom
0
print.printer_Samsung_ML-1430_Series_(Copy_1).print_unwriteable_margin_left
0
print.printer_Samsung_ML-1430_Series_(Copy_1).print_unwriteable_margin_right
0
print.printer_Samsung_ML-1430_Series_(Copy_1).print_unwriteable_margin_top
0
print.printer_\\Debbie\Samsung_ML-1740_Series.print_bgcolor
false
print.printer_\\Debbie\Samsung_ML-1740_Series.print_bgimages
false
print.printer_\\Debbie\Samsung_ML-1740_Series.print_command
print.printer_\\Debbie\Samsung_ML-1740_Series.print_downloadfonts
true
print.printer_\\Debbie\Samsung_ML-1740_Series.print_evenpages
true
print.printer_\\Debbie\Samsung_ML-1740_Series.print_footercenter
print.printer_\\Debbie\Samsung_ML-1740_Series.print_footerleft
&PT
print.printer_\\Debbie\Samsung_ML-1740_Series.print_footerright
&D
print.printer_\\Debbie\Samsung_ML-1740_Series.print_headercenter
print.printer_\\Debbie\Samsung_ML-1740_Series.print_headerleft
&T
print.printer_\\Debbie\Samsung_ML-1740_Series.print_headerright
&U
print.printer_\\Debbie\Samsung_ML-1740_Series.print_in_color
true
print.printer_\\Debbie\Samsung_ML-1740_Series.print_margin_bottom
0.5
print.printer_\\Debbie\Samsung_ML-1740_Series.print_margin_left
0.5
print.printer_\\Debbie\Samsung_ML-1740_Series.print_margin_right
0.5
print.printer_\\Debbie\Samsung_ML-1740_Series.print_margin_top
0.5
print.printer_\\Debbie\Samsung_ML-1740_Series.print_oddpages
true
print.printer_\\Debbie\Samsung_ML-1740_Series.print_orientation
0
print.printer_\\Debbie\Samsung_ML-1740_Series.print_pagedelay
500
print.printer_\\Debbie\Samsung_ML-1740_Series.print_paper_data
1
print.printer_\\Debbie\Samsung_ML-1740_Series.print_paper_height
11.00
print.printer_\\Debbie\Samsung_ML-1740_Series.print_paper_size
6357095
print.printer_\\Debbie\Samsung_ML-1740_Series.print_paper_size_type
0
print.printer_\\Debbie\Samsung_ML-1740_Series.print_paper_size_unit
0
print.printer_\\Debbie\Samsung_ML-1740_Series.print_paper_width
8.50
print.printer_\\Debbie\Samsung_ML-1740_Series.print_reversed
false
print.printer_\\Debbie\Samsung_ML-1740_Series.print_scaling
1.00
print.printer_\\Debbie\Samsung_ML-1740_Series.print_shrink_to_fit
true
print.printer_\\Debbie\Samsung_ML-1740_Series.print_to_file
false
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_bgcolor
true
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_bgimages
true
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_command
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_downloadfonts
true
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_edge_bottom
0
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_edge_left
0
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_edge_right
0
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_edge_top
0
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_evenpages
true
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_footercenter
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_footerleft
&PT
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_footerright
&D
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_headercenter
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_headerleft
&T
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_headerright
&U
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_in_color
true
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_margin_bottom
0.5
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_margin_left
0.5
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_margin_right
0.5
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_margin_top
0.5
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_oddpages
true
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_orientation
0
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_pagedelay
500
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_paper_data
1
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_paper_height
11.00
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_paper_size
6357095
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_paper_size_type
0
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_paper_size_unit
0
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_paper_width
8.50
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_reversed
false
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_scaling
1.00
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_shrink_to_fit
true
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_to_file
false
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_unwriteable_margin_bottom
0
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_unwriteable_margin_left
0
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_unwriteable_margin_right
0
print.printer_\\Helvirahel\Samsung_SCX-4x21_Series.print_unwriteable_margin_top
0
print.printer_\\http://192.168.0.104\Printer_Name.print_bgcolor
false
print.printer_\\http://192.168.0.104\Printer_Name.print_bgimages
false
print.printer_\\http://192.168.0.104\Printer_Name.print_command
print.printer_\\http://192.168.0.104\Printer_Name.print_downloadfonts
false
print.printer_\\http://192.168.0.104\Printer_Name.print_edge_bottom
0
print.printer_\\http://192.168.0.104\Printer_Name.print_edge_left
0
print.printer_\\http://192.168.0.104\Printer_Name.print_edge_right
0
print.printer_\\http://192.168.0.104\Printer_Name.print_edge_top
0
print.printer_\\http://192.168.0.104\Printer_Name.print_evenpages
true
print.printer_\\http://192.168.0.104\Printer_Name.print_footercenter
print.printer_\\http://192.168.0.104\Printer_Name.print_footerleft
&PT
print.printer_\\http://192.168.0.104\Printer_Name.print_footerright
&D
print.printer_\\http://192.168.0.104\Printer_Name.print_headercenter
print.printer_\\http://192.168.0.104\Printer_Name.print_headerleft
&T
print.printer_\\http://192.168.0.104\Printer_Name.print_headerright
&U
print.printer_\\http://192.168.0.104\Printer_Name.print_in_color
true
print.printer_\\http://192.168.0.104\Printer_Name.print_margin_bottom
0.5
print.printer_\\http://192.168.0.104\Printer_Name.print_margin_left
0.5
print.printer_\\http://192.168.0.104\Printer_Name.print_margin_right
0.5
print.printer_\\http://192.168.0.104\Printer_Name.print_margin_top
0.5
print.printer_\\http://192.168.0.104\Printer_Name.print_oddpages
true
print.printer_\\http://192.168.0.104\Printer_Name.print_orientation
0
print.printer_\\http://192.168.0.104\Printer_Name.print_pagedelay
500
print.printer_\\http://192.168.0.104\Printer_Name.print_paper_data
0
print.printer_\\http://192.168.0.104\Printer_Name.print_paper_height
11.00
print.printer_\\http://192.168.0.104\Printer_Name.print_paper_size_type
1
print.printer_\\http://192.168.0.104\Printer_Name.print_paper_size_unit
0
print.printer_\\http://192.168.0.104\Printer_Name.print_paper_width
8.50
print.printer_\\http://192.168.0.104\Printer_Name.print_reversed
false
print.printer_\\http://192.168.0.104\Printer_Name.print_scaling
1.00
print.printer_\\http://192.168.0.104\Printer_Name.print_shrink_to_fit
true
print.printer_\\http://192.168.0.104\Printer_Name.print_to_file
false
print.printer_\\http://192.168.0.104\Printer_Name.print_unwriteable_margin_bottom
0
print.printer_\\http://192.168.0.104\Printer_Name.print_unwriteable_margin_left
0
print.printer_\\http://192.168.0.104\Printer_Name.print_unwriteable_margin_right
0
print.printer_\\http://192.168.0.104\Printer_Name.print_unwriteable_margin_top
0
privacy.cpd.downloads
false
privacy.cpd.formdata
false
privacy.cpd.history
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
security.warn_viewing_mixed.show_once
false
Graphics
Adapter Description
NVIDIA GeForce GT 240
Vendor ID
10de
Device ID
0ca3
Adapter RAM
Unknown
Adapter Drivers
nv4_disp
Driver Version
6.14.12.8026
Driver Date
8-3-2011
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
GPU Accelerated Windows
1/1 Direct3D 9

Question owner

Is it bad form to reply to my own question? Anyway, I received a recommendation via another forum to try a fresh install after fully removing Firefox 7 from the system via Add/Remove Programs. I did so; the problem didn't go away.

Is it bad form to reply to my own question? Anyway, I received a recommendation via another forum to try a fresh install after fully removing Firefox 7 from the system via Add/Remove Programs. I did so; the problem didn't go away.
tyblackwing 0 solutions 2 answers

I have this same problem. I updated to 7.0.1 and now it takes a very long time for some websites to open. I get the spinning circle saying connected, but it takes minutes for the page to load. This didn't happen in any previous versions and I have been using Firefox on this PC since version 4. It isn't a wireless problem because Steam still connects and I can use Internet Explorer without it slowing down. I like Firefox much better, but this problem is forcing me to use IE instead. It only happens some times and other times the site load quickly like normal. I thought that shutting down Firefox and reopening would help (which is a pain), but that doesn't even always work.

I have tried a complete uninstall/reinstall and I ran a registry cleaner before reinstallation.

I use PC tools Spyware Doctor if that has anything to do with it, but I don't think it's blocking anything as I have been using Firefox for years with this PC and that antivirus.

Edit: I am running Windows 7 Ultimate 64bit, with 8 GB of ram, quad core extreme, and dual NVIDIA 280m graphics cards. I don't know what other info would be helpful.

I have this same problem. I updated to 7.0.1 and now it takes a very long time for some websites to open. I get the spinning circle saying connected, but it takes minutes for the page to load. This didn't happen in any previous versions and I have been using Firefox on this PC since version 4. It isn't a wireless problem because Steam still connects and I can use Internet Explorer without it slowing down. I like Firefox much better, but this problem is forcing me to use IE instead. It only happens some times and other times the site load quickly like normal. I thought that shutting down Firefox and reopening would help (which is a pain), but that doesn't even always work. I have tried a complete uninstall/reinstall and I ran a registry cleaner before reinstallation. I use PC tools Spyware Doctor if that has anything to do with it, but I don't think it's blocking anything as I have been using Firefox for years with this PC and that antivirus. Edit: I am running Windows 7 Ultimate 64bit, with 8 GB of ram, quad core extreme, and dual NVIDIA 280m graphics cards. I don't know what other info would be helpful.

Modified by tyblackwing

Question owner

I should clarify that once the problem starts happening, it's not just one particular site that's affected. The *act* of trying to load a site seems to trigger the problem, but no one site does so consistently, and once the problem has occurred, *no* site will load until I completely close down and restart the browser (or wait a few minutes for it to clear up on its own).

I should clarify that once the problem starts happening, it's not just one particular site that's affected. The *act* of trying to load a site seems to trigger the problem, but no one site does so consistently, and once the problem has occurred, *no* site will load until I completely close down and restart the browser (or wait a few minutes for it to clear up on its own).

Modified by DavidJProkopetz

Hasan 469 solutions 5600 answers

-> Clear Cookies & Cache

-> Clear the Network Cache

Perform the suggestions mentioned in the following article:

Check and tell if its working.

-> Clear Cookies & Cache * https://support.mozilla.com/en-US/kb/Template:clearCookiesCache -> [[How to clear the cache#w_clear-the-cache|Clear the Network Cache]] Perform the suggestions mentioned in the following article: * [[Firefox cannot load websites but other programs can]] Check and tell if its working.

Modified by Hasan

Question owner

No dice, I'm afraid. I already tried clearing my cookies, clearing my network cache, and even doing a clean reinstall. In addition, disabling IPv6 and DNS pre-fetching doesn't seem to have had any effect, and none of the other suggestions in the linked article seem applicable given the symptoms I'm experiencing.

No dice, I'm afraid. I already tried clearing my cookies, clearing my network cache, and even doing a clean reinstall. In addition, disabling IPv6 and DNS pre-fetching doesn't seem to have had any effect, and none of the other suggestions in the linked article seem applicable given the symptoms I'm experiencing.
Hasan 469 solutions 5600 answers

Chosen Solution

Type about:config in the Location (address) bar and press the "Enter" key. When you see a warning, click I'll be careful, I promise! button.

-> In the Filter bar, type network.http.max-connections

  • Right click the preference network.http.max-connections and choose Modify
  • change the value to 30 or 48
  • click OK

-> Close the about:config tab

  • Restart Firefox.

Check and tell if its working.

Type '''about:config''' in the Location (address) bar and press the "Enter" key. When you see a warning, click '''I'll be careful, I promise!''' button. -> In the '''Filter bar''', type '''network.http.max-connections''' * Right click the preference '''network.http.max-connections''' and choose '''Modify''' * change the value to '''30''' or '''48''' * click OK -> Close the '''about:config''' tab * Restart Firefox. Check and tell if its working.

Modified by Hasan

Question owner

That seems to have improved matters, but the erratic and intermittent nature of the problem makes it difficult to say for certain. I'll get back to you tomorrow - if it goes 24 hours without recurring, I'm prepared to call it solved.

That seems to have improved matters, but the erratic and intermittent nature of the problem makes it difficult to say for certain. I'll get back to you tomorrow - if it goes 24 hours without recurring, I'm prepared to call it solved.

Modified by DavidJProkopetz

fromthebeginning 0 solutions 9 answers

Running about 7 tabs open at startup, this has always worked fine, here is the problem and the sequence of events leading up to hope. Any suggestions would be appreciated:

Background:

   Mozilla updated me to 7.0 automatically a few days ago, no problems
   Yesterday they auto updated me to 7.0.1, now it won't connect (random tabs of the seven)
       Scaled back to 3 tabs at start now it connects but after a minute of so, the icon in the tabs just spinning and it isn't connected.
    When an open tab is spinning or trying to connect all other tabs sit and wait (my performance monitor shows CPU usage through the roof)
       Scaled back to one tab the same thing, ran with plugins disabled/safe mode
       Reinstalled Firefox, disabled the Norton firewall to test, same thing
       Checked the application setting on the firewall, it is set to allow or auto
       I downloaded Firefox 8 beta same issue, went back to 7.0.1 same issue
Any suggestions would be appreciated, never happened until the upgrade to 7.0.1 
       

This problem manifests itself as slow to connect, never connects, poor performance, high cpu usage etc

Comments on this issue are all over the web, LETS GET A FIX ON THIS please.

   BTW IE 8 and Chrome work fine, I've tried the suggestions above
Running about 7 tabs open at startup, this has always worked fine, here is the problem and the sequence of events leading up to hope. Any suggestions would be appreciated: Background: Mozilla updated me to 7.0 automatically a few days ago, no problems Yesterday they auto updated me to 7.0.1, now it won't connect (random tabs of the seven) Scaled back to 3 tabs at start now it connects but after a minute of so, the icon in the tabs just spinning and it isn't connected. When an open tab is spinning or trying to connect all other tabs sit and wait (my performance monitor shows CPU usage through the roof) Scaled back to one tab the same thing, ran with plugins disabled/safe mode Reinstalled Firefox, disabled the Norton firewall to test, same thing Checked the application setting on the firewall, it is set to allow or auto I downloaded Firefox 8 beta same issue, went back to 7.0.1 same issue Any suggestions would be appreciated, never happened until the upgrade to 7.0.1 '''''This problem manifests itself as slow to connect, never connects, poor performance, high cpu usage etc Comments on this issue are all over the web, LETS GET A FIX ON THIS please. BTW IE 8 and Chrome work fine, I've tried the suggestions above'''''

Modified by fromthebeginning

siscom 1 solutions 3 answers

Helpful Reply

Here is the fix, the problem is you dont have to setup memory at 30 but 48, Firefox Stop Loading Pages FIX

Here is the fix, the problem is you dont have to setup memory at 30 but 48, [http://bloggermind.net/blogging_tools/software/firefox-7-stops-loading-pages-high-cpu-fix/ Firefox Stop Loading Pages FIX]
fromthebeginning 0 solutions 9 answers

Thanks for the recommendation I will try it, test and get back to the group.

Thanks for the recommendation I will try it, test and get back to the group.
fromthebeginning 0 solutions 9 answers

Thanks looks like a fix!!!!!!!!!!!!!!!! Tried it 4 hours ago, multiple (up to 12) tabs running, ran video's from different sites simultaneously and have not had any recurrences of the issue.

Appreciate your recommendations.

Thanks looks like a fix!!!!!!!!!!!!!!!! Tried it 4 hours ago, multiple (up to 12) tabs running, ran video's from different sites simultaneously and have not had any recurrences of the issue. Appreciate your recommendations.

Question owner

Sorry for the delayed response. Changing max-connections to 48 seems to have cleared the problem right up. I have noticed a moderate reduction in performance on sites with very large numbers of images, though - hopefully we'll get a fix to the underlying issue of Firefox choking on too many concurrent connections at some point.

Sorry for the delayed response. Changing max-connections to 48 seems to have cleared the problem right up. I have noticed a moderate reduction in performance on sites with very large numbers of images, though - hopefully we'll get a fix to the underlying issue of Firefox choking on too many concurrent connections at some point.
tyblackwing 0 solutions 2 answers

This fixed it. Thank you mha007. Changed it to 48 and Firefox works great again now. I was afraid I was going to have to use IE lol.

This fixed it. Thank you mha007. Changed it to 48 and Firefox works great again now. I was afraid I was going to have to use IE lol.

Modified by tyblackwing