X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox constantly crashes since 15.0.1 update

Posted

Firefox crashes CONSTANTLY. It is non-discriminatory as to when, where, what or why I'm doing anything. No one web page has done it. I have always submitted results and asked to be notified and have heard bupkiss... I would attache my last crash data, except you guys have 30 crash dumps already. I've tried disabling all addons (Ghostery, ABP and Flash) to no avail. I'm currently running unsynced from my other devices to see if that makes a difference.

I switched because I was tired of IEs pop up and crap, but now I think IE is a Godsend. If you guys can't get this fixed, I'll move on to Chrome!

The damn thing JUST crashed AGAIN trying to Copy and Paste the Help>Troubleshooting info... I'm done.

Additional System Details

Crash ID

bp-7eeae09d-bf5c-42f6-baef-5501721209189/18/201215:34bp-9db78a92-ad62-4832-ae9c-b9d0021209189/18/201215:20bp-fa36c78b-82ce-4873-8de4-75e1721209189/18/201214:03bp-9fe03b5d-8200-437d-8e09-efb2421209189/18/201214:02bp-65d7652f-4381-42af-8de6-0d0bf21209159/15

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • Plug-in for detecting Nero Kwik Media.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Application Basics
Name
Firefox
Version
15.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Adblock Plus Pop-up Addon
0.4
true
adblockpopups@jessehakanen.net
Ghostery
2.8.2
true
firefox@ghostery.com
Flashblock
1.5.15.1
false
{3d7eb24f-2740-49df-8937-200b1cc08f8a}
Freemake Video Converter Plugin
1.0.0
false
fmconverter@gmail.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.display.background_color
#C0C0C0
browser.display.use_system_colors
true
browser.places.smartBookmarksVersion
4
browser.search.useDBForOrder
true
browser.startup.homepage
http://medford.craigslist.org/|http://www.tomshardware.com/forum/|https://www.facebook.com/|http://my.ebay.com/ws/eBayIS…
browser.startup.homepage_override.buildID
20120905151427
browser.startup.homepage_override.mstone
15.0.1
browser.tabs.warnOnClose
false
extensions.lastAppVersion
15.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1347651307
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5700 Series
Vendor ID
0x1002
Device ID
0x68b8
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.982.0.0
Driver Date
7-27-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (ATI Radeon HD 5700 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.1
4.9.1
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Helpful Reply

hello scottiemedic, some other users who have recently updated the graphics driver for their ati hardware (to ati catalyst version 12.8) have reported similar crashes. please try disabling hardware acceleration in firefox > options > advanced > general & see if this resolves the issue of frequent crashes for the moment until ati releases a new driver.

Question owner

Absolutely NOT. I tried that and FF looks like crap!! I'm not going to wait for another company to fix YOUR web browser. There are other options. I find your canned response to be inadequate, rude and downright ignorant (and you can tell the guy who told you to give that response I said so).

I know you are not personally responsible for the problem, or the reply you have to put, but in an era where IE, Chrome and FF are all competing for top dog (or fox), to tell your users to cripple their machine while waiting for AMD to fix the problem is redonk-ulous. If that's the stance Mozilla wishes to take, Chrome is the browser I'll use...

Question owner

Is this the answer?

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Helpful Reply

i'm fully personally responsible for all the replies i'm giving since i'm a volunteering contributor and not connected to mozilla. i honestly don't understand why you consider my response inadequate, rude and downright ignorant - but also have no desire arguing with you. furthermore you can rest assured that i don't care which browser you're using. however if you don't want to troubleshoot the issue, then there's no point posting at a support forum?!

i've looked on all your submitted crash reports and the ati driver version catched my eye, since i've seen quite a few similar crashes in the last few days. modern browsers the graphics hardware in your pc to render elements of webpages to make them load faster & therefore also depend on the drivers that are releaseds by those third-partys. in case there is a bug in ati's drivers that causes a crash, mozilla's only options are to wait for an update of that driver and blocklist the driver in the meantime (a process which is already being considered for your configuration).

Question owner

I was fully expecting a response from Mozilla, as I'm posting to their support site, not a contributing volunteer. This isn't Tom's Hardware or some other random forum...

Maybe Mozilla needs to move faster to either find a workaround for the driver issue, blocklist it or whatever and quit 'considering' it.

Modified by scottiemedic

Melowout 0 solutions 8 answers

Okay, since I'm NOT a gamer, I will give it a try - disabling hardware acceleration. Tired of the crashes, frozen screens and BSODS. If it doesn't work, I'll go Scottie's route - and give Chrome a try.

P.S. Thank you to all volunteers who try to help us out here. I thought this was Mozilla Support Team too.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hey Melowout, could you post a bunch of your latest crash report IDs as a reply to this question? - they would provide some insight on what's going wrong in your individual case (might also be an entirely different issue)... for instructions on how to retrieve them, please refer to https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help#w_get-help-fixing-this-crash

thanks!

Question owner

madperson, I owe an apology to you for my tone of the replies. I truly thought that you were posting on Mozilla's behalf (ie you have a cubical, get a paycheck type of thing). I'm not at all shabby at computers and know as a general consensus, most people don't have my level of expertise and wouldn't give a rat's ass or even know/tell the difference with HW ACC on or off...

I did disable HW acc. and the problem has ceased, but I still find that to be an inappropriate workaround by disabling pretty crossfired 5770s for a web browser to work. Not only that, the speed advantage FF had over IE is null now due to the lack of HW ACC while drawing web pages, and particularly one's saturated with images.

I'll try FF some other time, after their paid support team pulls their heads out and fixes it. Apparently they don't know how to test updates for more than a day before releasing to the general public.

Back to IE for me, I tried Chrome, and although fast, the interface makes me want to cut my heart out with a spoon...

Again, my apologies. After melow gets resolve to this, please feel free to close this thread if you have moderator capabilities, otherwise that can be directed at whatever mod sees this first.

Melowout 0 solutions 8 answers

@Madperson - - thank you for the followup - here is my recent crash update:


bp-7d98b11d-05b3-4086-a834-4d94121209199/19/20129:39 AMbp-121a8309-fe00-4eac-8390-596b621209199/18/201210:22 PMbp-d9737947-04dd-45ac-8452-99d4621209199/18/201210:11 PMbp-242c0175-3697-4b79-be1b-97abc21209189/17/201210:35 PMbp-8ca8685d-5aa3-4e43-b30f-a680621209179/16/201211:20 PMbp-1a1fe738-220b-4423-9c09-30da221209149/14/20122:37 PMbp-da15fc74-673a-423f-92db-6514f21209149/14/20121:55 PMbp-e5b5a7fe-827c-4071-bbf6-33b4121209129/12/201211:25 AMbp-edc9ef03-fd3b-427f-9522-ac87221209129/12/201211:25 AM

Melowout 0 solutions 8 answers

Let me try that again

bp-7d98b11d-05b3-4086-a834-4d94121209199/19/20129:39 AM bp-121a8309-fe00-4eac-8390-596b621209199/18/201210:22 PM bp-d9737947-04dd-45ac-8452-99d4621209199/18/201210:11 PM bp-242c0175-3697-4b79-be1b-97abc21209189/17/201210:35 PM bp-8ca8685d-5aa3-4e43-b30f-a680621209179/16/201211:20 PM bp-1a1fe738-220b-4423-9c09-30da221209149/14/20122:37 PM bp-da15fc74-673a-423f-92db-6514f21209149/14/20121:55 PM bp-e5b5a7fe-827c-4071-bbf6-33b4121209129/12/201211:25 AM bp-edc9ef03-fd3b-427f-9522-ac87221209129/12/201211:25 AM

Modified by Melowout

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

thanks Melowout, unfortunately there isn't a clear picture or quick solution from these crash reports obvious to me (but they aren't related to hardware acceleration). maybe another experienced forum member could also have a look at those.

there are 4 different types of crashes - 3 of them are already on mozilla's radar & get investigated, however their cause is not yet understood (bug#643840, 725009, 762987). i couldn't find information about the 4th one, so i will file a new bug report about it...

at the moment i can only point at the generic advice to troubleshoot crashes (essentially make sure that windows & all drivers are updated and do an in-depth scan for malware on your system): Avoid crashes - Tips and tricks

Melowout 0 solutions 8 answers

Thanks much for the feedback. My upgraded system is relatively new - only been around 3 weeks! New install of Windows 7, new power source, new Radeon HD 6750 graphics card, new memory, new SSDrive.... frustrating to say the least. All drivers are updated, all Windows updates installed.... but I'll keep digging. Thanks again. :)

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello fyi, i've opened bug #792626 for this issue - you also might want to keep an eye on that.

do the crashes happen too when you launch & run firefox in safemode?

Troubleshoot Firefox issues using Safe Mode


Just adding forum cross referencing info. I can not remeber but I think

  • internal searches still index archived threads
  • external searches do not.
  • Bug 792626 referred to
    • bp-1a1fe738-220b-4423-9c09-30da22120914
      @ RuleHash::AppendRule(RuleSelectorPair const&)

(I do not seem to find that signature currently though)

Potentially related thread Crash ID, bug wise, is /questions/979439#answer-508381

Modified by John99

Melowout 0 solutions 8 answers

I haven't run Firefox in safemode. But I will enable the hardware acceleration again - and see what happens. So far, since I disabled it - I haven't had ANY Firefox crashes - and no BSOD's...... I do believe there is a problem with the new ATI graphics card as I cannot get the DisplayPort to work at all - the other ports, VGA>DVI and DVI to HDMI work fine - so it all might be connected.

I'll report back and let you know what happens with hardware acceleration enabled.

Thank you much :)

thinIce 0 solutions 1 answers

I have an exam soon and I was forced to use chrome, with whom I lost all my favorites tools. The problem is solved, it was indeed the ATI driver (ATI ATI still grrrr...). Anyway, thaaaaaaanks madperson.

secondOption 0 solutions 1 answers

@madperson: Thanks for the info. My fox was crashing as well, but I was suspecting Kaspersky (since I've just updated it as well).. but seems the culprit is actually the new catalyst

Turned off HW acceleration, seems to be stable now.

Thanks again!

Melowout 0 solutions 8 answers

FollowUp/FYI - I've removed the ATI card - enabled hardware acceleration and have had no further Firefox crashes or BSOD's.

Unfortunately, I'll be taking a loss on the ATI card return but at least I'm up and running with the old card, two monitors, and now can get back to productivity.

Thanks for all the updates & follow-through on this issue - appreciate all your help :) 'Now, back to work!

cutmetal 0 solutions 23 answers

I was having the same problem.... But I keep forgetting that when you upgrade firefox... or it updates automatically... you need to right click on the firefox start up icon, go into properties, click on the compatibilities tab, and put a check in the "Run This Program As An Administrator" box, then hit apply. Start Firefox, and it should work OK. Problem is...each time you upgrade firefox and/or I think Adobe flash... you need to make sure that box is checked. This is on Firefox 15.0.1 with Adobe Flash 11.4.402.278 all up to date, Windows 7 64bit. If Firefox has Adobe flash add-on, it needs to run in admin mode or it will crash.

Melowout 0 solutions 8 answers

Thanks for the extra tip Cutmetal. I'm still having problems with Firefox crashing throughout the day - so I will give this a try! Next I'll try to figure out where Adobe Flash is.... I know it is in here but a search doesn't find it - but it continues to crash too, so I'll make sure I do the same. :)

cutmetal 0 solutions 23 answers

Adobe flash ... In firefox ... click "Tools"..... then "Add-ons"... then find "Shockwave Flash" in the list or any other flash. Then disable flash. Mine was locking as soon as I started Firefox while connected to the internet. So I had to unplug my computer from the router/modem, then start firefox while offline, then disable flash. Then restart firefox, plug back in the modem or router. If firefox works... then you know that is the problem. You will have any flash item saying that you are missing a plug-in.... so do what I suggested in the above post about admin. That was the fix for mine crashing... so I hope it works.... Make sure both Flash & Firefox are updated to the latest version. Each time it updates, Firefox defaults back to running without the admin box checked...so after a up date ... recheck that box.