Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FIREFOX will not permit me to ATTACH A FILE TO A HOTMAIL MESSAGE. This has been a problem for a LONG TIME. PLEASE FIX IT!

  • 10 replies
  • 7 have this problem
  • 2549 views
  • Last reply by Stringence

more options

FIREFOX will not permit me to ATTACH A FILE TO A HOTMAIL MESSAGE. This has been a problem for a LONG TIME. PLEASE FIX IT!

I am forced to use INTERNET EXPLORER if I wish to ATTACH a FILE to my HOTMAIL message.

This problem has been around a LONG TIME. Please put down the BEER and get to work!

All Replies (10)

more options

You might have a problem with an add-on interfering with some webpages functions.

Also, you can try and clear cache in Firefox: http://support.mozilla.org/en-US/kb/how-clear-firefox-cache

--

Have you disabled JavaScript or are you using NoScript, Adblock plus or any similar add-ons?

You can troubleshoot Firefox by launching it in Safe mode. This will use a clean profile of Firefox and eliminate any problems. Do this to make sure the function you are looking to use works.

more options

Just Uninstall Your Firefox and download the ne version and not forget to chek your os was 32bit or 64 bit and if problem consist chek

"[Spam link removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]"

Modified by Chris Ilias

more options

I am disappointed that none of the Firefox designers has tried to fix this problem. There was a time (long ago) when Firefox did not have the problem I have described. But the latest version that I have (15.0.1) does have the problem. Fortunately, Internet Explorer 7 does NOT have the problem so I switch to IE7 when I wish to append a file to a Hotmail message.

more options

I´ve ended up in this problem too - attachments no longer work in Hotmail.

I discovered the cause on my laptop, but I can´t explain it:

When the plugin-container.exe is disabled in about:config through changing dom.ipc.plugins.enabled from "true" to "false", attachments stop working in Hotmail. When I enable plugin-container, the ability to make attachments is restored. I´ve tested this back and forth many times, and it works.

The problem now is to keep the functionality in Hotmail, but do away with plugin-container.exe. It consumes a minimum of 2 gigabytes of RAM memory, usually more.

Any thoughts or tips on this issue?

Modified by Stringence

more options

Hey Stringence, I didn't know the disabling the plugin container could stop attaching files to Hotmail messages. I will have to test that.

I also encountered this problem and it frustrated me to hell. I luckily read about a solution in another thread (When using Hotmail, I cannot attach or forward attachments), that if you disable the Microsoft Silverlight plugin then try to create a new Hotmail message again, you will be able to attach files!

It was a strange solution but it worked. My guess is that Silverlight is breaking something to do with attaching files in Hotmail. After you are done sending your email, you can enable the Silverlight plugin if you need it for watching movies or other websites.

Usually the Silverlight plugin is used for watching videos. It is just like Adobe's Flash plugin. The problem for some people is they are using a Silverlight plugin that is a old version that Hotmail doesn't like and breaks the ability to add attachments to emails. So in some cases upgrading the Silverlight plugin to the newest version can fix this problem.

Upgrade link: http://www.microsoft.com/getsilverlight/

But some people did report that upgrading the Silverlight plugin did not resolve the issue. And that disabling the plugin was the only fix that worked.

To disable the Silverlight plugin:
Firefox button > Add-ons > Plugins

Then click on Silverlight and click the Disable button. Then close Firefox to save the changes. Reopen Firefox, login to Hotmail and now you should be able to attach files to your emails.

To enable the Silverlight plugin:
Firefox button > Add-ons > Plugins

Click on Silverlight and click the Enable button. Then close Firefox to save the changes.

more options

Thank You, you come with a simple solution easily understood.

I ´ve also tried a number of quirks in about:config.

So, now Silverlight is deisabled, I´m gonna stop the plugin-container.exe, and se what happens with Hotmail i Firefox. I hate to loose FF, it scrolls the pages smooothly and nice.

Why do we have to put upp hours and hours doing developers and designers jobs? This stupid problem shouldn´t even exist.

I´ll report back shortly.

Modified by Stringence

more options

Friends ... It worked.

1) First get rid of Silverlight, disable it in the Add-ons-section.

2) Next, through about:config you change dom.ipc.plugins.enabled to "false".

With these both done, the FF should work fine with Hotmail. And plugins-container.exe no longer pest your systems. Best of luck everyone!

more options

Thank you Stringence and Noah_SUMO. You have solved my problem which has been in need of a solution for almost two years. Mozilla Firefox designers should have fixed this problem long ago. Clearly, tighter supervision of the design group is required.

Stringence, I find that disabling Silverlight solves the problem for me. I do not have to do the other thing with "about.config".

Thank you both for your valuable help.

henryA

more options

No problem Stringence & HenryA. Glad I could help you guys out. I also hate this problem very much. But I would like to think that Firefox is not the only victim of Hotmail's broken attachment problem.

There's 2 more popular web browsers out there: Google Chrome and Opera. If I can find some time, I will test my Hotmail account in these browsers and see if I'm able to attach files to my emails without any problems. If I get the same problem as I did in Firefox, then I would like to blame the Silverlight plugin for this issue.

Also, you guys may not know this but there are rumors going around that Hotmail may be getting rid of the old website and replacing it with Outlook.com, a site that's supposed to have a futuristic redesign, better features and competitive with Google's Gmail.

So if that happens, look out for this problem on the new site. But it may be fixed on the new site because I believe Microsoft has moved most of their Hotmail developers to the Outlook website.

more options

Guys, my solution above on this problem, works.

However, there seems to be a second way worth trying:

  • reinstall/upgrade to Firefox 17 (reinstall/upgrade to keep passwords, favourites and so on)
  • uninstall and erase Silverlight, clear Windows Registry from all non-valid entries with a registry maintenance-tool, then reinstall Silverlight too

This procedure was successfully tested on a Win XP-system.

But, as stated above, Hotmail may be going down the drain, so don´t put more effort into this than necassary. With a new site, we´ll probably get lots of new problems to fight. ;-)

Modified by Stringence