X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox Opening new windows reverts to original Window

Posted

Just started with this problem, when I open a new window which is my preference rather than Tabs I find that whereas it used to open the new window and that was active, it is now opening a new window and then reverting to the original one.

Any ideas?

Additional System Details

This happened

Every time Firefox opened

This started when...

This week

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • VLC media player Web Plugin 2.0.2
  • Garmin Communicator Plug-In 4.0.3.0
  • 5.1.10411.0
  • iTunes Detector Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Shockwave Flash 9.0 r45

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

Application Basics
Name
Firefox
Version
15.0
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Autofill Forms
0.9.8.3
true
autofillForms@blueimp.net
British English Dictionary
1.19.1
true
en-GB@dictionaries.addons.mozilla.org
DownloadHelper
4.9.9
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Easy YouTube Video Downloader
6.5
true
{c0c9a2c7-2e5c-4447-bc53-97718bc91e1b}
FoxLingo
2.7.5
true
{ef62e1ce-d2a4-4cdd-b7ec-92b120366b66}
Garmin Communicator
4.0.3
true
{195A3098-0BD5-4e90-AE22-BA1C540AFD1E}
Imgur Uploader
1.0.3
true
giorgio@gilestro.tk
MP4 Downloader
1.3.2
true
mp4downloader@jeff.net
Textarea Cache
0.8.7
true
{578e7caa-210f-4967-a0d3-88fe5b59a39f}
Themes Menu
1.14
true
{84625510-7e5d-11e0-a411-0800200c9a66}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind
true
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.link.open_newwindow
2
browser.places.smartBookmarksVersion
4
browser.startup.homepage
file:///S:/wisdom_site/index.html
browser.startup.homepage_override.buildID
20120824154833
browser.startup.homepage_override.mstone
15.0
browser.tabs.loadInBackground
false
extensions.lastAppVersion
15.0
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1346049357
places.history.expiration.transient_current_max_pages
80513
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 4550
Vendor ID
0x1002
Device ID
0x9540
Adapter RAM
512
Adapter Drivers
aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Driver Version
8.850.0.0
Driver Date
4-19-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (ATI Radeon HD 4550 ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows
2/2 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.1
4.9.1
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

Skram0 0 solutions 3 answers

Just updated to FF v17.0.1 and using Adobe Flash v11.5.502.110 and the problem is still there.

I don't see how it could be totally Flash's fault. Even though if you do revert to an older version and the problem goes away. Seems like it's how FF interacts with the latest Flash. Like how can Flash alone be able to alter your browser's other tabs and other windows? Isn't it supposed to be sand-boxed? FF just needs to hold on to its focus of the current window.

sonnyboy1 0 solutions 11 answers

Me too, only now the problem is worse than before. Even clicking the page a few times, it still goes back to the original.

dvassy 0 solutions 1 answers

In my configuration, I have just solved this problem by disabling the flash download module. Not a problem as I do not download youtube videos that often, I can re-enable it temporarily on an ad-hoc basis.

Still, a fix would be nice

PierrePeter 0 solutions 2 answers

I have just removed everything that has the words "flash" and "shockwave" from my installed list of programmes and then reinstalled flash for Firefox and this has cured my problem. I haven't reinstalled flash for IE as I hardly ever use IE, but this may not be the problem.

I use Google a lot; everytime I opened a new link, the newly opened window was hidden by the Google window, which was really getting on my tits (as we say in Britain!).

I am running W7 64bit.

Hope the cure lasts.

jimmywrangles 0 solutions 5 answers

This fix worked for me, Thanks a million strummer

The best solution I have found is to install an older version of Flash Player.

To use an older version of Flash: Uninstall Flash Player with their uninstaller. It is important to use their uninstaller. http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html#main_Download_the_Adobe_Flash_Player_uninstaller

Direct link: http://download.macromedia.com/get/flashplayer/current/support/uninstall_flash_player.exe

Re-install an older Flash Player version. I'm using version 11.1.102.63 which solves the problem. http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

If you get a message to 'update plugins' on flash sites, you can hide that nag if desired: https://support.mozilla.org/en-US/questions/928032

Good luck!

jimmywrangles 0 solutions 5 answers

After disabling my addons, uninstalling flash and reinstalling an older version the problem has gone, I then re-enabled my addons and the problem is still gone...YAY. Now i'm no great techy but to me that suggests it's adobe flash player not firefox that's causing the problem which would explain why firefox haven't applied a fix. I really hope that helps someone, if it does don't thank me just throw money, if it doesn't blame Strummer it was his idea :)

Question owner

Nope, I have uninstalled, rebooted, then re-installed then rebooted and the problem still exists!

jimmywrangles 0 solutions 5 answers

Did you reinstall using an older version of flash?

Question owner

Nope downloaded the latest version

jimmywrangles 0 solutions 5 answers

Remove flash with the uninstaller, http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html#main_Download_the_Adobe_Flash_Player_uninstaller

Then reinstall an older version of flash, I used the version mentioned in the post by strummer on page two version 11.1.102.63 http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html You'll find it about half way down the page.

Give that a go and see if it works, it did for me.

Question owner

Thanks Jimmy, that worked :-)

What now, do you refrain from installing any updates?

jimmywrangles 0 solutions 5 answers

I'm going to wait until adobe has a new update and try that, if it doesn't work i'll go back to the version that does. Really glad I was able to help, have a good christmas...assuming the world doesn't end tomorrow :)

Question owner

Thanks Jimmy, Have a great Christmas as well?

slam5 0 solutions 18 answers

Thanks all for and have a very merry Christmas and happy New Year!

PierrePeter 0 solutions 2 answers

I installed the latest version of flash for it to work for me, so it isn't the version that does the trick.

There is a conflict between a sequence of updates of flash and Firefox that has caused this and the resultant problem is in Firefox, not flash, so Mozilla could do with looking into this before too many people (who don't follow this forum) get so pissed off with it they move to another browser, as I was about to do.

See you all the other side of the end of the world!!

niekkouwenberg 0 solutions 3 answers

Helpful Reply

I believe I have fixed this problem by disabling protected mode for Flash, as described here: Disabling Protected Mode in Flash 11.3

"Starting in Flash 11.3 the plugin runs in Protected Mode on Vista and above. This has been causing problems for some Firefox users." (Our issue is however not listed on that KB page.)

By adding the line ProtectedMode=0 to "C:\Windows\SysWOW64\Macromed\Flash\mms.cfg", all problems seems to have disappeared. So no need to disable Flash, or install an older version.

Can anyone confirm?

I am now using Firefox 18 (latest) and Flash 11.5 r502 (latest).

Modified by Noah_SUMO

mhmaddog 0 solutions 4 answers

YEEEEEEEEEEEEE-HAAAAAAAAAAAA or...... YESSSSSSSSSSS!!!!!!!!!

Many thanks - tested and does the job for me. All I needed was to figure how to open the cfg file (text editor). make a copy first in case......

wstco 0 solutions 3 answers

Thank you niekkouwenberg!!! none of the prior suggestions fixed the problem for me, but disabling the protected mode for flash finally did the trick,

I am using firefox 17.0.1 and the latest flash from adobe.

Not sure how much of a security risk is involved by disabling the protected mode, but the annoyance caused by the problem was unacceptable, so I'm willing to go with it.

Thanks again.

slam5 0 solutions 18 answers

YEA or YES in whatever language you can think of. THANK YOU SO MUCH! Protect mode is a significant security feature of flash but since I use noscript, it does alleviate some of the risk (at least you have a choice of running flash of only running selective flash on trusted site). I like the security feature but it caused me a lot of grief. Once again, THANK YOU!

Skram0 0 solutions 3 answers

Just updated to FF v18 and using Adobe Flash beta v11.6.602.137 and the problem is still there.

I really don't think it's wise to downgrade to any lower version.

Look at the news recently about people saying to disable Java. It's because of security risks/holes. Flash has the same security issues too. Infections can now come through Flash, Java, IE, and many others. I say it's best to be up to date on everything.