X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox tries to load HTTPS on every web site (and no http every where is NOT installed) how can i stop this?

Posted

i can see firefox adding https to every single URL i try to go to, if it fails over it goes to none HTTPS. i do "not" have https every where installed, i do however have avast installed, if its a feature of avast i cant find it.

Chosen solution

You set the Boolean pref browser.urlbar.autoFill to false on the about:config page to disable auto-fill on the location bar.

See "Prevent Firefox from automatically completing URLs":


You can set the browser.urlbar.formatting.enabled pref to false on the about:config page to disable the highlighting of the domain and see the full URL more clearly.

You can set the browser.urlbar.trimURLs pref to false on the about:config page to see the http: protocol on the location bar and in the pop-up if you hover a link.

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

This started when...

a few months back

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Google Update
  • Nitro PDF Plug-in for Firefox and Chrome
  • Photosynth 2.110.317.1042
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • 5.1.10411.0
  • Picasa plugin
  • Facebook Video Calling Plugin
  • VLC media player Web Plugin 2.0.0-rc
  • GEPlugin
  • npapicomadapter
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Application Basics
Name
Firefox
Version
14.0.1
User Agent
Mozilla/5.0 (Windows NT 6.0; rv:14.0) Gecko/20100101 Firefox/14.0.1
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
CleanPrint
4.0
true
cleanprint@formatdynamics.com
Download YouTube Videos as MP4 and FLV
1.4.4
true
{b9bfaf1c-a63f-47cd-8b9a-29526ced9060}
Social Fixer
6.751
true
socialfixer@mattkruse.com
SPDY indicator
2.1
true
spdyindicator@chengsun.github.com
TinEye Reverse Image Search
1.1
true
tineye@ideeinc.com
avast! WebRep
7.0.1466
false
wrc@avast.com
Google Gears
0.5.36.0
false
{000a9d1c-beef-4f90-9363-039d445309b8}
Microsoft .NET Framework Assistant
0.0.0
false
{20a82645-c095-46ed-80e3-08825760534b}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20120713134347
browser.startup.homepage_override.mstone
14.0.1
extensions.lastAppVersion
14.0.1
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1346041037
places.history.expiration.transient_current_max_pages
80228
privacy.cpd.cookies
false
privacy.cpd.downloads
false
privacy.cpd.formdata
false
privacy.cpd.history
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) G33/G31 Express Chipset Family
Vendor ID
0x8086
Device ID
0x29c2
Adapter RAM
Unknown
Adapter Drivers
igdumdx32
Driver Version
7.15.10.1666
Driver Date
2-26-2009
Direct2D Enabled
Blocked for your graphics driver version.
DirectWrite Enabled
false (7.0.6002.18592)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) G33/G31 Express Chipset Family) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows
0
JavaScript
Incremental GC
1
Library Versions
Expected minimum version
Version in use
NSPR
4.9
4.9
NSS
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS Util
3.13.5.0
3.13.5.0
NSS SSL
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS S/MIME
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8035 answers

I am not sure I fully understand from your message exactly what you are seeing, but there have been a couple of recent changes to Firefox, and these are probably what are affecting you. By default Firefox now:

  1. uses Google's https search service
  2. autocompletes location bar addresses, with a bias for https

Have a look at these two threads

  1. remove google https 14.0.1 /questions/932674#answer-353249
    My post gives a method for adding to and changing the search bar options
  2. typing in url for my company website sends it to https .... /questions/933563#answer-356371
    Jscher2000gives explanations and workarounds

Maybe if you explain in more detail what is happening, possibly with examples that can be tried it will help me to understand what you see, or maybe the above linked threads help.

Question owner

its that last one exactly, i didnt realize about the trailing / but sure enough thats it. how do i stop it from doing that? normally it wouldnt be a problem but there are a few web sites that are amazingly slow on https and honestly i dont need https for every single connection. (facebook for example, for me at least is extremely slow with https and i use "social fixer" which aparantly does not take too kindly to switching around from http/https)

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96853 answers

Chosen Solution

You set the Boolean pref browser.urlbar.autoFill to false on the about:config page to disable auto-fill on the location bar.

See "Prevent Firefox from automatically completing URLs":


You can set the browser.urlbar.formatting.enabled pref to false on the about:config page to disable the highlighting of the domain and see the full URL more clearly.

You can set the browser.urlbar.trimURLs pref to false on the about:config page to see the http: protocol on the location bar and in the pop-up if you hover a link.

Question owner

so the only way is to disabled a useful feature entirely?

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96853 answers

With auto-fill disabled you can still select an entry from the drop down list that opens when you start typing.
Personally I do not like autocomplete because it is confusing when you start typing and you want to open a completely different website than Firefox suggests.

Modified by cor-el

Question owner

i personally use it, if this was a dev change to push for https the devs should have just made it an option, on a laptop i can see wanting https when ever possible especially on wifi. but on a hardline connection, it just adds over head when not needed. guess ill just remove the S when its a problem until i get fed up enough to move to a different browser :: sigh :: thanks for the help