X
Tap here to go to the mobile version of the site.

Support Forum

I see solution for netflix (mac) where you need to switch to 'open in 32 bit mode', but when I go into info for FF, that radio button is not there. ??

Posted

i am confused

i am confused

Chosen solution

See the first comment here (which I linked earlier)

Quote:


FYI: I downloaded the latest version of Silverlight (5.1.10411.0); I installed it and restarted Firefox, but Silverlight remained blocked until I enabled it using the Add-ons/Plugin page.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1
August 23rd, 2012


You may need to open the Firefox Tools menu, then go the Add-ons manager Plugins panel and enable the Silverlight plugin.

If the problem isn't resolved, even after restarting Firefox, delete the pluginreg.dat file from the Firefox profile folder as explained in the Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems article, Re-initializing the plugins database section.

Read this answer in context 3

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 11.2 r202
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX Web Player version 2.0.3.4
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

jscher2000
  • Top 10 Contributor
2999 solutions 27850 answers
I'm not a Mac user, but here is a thought from other thread: * https://support.mozilla.org/en-US/questions/812676 - use Finder, not Path Finder Screen shots (separate sites): * http://www.mostoptimal.com/tech/configuring-firefox-4-to-start-in-32-bit-mode/ * http://alexsantidote.com/535/start-firefox-4-in-32-bit-mode-for-less-ram-usage/

Question owner

Sorry I wasn't clear, but I did exactly what those instruction say, but when I open the info box, the option to 'open in 32bit mode' is not there

Sorry I wasn't clear, but I did exactly what those instruction say, but when I open the info box, the option to 'open in 32bit mode' is not there
AliceWyman
  • Moderator
193 solutions 2216 answers

Even if you could set the Firefox.app to open in 32-bit mode it may not work if you are using an older version of Silverlight, as reported here:

Additionally, I don't even see Silverlight in your Plugins list. Netflix uses Silverlight and versions older than 5.1 have been blocklisted which may explain why it's missing. Instead of trying to use the 32-bit workaround, update to Silverlight 5.1 Ref:

While you are at it, visit http://www.mozilla.com/plugincheck/ and update your other plugins. You should also Update Firefox to the latest version since Firefox 13.0.1 is outdated.

Even if you could set the Firefox.app to open in 32-bit mode it may not work if you are using an older version of Silverlight, as reported here: *https://support.mozilla.org/questions/932415 ''I just updated FF to 14.0.1 (Mac 10.6.8) and now netflix won't work. It's asking to restart in 32 bit mode and I changed it in the Get Info to 32 bit. No luck.'' Additionally, I don't even see Silverlight in your Plugins list. Netflix uses Silverlight and versions older than 5.1 have been blocklisted which may explain why it's missing. Instead of trying to use the 32-bit workaround, update to Silverlight 5.1 Ref: *https://blog.mozilla.org/addons/2012/08/22/blocking-old-silverlight-on-mac-os-x/ *https://bugzilla.mozilla.org/show_bug.cgi?id=782672 *[[Use the Silverlight plugin to play audio and video]] While you are at it, visit http://www.mozilla.com/plugincheck/ and update your other plugins. You should also [[Update Firefox to the latest version]] since Firefox 13.0.1 is outdated.

Modified by AliceWyman

Question owner

I had reverted back to V13 to get Netflix to work, which it did, but then I started getting a message about a problem with Silverlight. Today, all of a sudden Silverlight is not installed.

And now I have a new problem. I updated to 14 as you suggested, checked my plugins (updated Flash), and installed latest SL via the link you gave. Computer says install was successful, but SL is in fact not there, confirmed by the SL website, Netflix site asking me to install, and there are no files in Library/INternet plugins.

THis is absurd.

I had reverted back to V13 to get Netflix to work, which it did, but then I started getting a message about a problem with Silverlight. Today, all of a sudden Silverlight is not installed. And now I have a new problem. I updated to 14 as you suggested, checked my plugins (updated Flash), and installed latest SL via the link you gave. Computer says install was successful, but SL is in fact not there, confirmed by the SL website, Netflix site asking me to install, and there are no files in Library/INternet plugins. THis is absurd.
AliceWyman
  • Moderator
193 solutions 2216 answers

Chosen Solution

See the first comment here (which I linked earlier)

Quote:


FYI: I downloaded the latest version of Silverlight (5.1.10411.0); I installed it and restarted Firefox, but Silverlight remained blocked until I enabled it using the Add-ons/Plugin page.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1
August 23rd, 2012


You may need to open the Firefox Tools menu, then go the Add-ons manager Plugins panel and enable the Silverlight plugin.

If the problem isn't resolved, even after restarting Firefox, delete the pluginreg.dat file from the Firefox profile folder as explained in the Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems article, Re-initializing the plugins database section.

See the first comment here (which I linked earlier) *https://blog.mozilla.org/addons/2012/08/22/blocking-old-silverlight-on-mac-os-x/ '''Quote:''' ----- ''FYI: I downloaded the latest version of Silverlight (5.1.10411.0); I installed it and restarted Firefox, but Silverlight remained blocked until I enabled it using the Add-ons/Plugin page.'' ''Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1''<br> ''August 23rd, 2012'' ----- You may need to open the Firefox '''Tools''' menu, then go the '''Add-ons''' manager '''Plugins''' panel and enable the Silverlight plugin. If the problem isn't resolved, even after restarting Firefox, delete the pluginreg.dat file from the [[Profiles|Firefox profile folder]] as explained in the [[Troubleshooting plugins]] article, '''Re-initializing the plugins database''' section.

Helpful Reply

"You may need to open the Firefox Tools menu, then go the Add-ons manager Plugins panel and enable the Silverlight plugin. "

that did it, many thanks

"You may need to open the Firefox Tools menu, then go the Add-ons manager Plugins panel and enable the Silverlight plugin. " that did it, many thanks
AliceWyman
  • Moderator
193 solutions 2216 answers

You're welcome. Thanks for posting back with the outcome.

You're welcome. Thanks for posting back with the outcome.