X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Getting "This video is currently unavailable" on Youtube

Posted

Since I got up Wednesday evening, I have been getting "This video is currently unavailable" when I try to view Youtube videos, both embedded and on the Youtube page for said video.

This happens more often than not. It only happens in Firefox, Chrome and MSIE do just fine. When I got up Thursday evening and started my system, I got a message from Adobe that Flash needed to update, I updated, no effect.

Here's three vids where the problem is happening https://www.youtube.com/watch?v=N6phrXDGHIo https://www.youtube.com/watch?v=pZ4ffqXg6RA https://www.youtube.com/watch?v=g-6SmnvMbGk

Apparently, the problem is with Firefox. What can I do to fix this?

Chosen solution

Disabling hardware acceleration didn't do it either. But I did see on the first page you linked to where it said ti try disabling add-ons. So I restarted Firefox in safe mode and the problem didn't happen. I restarted with add-ons enabled and it did happen. I disabled Flashblock (keeps flash things from playing until I want them to) and the problem didn't happen. I should have known to try that first.

Thanx for your help!

Read this answer in context 6

Additional System Details

This happened

Every time Firefox opened

This started when...

Wednesday

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • Amazon MP3 Downloader Plugin 1.0.17
  • Google Update
  • Next Generation Java Plug-in 1.6.0_33 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • 5.1.10411.0
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 12.0.1.647
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Application Basics
Name
Firefox
Version
14.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
avast! WebRep
7.0.1456
true
wrc@avast.com
Custom Buttons
0.0.5.5
true
custombuttons@xsms.org
FireFTP
2.0.7
true
{a7c6cf7f-112c-4500-a7ea-39801a327e5f}
FireFTP button
1.1.1d
true
{9BAE5926-8513-417d-8E47-774955A7C60D}
Flagfox
4.2.0
true
{1018e4d6-728f-4b20-ad56-37578a4de76b}
Flashblock
1.5.16
true
{3d7eb24f-2740-49df-8937-200b1cc08f8a}
Free YouTube Download (Free Studio) Menu
1.0.10
true
{ACAA314B-EEBA-48e4-AD47-84E31C44796C}
Java Console
6.0.33
true
{CAFEEFAC-0016-0000-0033-ABCDEFFEDCBA}
Launchy
4.4.0
true
launchy@gemal.dk
New Tab King
5.1.4
true
{FC5BAC7D-D696-4ba6-B913-CF8F000C33DF}
New Tabs at the End
1.0
true
new-tabs-at-end@forerunnerdesigns.com
Open Tab Count
1.1
true
tabcount@3greeneggs.com
Save Images
0.7.9
true
LDSI_plashcor@gmail.com
WOT
20120515
true
{a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}
YouTube Unblocker
0.2.0
true
youtubeunblocker@unblocker.yt
HP Smart Web Printing
4.60
false
smartwebprinting@hp.com
Multi Links
3.0.0.19
false
multilinks@plugin
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
0
browser.cache.disk.smart_size.enabled
false
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
911360
browser.places.smartBookmarksVersion
4
browser.sessionstore.restore_on_demand
false
browser.startup.homepage
http://forecast.weather.gov/MapClick.php?CityName=Gatlinburg&state=TN&site=MRX&textField1=35.7234&textField2=-83.4937&e=…
browser.startup.homepage_override.buildID
20120713134347
browser.startup.homepage_override.mstone
14.0.1
browser.tabs.warnOnOpen
false
extensions.lastAppVersion
14.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1345795753
places.history.expiration.transient_current_max_pages
100530
plugin.disable_full_page_plugin_for_types
audio/mpeg,audio/x-mpeg
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
AMD M880G with ATI Mobility Radeon HD 4250
Vendor ID
0x1002
Device ID
0x9712
Adapter RAM
256
Adapter Drivers
atiu9p64 atiuxp64 atiu9pag atiuxpag atiumdva atiumd6a atitmm64
Driver Version
8.770.2.1000
Driver Date
9-19-2010
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (AMD M880G with ATI Mobility Radeon HD 4250 ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows
2/2 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
1
Library Versions
Expected minimum version
Version in use
NSPR
4.9
4.9
NSS
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS Util
3.13.5.0
3.13.5.0
NSS SSL
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS S/MIME
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC

ideato
  • Top 25 Contributor
616 solutions 4258 answers

Try to update RealPlayer(tm) LiveConnect-Enabled Plug-In to RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit)

see : http://kb.mozillazine.org/Real_Player


thank you

Question owner

Thanx for your reply!

Unfortunately, none of the options that page lists works. I uninstalled RealPlayer (I had version 14 something) and installed 15.0.6.14 with the Browser Record Plugin that "has been known to cause issues with Flash content or other problems in Mozilla browsers." Then I tried disabling Flash 11.3 protected mode by by adding the line ProtectedMode=0 to the Flash "mms.cfg" file (I have Win7-64). Then I uninstalled flash completely by using Adobe's Flash Uninstaller, restarted and installed Flash 10.3

None of that worked, I still get "This video is currently unavailable"

Question owner

I just noticed something else. Now the problem only happens when I view a video on Youtube. It does not happen when I view an embedded Youtube video on any other site

Modified by Cloudchaser

ideato
  • Top 25 Contributor
616 solutions 4258 answers

Try to Turn off hardware acceleration and "disable the hardware acceleration" in the Flash Player too :

http://helpx.adobe.com/flash-player/kb/video-playback-issues.html

http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html


thanks again

Chosen Solution

Disabling hardware acceleration didn't do it either. But I did see on the first page you linked to where it said ti try disabling add-ons. So I restarted Firefox in safe mode and the problem didn't happen. I restarted with add-ons enabled and it did happen. I disabled Flashblock (keeps flash things from playing until I want them to) and the problem didn't happen. I should have known to try that first.

Thanx for your help!

ideato
  • Top 25 Contributor
616 solutions 4258 answers

Great, i am happy you solve it, choose your last reply as Solution chosen to help others with similar problem.

thanks again

saturnjct 0 solutions 3 answers

Helpful Reply

I solved my problem by removing my browser from the HTML5 trial.

See http://forums.mozillazine.org/viewtopic.php?f=38&t=2455373

saturnjct 0 solutions 3 answers

I re-joined the HTML5 trial and tried again. After starting up Web Console and inspecting the javascript, I noticed that there was an error being reported related to what I assume was a regional cache. I removed all of my YouTube cookies and tried again. It now works.

Question owner

My browser is also removed from the HTML5 trial as well as all Youtube cookies have been cleared and that had no effect.

saturnjct 0 solutions 3 answers

How did you delete the cookies? I clicked on the icon at the start of the address bar, selected "More Information..", then Security, then "View Cookies", then "Remove All Cookies". I then had to reload the page with Shift-Ctrl-R to force a full reload.

Helpful Reply

That is how I removed the cookies. Also, I discovered that my Firefox wasn't opted out of the html5 trial after all. I thought it was, but it must have somehow got switched back. I opted out again and the problem hasn't repeated.