X
Tap here to go to the mobile version of the site.

Support Forum

Babylon will not go away.

Posted

I recently downloaded the latest version of Flash player, and now babylon is the home page and default search engine. I have tried all of the things on other help threads, and as soon as I restart Firefox, Babylon is back. Nothing works past restarting Firefox. I opened Internet Explorer, and Babylon is in there as well.

I recently downloaded the latest version of Flash player, and now babylon is the home page and default search engine. I have tried all of the things on other help threads, and as soon as I restart Firefox, Babylon is back. Nothing works past restarting Firefox. I opened Internet Explorer, and Babylon is in there as well.

Additional System Details

This happened

Every time Firefox opened

This started when...

After I downloaded Flash Player

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.16
  • Version 3.4.2.8800
  • Shockwave Flash 11.3 r300
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • 5.1.10411.0
  • Shockwave Flash 11.2 r202
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Picasa plugin
  • Facebook Video Calling Plugin
  • NPWLPG
  • npapicomadapter
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Tyler Downer
  • Administrator
  • Moderator
1345 solutions 8974 answers

First, go to your Start button, then control Panel, then Uninstall a Program. Uninstall anything related to Babylon.

Then, Reset Firefox. Refresh Firefox - reset add-ons and settings. this should eliminate Babylon.

First, go to your Start button, then control Panel, then Uninstall a Program. Uninstall anything related to Babylon. Then, Reset Firefox. [[Reset Firefox – easily fix most problems]]. this should eliminate Babylon.
andythebeagle 3 solutions 57 answers

Helpful Reply

I RECEIVED THIS FROM BABYLON SUPPORT

See also: http://tinyurl.com/c7ktpws (Mozilla on You Tube)

=================================

Dear Sir,

thank you for taking the time to write us.

Please accept my apology for any inconvenience.

Go to Control Panel, click Programs (software).

Uninstall "Browser Manager" + "Bprotector" + "Object Installer" + "Babylon Toolbar on IE"

Then depending on which browser you use , follow the relevant steps:


Firefox ---------------------------

> Open a new Firefox window (website)

> Go to Tools> Options> and go to change your order, the Home. ( f.e www.google.de) and click OK.

> Remove the search engine of Babylon by clicking the small arrow next to the icon of Babylon

> Manage Search Engines

> select Babylon and Remove

> Close Firefox and open again

> write in the address Bar "about:config " and click Enter

> Write in the search engine "Babylon."

> Click on any 'Babylon' preferences with the right mouse button and select "Reset"

In the following video you can see how to change TAB URL :

http://www.youtube.com/watch?v=4yPX-ZJ5fQc&feature=related


Chrome -------------------------------------------------

Open Google Chrome and click on the "wrench" icon:

Click> Settings , choose the option "Open a particular page or set of pages."

Click "Set Pages" on page Babylon and delete from the list.

To change the search engine in Google Chrome, please follow the instructions below:

Open Google Chrome on the "wrench" icon on the right side of the address bar, click:

Settings> Under "Search", click "Manage Search Engines ...".

If you see "Babylon Search" as a standard (default), select please another search engine as the default from (Google, Bing, etc.). Only then will you Babylon You can remove by clicking the little 'X'.


Internet Explorer (IE) ------------ -------------------------------------

Open your Internet Explorer browser, click on "Tools", then "Internet Options" and in the section "Tabs" click on "Settings". It will open a new window, on the option "When a new tab is opened, open:" in the drop-down menu please choose "Your first homepage". Then click OK, Apply and OK.

If I can be of further assistance, please do not hesitate to write to me again.

Best regards,

Babylon Support Team | Babylon Ltd.

I RECEIVED THIS FROM BABYLON SUPPORT See also: http://tinyurl.com/c7ktpws (Mozilla on You Tube) ============================================= Dear Sir, thank you for taking the time to write us. Please accept my apology for any inconvenience. Go to Control Panel, click Programs (software). Uninstall "Browser Manager" + "Bprotector" + "Object Installer" + "Babylon Toolbar on IE" Then depending on which browser you use , follow the relevant steps: ----------------------Firefox --------------------------- > Open a new Firefox window (website) > Go to Tools> Options> and go to change your order, the Home. ( f.e www.google.de) and click OK. > Remove the search engine of Babylon by clicking the small arrow next to the icon of Babylon > Manage Search Engines > select Babylon and Remove > Close Firefox and open again > write in the address Bar "about:config " and click Enter > Write in the search engine "Babylon." > Click on any 'Babylon' preferences with the right mouse button and select "Reset" In the following video you can see how to change TAB URL : http://www.youtube.com/watch?v=4yPX-ZJ5fQc&feature=related ----------------------------- Chrome ------------------------------------------------- Open Google Chrome and click on the "wrench" icon: Click> Settings , choose the option "Open a particular page or set of pages." Click "Set Pages" on page Babylon and delete from the list. To change the search engine in Google Chrome, please follow the instructions below: Open Google Chrome on the "wrench" icon on the right side of the address bar, click: Settings> Under "Search", click "Manage Search Engines ...". If you see "Babylon Search" as a standard (default), select please another search engine as the default from (Google, Bing, etc.). Only then will you Babylon You can remove by clicking the little 'X'. --------------------------------- Internet Explorer (IE) ------------ ------------------------------------- Open your Internet Explorer browser, click on "Tools", then "Internet Options" and in the section "Tabs" click on "Settings". It will open a new window, on the option "When a new tab is opened, open:" in the drop-down menu please choose "Your first homepage". Then click OK, Apply and OK. If I can be of further assistance, please do not hesitate to write to me again. Best regards, Babylon Support Team | Babylon Ltd.

Question owner

Those things work until I restart Firefox, and then the babylon page is the homepage again.

Those things work until I restart Firefox, and then the babylon page is the homepage again.
Tyler Downer
  • Administrator
  • Moderator
1345 solutions 8974 answers

Have you installed Babylon from your control Panel? Do that first, then Reset Firefox again :)

Have you installed Babylon from your control Panel? Do that first, then Reset Firefox again :)

Question owner

The problem is that I never allowed babylon to be installed on my computer. I was updating adobe or java, I don't remember which, and it asked if I wanted babylon to be installed. I clicked "no" twice. There is no program with babylon in the name on my list of programs in the uninstall panel.

The problem is that I never allowed babylon to be installed on my computer. I was updating adobe or java, I don't remember which, and it asked if I wanted babylon to be installed. I clicked "no" twice. There is no program with babylon in the name on my list of programs in the uninstall panel.
Tyler Downer
  • Administrator
  • Moderator
1345 solutions 8974 answers

Babylon is a malicious toolbar that often sneaks into Firefox. Do you have something called Browser Protection, or similar in your control panel? You can sort the items on the installed date and see what is the most recently installed software, see if anything suspicious shows up (feel free to post the list here and I can take a look at it)

Babylon is a malicious toolbar that often sneaks into Firefox. Do you have something called Browser Protection, or similar in your control panel? You can sort the items on the installed date and see what is the most recently installed software, see if anything suspicious shows up (feel free to post the list here and I can take a look at it)
contrawise 1 solutions 12 answers

I just got rid of a similar Babylon infection on a friend's computer. Apparently that one rode in with a Flash Player update as well "Thank you very much Adobe!" [NOT ... ]

Using the Remove Programs control panel, remove any program you can find related to Babylon. Don't expect all the possibilities to start with "B".

After that, if you are still seeing that searches are going to Babylon, it may be because a search preference was set that is independent of the toolbars and other applications. Type "About:Config" in the Address Bar to open the prefs file, and find the address bar search preference. If the preference is turned on, and there is a string present pointing to the Babylon search engine, delete the string. As I remember, you can use the browser's "Find" utility to find instances of Babylon in the prefs file.

You may need to clean up similar preferences on any other web browsers you have on the computer. I had to clean up after both Chrome and IE on the computer I cleaned up.

Finally ... send an email blast to whoever sent that piece of trash to you. Tell them that, if they expect users to update their software, stop sending junk along with the update in "opt-out" format.

I just got rid of a similar Babylon infection on a friend's computer. Apparently that one rode in with a Flash Player update as well "Thank you very much Adobe!" [NOT ... ] Using the Remove Programs control panel, remove any program you can find related to Babylon. Don't expect all the possibilities to start with "B". After that, if you are still seeing that searches are going to Babylon, it may be because a search preference was set that is independent of the toolbars and other applications. Type "About:Config" in the Address Bar to open the prefs file, and find the address bar search preference. If the preference is turned on, and there is a string present pointing to the Babylon search engine, delete the string. As I remember, you can use the browser's "Find" utility to find instances of Babylon in the prefs file. You may need to clean up similar preferences on any other web browsers you have on the computer. I had to clean up after both Chrome and IE on the computer I cleaned up. Finally ... send an email blast to whoever sent that piece of trash to you. Tell them that, if they expect users to update their software, stop sending junk along with the update in "opt-out" format.

Modified by contrawise

andythebeagle 3 solutions 57 answers

Re read the post from Babylon. Their instructions fixed my problem.

Re read the post from Babylon. Their instructions fixed my problem.

Question owner

I looked at the programs by installation date and deleted everything that was on the same day as my adobe update, but nothing changed.

I should add that the only problem I'm having now is that the babylon page is my home page on Firefox no matter what I change, and it's the only browser I use. I've reset my home page through internet options, done the "about:config" search and reset everything with babylon in the name, and searched my program list for anything with babylon and found nothing.

Thanks for all your help, everyone, even if this won't ever get fixed=)

I looked at the programs by installation date and deleted everything that was on the same day as my adobe update, but nothing changed. I should add that the only problem I'm having now is that the babylon page is my home page on Firefox no matter what I change, and it's the only browser I use. I've reset my home page through internet options, done the "about:config" search and reset everything with babylon in the name, and searched my program list for anything with babylon and found nothing. Thanks for all your help, everyone, even if this won't ever get fixed=)
andythebeagle 3 solutions 57 answers

A few things come to mind. The instructions might not quite fit your FF version. Mine is Nightly 18. Got tired of FF 14. Problems w/ flash. My Babylon came with a "live TV" app. Cant remember if from the extentions page or CNet.

A few things come to mind. The instructions might not quite fit your FF version. Mine is Nightly 18. Got tired of FF 14. Problems w/ flash. My Babylon came with a "live TV" app. Cant remember if from the extentions page or CNet.