X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

After updating to 14.0.1 Firefox will force https on websites. How do I fix?

Posted

Ever since I updated to 14.0.1 I have been having problems with this. As of right now, even this website is currently being forced https. My friend is also having the exact same problem as me, so it isn't just a single problem here. (However it could be two)

Can anyone help me here? Happens on pretty much all websites, cannot put just one site.

Chosen solution

it is because of the autocomplete. Is there any way to fix this without disabling this feature though?

So far, I haven't read about any ways to change how the autofill URL is selected from history.

If you turn off urlbar.autofill, then Firefox 14 will behave like Firefox 13: (1) the drop-down of list of matches from your bookmarks and history will appear below the address bar, and (2) if you don't choose a match from the list but instead press Enter, Firefox will load http:// + what you typed (or if you typed separate words, it will run a search).

Read this answer in context 6

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.3 r300
  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • Nexon Game Controller
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • 4.1.10329.0
  • NPWLPG
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

dumdidadida 172 solutions 1436 answers

Hi,

Please check if this happens in Safe Mode. Safe mode disables the installed Extensions, and themes (Appearance) in Tools (Alt + T) > Add-ons. Hardware acceleration is also temporarily disabled - the manual setting is Tools > Options > Advanced > General > Use hardware acceleration when available. All these settings/options/add-ons can also be individually or collectively disabled/enabled/changed in Firefox normal mode to check if an extension, theme, option or hardware acceleration is causing issues. Disabling/enabling hardware acceleration, and some types of add-ons in normal mode may require a Firefox restart.

Uninstalling Add-ons

Uninstalling Toolbars

Troubleshooting Extensions and Themes

Cannot Uninstall Add-on

Problematic Extensions

Options

If the problem persists, you can also consider the Reset Firefox feature via Help (Alt + H) > Troubleshooting Information.

(To revert to the previous profile you were using, close the new profile (i.e. exit Firefox), start Firefox and choose the Default User profile. While the Profile Manager is open, you can also delete the newly reset profile (the one containing random numbers), or the former profile, as the case may be).

Managing profiles

Profiles Howto

cor-el
  • Top 10 Contributor
  • Moderator
10747 solutions 96705 answers

Which security software (firewall, anti-virus) do you have?

Question owner

It still forces it in Safemode as well. Like I told you, it has only been happening since the latest Firefox update and I have not updated any of my plugins since then. The only plugin I have is Adblock+ anyway.

My Firewall is Online Armor and I use Microsoft Security Essentials.

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

I don't have the solution to your problem, but two notes:

  • This site has long been a secure site, at least if you are logged in. No change there.
  • In Firefox 14, the built-in Google search was changed to use HTTPS. However, I'm not aware of any other (intentional) changes from HTTP to HTTPS.
cor-el
  • Top 10 Contributor
  • Moderator
10747 solutions 96705 answers

See the Firefox release notes about the change to a secure Google connection.

Did you check if the firewall has setting to force a secure connection?

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

Helpful Reply

Is this when you start typing in the URL bar and press Enter to accept the autocomplete suggestion? If so, please see this thread: typing in url for my company website sends it to https index page in Firefox, but not IE or Chrome, and the behavoir is not wanted.

Question owner

It is not my Firewall doing this. It happens on EVERY WEBSITE. Not just mozilla.org.

To simplify my problem even further, I will use an example website of a game I play, which is the most frustrating because of this problem.

I click my address bar and type in: www.runescape.com and press enter. It then takes me to: https://www.runescape.com/

jscher2000, it may be because of the autocomplete. I will look at this a bit more.


Edit: jscher2000, it is because of the autocomplete. Is there any way to fix this without disabling this feature though?

Modified by xdflames

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

Chosen Solution

it is because of the autocomplete. Is there any way to fix this without disabling this feature though?

So far, I haven't read about any ways to change how the autofill URL is selected from history.

If you turn off urlbar.autofill, then Firefox 14 will behave like Firefox 13: (1) the drop-down of list of matches from your bookmarks and history will appear below the address bar, and (2) if you don't choose a match from the list but instead press Enter, Firefox will load http:// + what you typed (or if you typed separate words, it will run a search).

Question owner

Okay, well I guess that will have to be the solution for now. Thanks for your help.

Aurora025 1 solutions 4 answers

I have this problem too. We have a online shop and after updating to 14.0.1 it always redirects me to https, which is very bad, because customers are getting a security warning because of this. 14.0.1 should redirect to https by using Google but not on other sites. Is this a bug??? What can I do so that customers are not redirecting to https immediatly on our shop?

dumdidadida 172 solutions 1436 answers

Hi Aurora025,

It would also be helpful to start a new thread. This would help to provide more information specific to the situation.

Aurora025 1 solutions 4 answers

Following solution worked for me. Just put following in the .htaccess file and put your domain name instead of http://www.example.com below:

Modified by Aurora025

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

Hi Aurora025, you need to create a redirect on your site. See how the site http://worldmusic.org/ did that in this thread, or you could contact the poster there: typing in url for my company website sends it to https index page in Firefox, but not IE or Chrome, and the behavoir is not wanted.


Edit: You beat me to it. Thanks for posting the solution. .htaccess rules are tricky, so you might end up with some tweaks to that but it's a great starting point.

Modified by jscher2000

Aurora025 1 solutions 4 answers

So is this a big Firefox bug?

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

Hi Aurora025, a bug has been filed. Currently, it seems that if your history shows that you have used a secure (HTTPS) URL on a site, then autofill defaults to HTTPS for the home page of the site. The bug suggests changing this default to HTTP and letting the site redirect the user if it wants to. No idea when that might get resolved.

You can read the current status of the bug here: Bug 769994 – Inline autocomplete selects HTTPS domain against HTTP domain by default. If you register on Bugzilla, you can add a vote to fix it if you like. However, please do not post "me too"-type comments in bugs, since that can discourage developers from staying on the cc list and solving it.

DianeV2 0 solutions 2 answers

In my opinion, creating a redirect on a website from https to http is not the best solution -- what if the website actually uses a security certificate? And you can't do that for every website.

I found one solution:

Tools > Options > Privacy For Location Bar, select Nothing

jscher2000
  • Top 10 Contributor
2357 solutions 20870 answers

Hi DianeV2, it's confusing because some of the solutions in the discussion are for users and some are for webmasters.

If the site has a security certificate that is valid for the home page, no action needs to be taken by the webmaster. The problem arises when the certificate only applies to some parts of the site.

If you are changing your browser settings, you can either completely turn off the autocomplete drop-down using the setting you described, or you can turn off only the address bar autofill feature and keep the drop-down.

DianeV2 0 solutions 2 answers

Ah, I see. Thing is, even if you have a security certificate that is valid for every page, you don't necessarily want to have people visiting every page via an https link.

Anyway ... I do thank you for the tips. :)