Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Force cache refresh for my website

  • 3 replies
  • 28 have this problem
  • 33740 views
  • Last reply by FedUp

more options

Hello,

I have a problem on my website : http://kevinpounot.olympe.in/
This problem appear just with Firefox.

When I update my site with new photo or if I change the main page, the modifications does not appear in Firefox. The browser just load the caching version of my website and the new stuff is not here.

I already tried some codes like :

<HEAD>
<META http-equiv="Cache-Control" content="no-cache">
<META http-equiv="Pragma" content="no-cache">
<META http-equiv="Expires" content="0">
</HEAD> 

or

<?php
header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");
header("Last-Modified: " . gmdate("D, d M Y H:i:s") . " GMT");
header("Cache-Control: no-cache, must-revalidate");
header("Pragma: no-cache");
?> 

Nothing works. Is there a code which could force the browser to refresh cache and load the latest version of the site ?

PS : Sorry for possible mistakes in my english. ;)

Modified by cor-el

All Replies (3)

more options

Try posting at the Web Development / Standards Evangelism forum at MozillaZine. The helpers over there are more knowledgeable about web page development issues with Firefox.
http://forums.mozillazine.org/viewforum.php?f=25
You'll need to register and login to be able to post in that forum.

more options

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)
more options

The first thing to check is whether you have any caching plugins like WPSuper cache if you are using a CMS like Wordpress.

These create temporary HTML versions of your page so it is not enough to deactivate them, you have to activate them and then delete their cache from their settings page.

If you are a developer and never want cache loaded then

enter the following into your address bar

about:config

Tell it you understand it is dangerous

enter cache into the search bar and look for

browser.cache.disk.enable

Read about what it does here

http://kb.mozillazine.org/Browser.cache.disk.enable

clicking it sets it to false

This will make firefox slower but will work

You can use this as an alternative

browser.cache.check_doc_frequency

read about it here

http://kb.mozillazine.org/Browser.cache.check_doc_frequency

basically the settings are

0 Check for a new version of a page once per session 1 Check for a new version every time a page is loaded. 2 Never check for a new version - always load the page from cache. 3 Check for a new version when the page is out of date. (Default)

but this does not work so well for me

Note that

browser.cache.disk.enable

must be set to true for

browser.cache.check_doc_frequency

to make any difference

Note that your ISP may be caching, if so consider using different nameservers like openDNS or Google DNS

Modified by FedUp