Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why must I re-enter my password on almost every yahoo mail action.

  • 3 replies
  • 2 have this problem
  • 1686 views
  • Last reply by cor-el

more options

In Yahoo Mail Classic about every 1-2 actions, reply, send or open in a new tab, I am required to re-enter my password. When I re-enter my password, if I am sending or forwarding, I lose what I have entered and get a blank new email. This only happens in FireFox. When using Explorer I have no re-enter password requests. I don't have any passwords saved in anything. I use clear history and cookies when closed. I am using 13.0.1.

Chosen solution

This can be caused by the connection settings having the default setting.

Try to select the "No Proxy" setting instead of the default "Use the system proxy settings" setting.

  • Tools > Options > Advanced : Network : Connection > Settings
Read this answer in context 👍 2

All Replies (3)

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

more options

I am now getting to enter my password to delete an email. That maybe new. There wasn't anything in my history, but I followed your instructions and I have done a CC Cleaner scan, a malwarebytes scan and an essentials scan. All came up clean. Any other ideas? Thanks, Doug

more options

Chosen Solution

This can be caused by the connection settings having the default setting.

Try to select the "No Proxy" setting instead of the default "Use the system proxy settings" setting.

  • Tools > Options > Advanced : Network : Connection > Settings