X
Tap here to go to the mobile version of the site.

Support Forum

I don't see java in Plugins after I install it.

Posted

I installed the jdk 1.6u7, and then I open firefox, I see there is a java console 6.0.07 in extension, but in plugins, there is no java. and I can't open java website, it shows I don't install java in my machine, but actually, I have installed jdk 1.6u7. I think only if the java exists in plugins, the website can get the jvm and run.

it seems it is ok if I install a jdk which will create a plugin in plugins, and the extension can't be used.

I installed the jdk 1.6u7, and then I open firefox, I see there is a java console 6.0.07 in extension, but in plugins, there is no java. and I can't open java website, it shows I don't install java in my machine, but actually, I have installed jdk 1.6u7. I think only if the java exists in plugins, the website can get the jvm and run. it seems it is ok if I install a jdk which will create a plugin in plugins, and the extension can't be used.

Chosen solution

You need the Next-Generation Java™ Plug-In present in Java 6 U10 and later (Linux: libnpjp2.so; Windows: npjp2.dll).

Read this answer in context 1

Additional System Details

Installed Plug-ins

JAVA

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

N/A

Question owner

3 screenshots: extensions and plugins, and the checking java result in java.com

3 screenshots: extensions and plugins, and the checking java result in java.com
dumdidadida 155 solutions 1440 answers

Helpful Reply

Hi,

You would need JRE (Java Runtime Environment) to run Java programs. You can try to click the download button on the page (above image) or you can download the latest version here: http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1637588.html

Hi, You would need JRE (Java Runtime Environment) to run Java programs. You can try to click the download button on the page (above image) or you can download the latest version here: http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1637588.html

Question owner

Thanks for your reply!

I download the jdk file: jdk-6u7-windows-i586-p.exe, after I click it and install, it installed both the jdk and jre, I can see 2 folders: C:\Program Files (x86)\Java\jdk1.6.0_07 and C:\Program Files (x86)\Java\jre1.6.0_07.

Is the JRE in jdk file are different from the pure JRE file? let me try....

And I need to run the oracle forms 12.1.3, it requires JRE 1.6.0_07...

Thanks for your reply! I download the jdk file: jdk-6u7-windows-i586-p.exe, after I click it and install, it installed both the jdk and jre, I can see 2 folders: C:\Program Files (x86)\Java\jdk1.6.0_07 and C:\Program Files (x86)\Java\jre1.6.0_07. Is the JRE in jdk file are different from the pure JRE file? let me try.... And I need to run the oracle forms 12.1.3, it requires JRE 1.6.0_07...
dumdidadida 155 solutions 1440 answers

I think the runtime included with JDK (Java Development Kit) may not extend to web functionality. It may be strictly for development/testing purposes. Please also note that many versions of Java prior to the latest 1.6.33 in the 1.6.x series are automatically blocked by Firefox due to severe vulnerabilities.

I think the runtime included with JDK (Java Development Kit) may not extend to web functionality. It may be strictly for development/testing purposes. Please also note that many versions of Java prior to the latest 1.6.33 in the 1.6.x series are automatically blocked by Firefox due to severe vulnerabilities.

Question owner

install the pure JRE file, the same, can't see plugin in plugins.

then I install jdk-6u16-windows-i586.exe, it works:

Verifying Java Version A newer version of Java is available

Please click the download button to get the recommended Java for your computer. Your Java version: Version 6 Update 16

so... I can only understand as that the firefox 13.0.1 does not support java 1.6.0_07...

install the pure JRE file, the same, can't see plugin in plugins. then I install jdk-6u16-windows-i586.exe, it works: Verifying Java Version A newer version of Java is available Please click the download button to get the recommended Java for your computer. Your Java version: Version 6 Update 16 so... I can only understand as that the firefox 13.0.1 does not support java 1.6.0_07...
dumdidadida 155 solutions 1440 answers

Possibly it could be like that :)

Possibly it could be like that :)
cor-el
  • Top 10 Contributor
  • Moderator
16657 solutions 150560 answers

Chosen Solution

You need the Next-Generation Java™ Plug-In present in Java 6 U10 and later (Linux: libnpjp2.so; Windows: npjp2.dll).

You need the Next-Generation Java™ Plug-In present in Java 6 U10 and later (Linux: libnpjp2.so; Windows: npjp2.dll). *http://java.com/en/download/faq/firefox_newplugin.xml
AliceWyman
  • Moderator
236 solutions 2545 answers

Helpful Reply

Like cor-el said, you need the "Next Generation" Java plugin found in Java 6 Update 10 and above. The Java Console you see in the Extensions list is an outdated add-on for Java 6 Update 7, which is a version of Java that is too old to work in Firefox.

Additionally, older versions of Java may be blocked by Firefox for security reasons so you should make sure Java is up-to-date.

The Java Update feature lets you check for updates from the Java (32-bit) Update tab in Windows Control Panel. To update java manually, go to http://java.com/en/download/index.jsp and download the latest version of Java, currently Java 7 Update 5, then close Firefox and run the installer. You will then see Java(TM) Platform SE 7 U5 in the Firefox Add-ons Manager Plugins list when you next open Firefox. You can check your Java version using the test links here.

If for some reason you need the Java Development Kit (JDK), rather than the JRE that you need for Firefox and other browsers, you can get it here:

For more information see:

Like cor-el said, you need the "Next Generation" Java plugin found in Java 6 Update 10 and above. The Java Console you see in the Extensions list is an outdated add-on for Java 6 Update 7, which is a version of Java that is too old to work in Firefox. Additionally, older versions of Java may be blocked by Firefox for security reasons so you should make sure Java is up-to-date. The [http://www.java.com/en/download/help/5000020700.xml Java Update] feature lets you check for updates from the Java (32-bit) Update tab in Windows Control Panel. To update java manually, go to http://java.com/en/download/index.jsp and download the latest version of Java, currently Java 7 Update 5, then close Firefox and run the installer. You will then see Java(TM) Platform SE 7 U5 in the Firefox Add-ons Manager Plugins list when you next open Firefox. You can check your Java version using the test links [http://kb.mozillazine.org/Java#Testing_Java here]. If for some reason you need the Java Development Kit (JDK), rather than the JRE that you need for Firefox and other browsers, you can get it here: *http://www.oracle.com/technetwork/java/javase/downloads/index.html For more information see: *[[Use the Java plugin to view interactive content on websites]] *[[Old versions of Java have been blocked - update and unblock Java]] *http://kb.mozillazine.org/Java

Modified by AliceWyman

Question owner

Exactly, it support the version after 6u10, and I found the support information in meta link of oracle. I installed 6U32, it works fine.

Thanks all for help.

Exactly, it support the version after 6u10, and I found the support information in meta link of oracle. I installed 6U32, it works fine. Thanks all for help.