X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

missing option to show blocked popup

Posted

sometimes when a popup is blocked and I get the yellow bar, when I click Preferences button the right, I don't get the fourth option in the menu, to show the blocked popup. seems to only happen on certain sites, like this one: http://www.sixstardj.com/esigihdhiqu2.html (click on the photo).

should i report this as a bug?

Modified by sumguy

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Helpful Reply

I actually get the enlarged image pop-up right away, no bar at all. I wonder why the difference?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

That popup opens via a JavaScript:

So make sure that you aren't blocking JavaScript if the pop-up isn't working.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

a999.1 0 solutions 1 answers

No kidding. Pop-up blocker has to be on by default, or the web in unusable, because if you hit the wrong site by mistake, your desktop will immediately be so full of advertising windows popping up and moving around.

There are various secure financial sites where reports are generated on request. These are slow sites that tend to bog down from time to time, and a request might take 5-10 minutes, and then a window is supposed to pop up with the report when it comes back, because you might be working on something else by that time.

The lack of an option to show the blocked pop-up means I have to put in another request after enabling pop-ups for that domain and wait another 5-10 minutes while the report is generated all over again, which further bogs the server down for everybody else, too.

Yes it's still open source, but unfortunately, Mozilla plays with the big boys now, and they don't listen to users anymore. When something like this doesn't work right, I have to assume it's not so much a bug as that functionality has been crippled because it doesn't fit one of their partners' business plans.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi a999.1, how do you know a pop-up was blocked if you don't get an infobar: have you tested that same site with the pop-up blocker turned off and on, and you get consistent success and failure, respectively?

You can give any site explicit permission to display pop-ups so you don't have to completely open up the browser.

(1) If the popup source is the same domain as the page itself, while viewing a page on the site, right-click and choose View Page Info > Permissions (or on the menus use Tools > Page Info)

Uncheck the "Use default" checkbox and choose Allow. Then close the dialog.

(2) If the popup is not from the identical domain, you can add its domain in the Exceptions dialog to the right of "Block pop-up windows" here:

(WIN) orange Firefox button or classic Tools menu > Options > Content
(MAC) Firefox > Preferences > Content
(LINUX) Edit > Preferences > Content

As for "partners' business plans," I have no idea what partner wouldn't want the pop-up blocker to work as designed.