X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I remove MyStart:Incredibar ?

Posted

I have an issue with one of my Firefox extensions/plugins, it's called MyStart: Incredibar, and I basically installed unintentionally when I installed a program with a Brothersoft downloader/launcher. I tried uninstalling Mystart and I tried permanently stopping the service that updates the MyStart incredibar plugin. What it basically does is, when I open a new tab in Firefox, it opens some sort of website, I don't have a problem with it loading a search engine, the only problem I have regarding the search engine is that every time I open a new tab, it actually loads a new page. I even tried resetting the certain figures in about:config which helped temporarily, but after I restart Firefox then it still runs the search engine when I open a new tab. I use Eset Nod32 and Anti-Malmwarebytes as my system's defense, and I've tried scanning with both of them but they don't help at all, does anyone have information that will permanently remove this plugin from my PC?

Screenshot of this problem can be found HERE

My About:Config settings looks like THIS

Modified by CntrlAltDel

Chosen solution

I've removed it from Explorer and Chrome, but not so lucky with Firefox. Same problem: when I open a new tab it appears (with iPhones dancing across the bottom of the screen). I actually thought Spybot S&D had removed it as it found something in the registry, but no.

Looking at about:config, I have about 60 lines all starting with extensions.incredibar. As you say, changing things don't stay changed. I've deleted the address that it goes to but it makes no difference. Has to be something else in the registry.

I'm thinking the only way is to save bookmarks and reinstall Firefox. ugh. I'll keep at it.

Read this answer in context 31

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

IndyGent 0 solutions 1 answers

After searching for days and trying a number of things, I uninstalled firefox. That did it! (It's like getting rid of a headache I've had for a month!!!) When I reinstalled Firefox, though it was back. I don't know what it piggy backed, but I uninstalled it again. Again, it's gone. I'll find another search engine, but it won't be Firefox!!

joabba 0 solutions 1 answers

Very helpful! It has been annoying me for ages. Thank you very much.

Wynter 1 solutions 10 answers

IndyGent - ??? Firefox isn't a search engine! If the program is still there then it's going to attach itself to Firefox again. Go to Add/Remove programs (or use CCleaner's removal (much faster) and look for any of the names mentioned in this thread; remove any you find THEN reinstall Fireox. :)

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6638 answers

For anyone affected by Mystart, try the following:

Uninstall any Unwanted Programs

  1. Click Start
  2. Click Control Panel
  3. Go to Uninstall a Program (It may be called Add or Remove programs or something different based on your Windows versoin)
  4. Uninstall anything related to Mystart, Incredibar, etc.

Scan for Viruses You can try some of the following programs to scan for malware:

Reset Firefox Reset Firefox to restore Firefox to it's default settings. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

princess18 0 solutions 1 answers

aggelosy - your reply was really useful - thanks!

Modified by princess18

3400FerrariItalia 0 solutions 2 answers

I have figured out how to remove Mystart Incredibar. Go to this site for more details. I just made the blog. This should help. If not, I'm sorry. That could help you with your problems. This will work for only Mozilla FIrefox. Best Regards, 3400FerrariItalia

www.incredibarremoval.blogspot.com

3400FerrariItalia 0 solutions 2 answers

Here is a Set By Step Instruction for Removal of Incredibar

www.incredibarremoval.blogspot.com

cooldriver 0 solutions 2 answers

here u goo.... this video shows how to remove incredibar completely from all your browswers including firefox:

http://www.youtube.com/watch?v=sHHXPuCMRjc

cooldriver 0 solutions 2 answers
).......

Modified by cooldriver

pier4r 0 solutions 1 answers

Ok the solution is: First remove incredibar from addons, search engine and home page as written in http://deletemalware.blogspot.it/2012.../remove-mystart-by-incredibar-uninstall.html ; then the last step will be "remove incredibar as newtab".

Follow [This step (from mozilla support)] then search, using the same folder that contains the user.js file, all pref.js files. Open each of them with notepad, search for incredibar and delete all entries.

Modified by Noah_SUMO

michaelw60 0 solutions 1 answers

Hi there,

I had the same problem.

I reset Mozilla to default (go to the help section) and now I have to install my add-ons again :(

I also had it in chrome. I changed all the setting as recommended in this thread and followed instructions on a youtube video

That didn't work so I then checked the extensions in chrome and saw one called 'New tab for Chrome™'. I disabled this and thankfully it is now removed!

Hope this helps, Michael

Damo 0 solutions 3 answers

Hi, I had this problem too, running Firefox 14 and despite doing every step all the other forum threads told me to, I found that Incredibar was still hijacking my New Tab page. First do all the uninstalling etc, but don't bother editing your about:config, as the bloody thing will just reset every time you restart Firefox. So, solution - somewhere on these support pages someone mentioned that it may have been attached to other add-ons. He suggested going through one by one till you find the infected add-on. Not necessary as I have found that every add-on is infected. If you go to your profile folder in Windows (or my favourite Cubic) Explorer and search for every file named prefs.js. Most add-ons and Firefox itself have this file. Open each in notepad and search with in the text for "incredibar", delete all lines featuring anything to do with it, then save the files. Ta da, Incredibar is gone.

comgeek888 0 solutions 12 answers

Mystart.incredibar is a malicious browser toolbar , it is classified as a browser hijacker because of its hijacking activities. As we know, it redirects webpages and search queries to wrong websites, it is an annoying and harmful malware. Moreover, if once installed, you wont be able to uninstall mystart.incredibar using control panel because it is a maware and it protects itself from being removed. To get rid of MyStart:incredibar, you have to run an anti-malware program on ur PC. it can also be removed manually as instructed here in http://www.techvts.com/mystart-incredibar-redirect-removal

ayapa7 0 solutions 1 answers

Good Solution and permanent solution:

search for the link in mozilla installed location i you hard disk: ex: mystart.incredibar.com/mb165?a=6PQIiNRfL2&loc=FF_NT

or else which link you are getting while selecting new tab in firefox

I think you may get the below mentioned files.then

Delete prefs.js and sessionstore.js file in Mozilla installed location.

or else delete the files which contain the incredibar link.

restart the firefox..you problem ll be solved.

Modified by ayapa7

Damo 0 solutions 3 answers

Great advice, ayapa7, but I tried that and found eventually that this darn thing actually installs itself into every add-on you have installed too. So deleting Firefox's pref.js etc only works if you have no add-ons. When you restart Firefox with add-ons, the toolbar re-writes the config settings and resets your newtab address. I found you have to delete the "incredibar" lines out of every prefs file for each and every add-on. Time intensive, but it works.

koromyst 0 solutions 1 answers

I have suffered with the same issue. I keep having to reset all values daily in Firefox's about:config. However, if I closed Firefox then opened it again, the Incredibar crap will reappear and I have to do the reset all over again. In the end, editing about:config was eventually just a temporary solution. I've also did the remove add-on/extensions from Firefox like Web Assistant and stuff. I've also deleted all registry keys containing the word "incredibar" in my windows registry. But Incredibar just kept on reappearing.

Fortunately, I've found another workaround to the problem. These steps are what I did to finally get rid of the annoying Incredibar. This method will require you to edit some items in your Firefox Profiles folder. It's a long process though ;)

First off, check to see if your PC is infected with the svciyyyt.exe trojan.

  1. Start+Run / Win+R
  2. Type in services.msc and click OK
  3. Scroll down to find the trojan and remove/disable it
  4. Close the services window

I found that out by accident. I was looking at the process list in my task manager and found one that I was not familiar with (svciyyyt). Did a quick search and found out that it might be a backdoor/entrance to enable malwares/trojan infect my PC unknowingly.

Then,

  1. Open MyComputer and type in C:\Documents and Settings\[Your PC Account Username]\Application Data\Mozilla\Firefox\Profiles. Example: C:\Documents and Settings\koromyst\Application Data\Mozilla\Firefox\Profiles
  2. Click on the .default folder
  3. Copy your User.js and Prefs.js files and place them on your desktop. These will act as backups in case anything goes wrong.
  4. Go back to the Profiles folder. Open your existing (original) User.js with Notepad. Check to see whether it's loaded with Incredibar crap. Mine was. So I deleted the whole thing in there and replaced it with just one line, which is: user_pref("browser.newtab.url", "http://www.google.com.my"); Then saved it to confirm the change.
  5. Open the existing (original) Prefs.js with Notepad. Ctrl+F and type in browser.newtab.url. Set the url to the homepage of your choice. Mine was google so I copy-pasted the user_pref that I did in my user.js. Then save to confirm the change. If you want, you can do a Ctrl+F and type in Incredibar (or mystart) and delete the lines containing the item. DO NOT modify anything else besides that.

By the way, among the lines I saw in the Prefs.js, several lines containing random letters and numbers caught my attention: {336D0C35-8A85-403a-B9D2-65C292C39087} Did a quick search and found out that it's an Incredibar-related extension. Deleted the lines without thinking much. Then regretted it thinking omg will my firefox break down or something?! Fortunately, it didn't and I was able to breathe normally again =D

Next is to check on the extensions folder.

  1. Open MyComputer and type in C:\Documents and Settings\[Your PC Username]\Application Data\Mozilla\Firefox\Profiles. Example: C:\Documents and Settings\koromyst\Application Data\Mozilla\Firefox\Profiles. (If the Profiles folder is already opened just skip to step 3)
  2. Click on the .default folder
  3. Rename your existing "extensions" folder. Example: Rename "extensions" to "extensions__"
  4. Create a new folder and name it "extensions"
  5. Move one item in the old extensions folder to the new one. Open the Firefox browser and click on new tab to see if MyStart Incredibar page loads. If it doesn't, then the extension is safe to use. Close the browser
  6. Repeat step 5 to move the remaining extensions into the new folder
  7. If one of the extensions causes the Incredibar to load, then delete the extension as it might be the cause why Incredibar keeps reappearing again and again

Finally, I'm not a user of Incredimail, so when finding out that the said item was in my PC, I decided to have a go and remove the item. To remove the item, I had to go into my windows registry.

  1. Win+R / Start+Run
  2. Type in "regedit"
  3. Highlight My Computer and Ctrl+F and type in Incredimail. The search might take a while. Once the result(s) appear, delete Incredimail. (At the same time, I've found out a list of spam domains as well residing in my pc. Darn it.)

I'm not sure what will happen if I remove it but as of current, anything starting with "Incredi-" drives me insane so I think it's best that I get it off my PC to ensure my sanity is still intact =P

.....

I can't guarantee that these methods will work for you but they definitely worked for me. My tab now loads normally and shows my default homepage. My restless nights are now over. Lol. I'm not an expert in malware removal. The steps I've taken were mostly a mashed up of "how to remove incredibar"s. I was that desperate so I tried every solution possible =P

And I didn't have to uninstall and reinstall my Firefox =D

Good luck!

Explainafide 0 solutions 2 answers

That worked a treat- thanks for the advice Mr. Hussy!

cmackenzie 0 solutions 3 answers

-i have done everything suggested. everything was there (my start and/or incredible). -tried changing items mentioned, but not successful. -ran advanced system care 6 (usually great results, nothing detected).

-ran malwarebytes anti malware. it found three lines with five bugs in total (refer to screen shots pages 5, 6, 7, and 8) -names had nothing to do with the mystart or incredibar identity names(refer to screen shot 9) -this deleted "my start" toolbar. nothing else.

-then i got into blank:config. (refer to screen shots 1, 2, 3, and 4) -i found 54 lines infected. three that were separate, (refer to screen shots 3 and 4 for a sample of before and after) i was able to change. -the rest, i found as a block, one after another. -these i could not affect. -i tried the double right click. nothing. -the window that came up listed: modify, copy, copy name, copy value, new, reset - i would hit modify and reset repeatedly until it altered, then changed. -the items in the block would not change at all.

cmackenzie 0 solutions 3 answers

i do believe i have the cure for mozilla firefox.

go to "HELP"up at the top. click on "Trouble shooting Information". click on "Reset Firefox" in the big box, on the left, at the top. all basic stuff is automatically saved. everything about "my start" and "incredibar" in the "about:config" is gone. to get to "about:config" , go to your address bar and type it in. scroll and it will/should be, gone.  :) YES!!!

takes less then twenty seconds. i have been working on this for three days.

PLEASE, contact the companies that advertise with them, and voice your displeasure.

mcquicker 0 solutions 2 answers

My problem is that MyStart only comes up with the plug in FVD Speed Dial with Full Online Sync. When installed, this plug in has a search box and even though mystart or incredibar is not present in my system, if you do a search within the FVD Speed Dial search box it will link to MyStart.

I would greatly appreciate a way to remove this poison from the plugin because FVD Speed Dial is a very useful tool and it would be terrible that people stop using it because of it being hijacked.