X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I remove MyStart:Incredibar ?

Posted

I have an issue with one of my Firefox extensions/plugins, it's called MyStart: Incredibar, and I basically installed unintentionally when I installed a program with a Brothersoft downloader/launcher. I tried uninstalling Mystart and I tried permanently stopping the service that updates the MyStart incredibar plugin. What it basically does is, when I open a new tab in Firefox, it opens some sort of website, I don't have a problem with it loading a search engine, the only problem I have regarding the search engine is that every time I open a new tab, it actually loads a new page. I even tried resetting the certain figures in about:config which helped temporarily, but after I restart Firefox then it still runs the search engine when I open a new tab. I use Eset Nod32 and Anti-Malmwarebytes as my system's defense, and I've tried scanning with both of them but they don't help at all, does anyone have information that will permanently remove this plugin from my PC?

Screenshot of this problem can be found HERE

My About:Config settings looks like THIS

Modified by CntrlAltDel

Chosen solution

I've removed it from Explorer and Chrome, but not so lucky with Firefox. Same problem: when I open a new tab it appears (with iPhones dancing across the bottom of the screen). I actually thought Spybot S&D had removed it as it found something in the registry, but no.

Looking at about:config, I have about 60 lines all starting with extensions.incredibar. As you say, changing things don't stay changed. I've deleted the address that it goes to but it makes no difference. Has to be something else in the registry.

I'm thinking the only way is to save bookmarks and reinstall Firefox. ugh. I'll keep at it.

Read this answer in context 31

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

dumdidadida 172 solutions 1436 answers

Helpful Reply

Hi,

You can try to right-click and Reset or Modifythe value of browser.newtab.url in about:config

about:config Entries

If it reverts back, please see this.

You can also try to Remove or Disable it in Firefox Tools (Alt + T) > Add-ons > Extension, if present.

Question owner

I've done that before, it works temporarily, when I restart firefox then the new tab still opens that search engine

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96785 answers

See:

IncrediMail Help Center: How do I remove IncrediMail MyStart from my Firefox Internet Browser?

Question owner

That's not the same thing

Wynter 1 solutions 10 answers

Chosen Solution

I've removed it from Explorer and Chrome, but not so lucky with Firefox. Same problem: when I open a new tab it appears (with iPhones dancing across the bottom of the screen). I actually thought Spybot S&D had removed it as it found something in the registry, but no.

Looking at about:config, I have about 60 lines all starting with extensions.incredibar. As you say, changing things don't stay changed. I've deleted the address that it goes to but it makes no difference. Has to be something else in the registry.

I'm thinking the only way is to save bookmarks and reinstall Firefox. ugh. I'll keep at it.

Modified by Wynter

dumdidadida 172 solutions 1436 answers

Hi Wynter,

If you have the particular Extension you can try to Disable it in Tools (Alt + T) > Add-ons as well as change the new tab address.

Wynter 1 solutions 10 answers

Hi dumdidadida!

That's the strange thing: I have just 2 extensions (After the Deadline and Rainbow), so it doesn't make sense that Incredibar isn't listed as one of them if it's there in about:config. A puzzle that would tax Sherlock Holmes, for sure. :)

Thank you!

Lotharius 0 solutions 5 answers

I have the same problem and I'm running out of ideas. Have also started with about:config to reset all related user settings, running scanns with spybot and Malwarebyte repeatedly. I know that in my case the malware has been installed by installing pdfcreator from the sorceforge net page. I have removed the program but it was meaningless because incredibar gets started from a separate source. Then I have searched wit the explorer all files related to incredibar, mystart and softonic and deleted - even the cookies. I have checked after all the IE which I don't use. It is clean now, starting with a blank page. The problem is to clean the firefox and I hope Mozilla will investigate and deliver an update.

Wynter 1 solutions 10 answers

I took the plunge. Saved my bookmarks and reinstalled. I thought it was going to be painful but it wasn't. Less than 10 minutes and Firefox is back. Incredibar is no more.

)
Lotharius 0 solutions 5 answers

I did exactly what you recommend and it's working great although I have restarted FF several times now. Thanks

akuhlmann83 0 solutions 1 answers

Hello All - I never ever respond to these posts, but the incredibar was so annoying that when I figured out how to remove it, I felt I needed to spread the knowledge.

So first I went to my start menu and went into the control panel. Once in the control panel I went to Programs and there should be an option to Uninstall Program. From there I searched for the Incredibar program and the Mystart Incredibar program. You may want to sort by date because I noticed when I got into the programs that there were a few different names for the program and when I only deleted 1 it didn't work. All of my programs were apparently downloaded on the same date.

After I deleted the programs I opened my Firefox window and in the left hand corner of the window is the orange Firefox drop down menu - click on that and go to Options and it will pull up another drop down menu and click on Options again and it will open a window. Once that Window is open you need to click on the Restore Default button and then click OK and it should get rid of the Incredibar.

I had the Incredibar on my Explorer as well and it didn't go away until I set IE back to its default settings as well.

I hope this was helpful!!!

courtneyb 0 solutions 1 answers

I had this problem and tried several suggestions including resetting the user settings in about:config and system restore. What worked for me was to hover over Help in the Firefox window, click Troubleshooting Information, and then Reset Firefox. It saved all of my bookmarks and cookies, but the Incredibar is gone. Hope this helps!

Lotharius 0 solutions 5 answers

... thanks for the link, the page looks useful but also in case of (hopefully not) future problems. Although I have solved the problem by removing and reinstall FF, I will keep it in my bookmarks.

da_madog 0 solutions 2 answers

ill give it ago :P

Modified by da_madog

da_madog 0 solutions 2 answers

thank you so much yours was the most helpful one out and you fixed my problem you are the best!! just for everyone that reads this it dose save all you info so don't be scared to try it REALLY WORKS!!

kingnothing 0 solutions 1 answers

The only way I have found to fully remove Mystart is a system restore. Good Luck!

mummylinda 0 solutions 4 answers

bless you , this came in one the back of an AVG free program and I am now free of issues , and a new computer too. thank you all.

Modified by mummylinda

kenneth28 0 solutions 3 answers

Hi Unistall Mozilla Firefox and then install it again(before this you should also remove -uninstall-incredibar and myspace from controlpanel-programs,and possibly reset default browser in about:config). Best of luck Kenneth

hussy-ameer 0 solutions 2 answers

Helpful Reply

'* I GOT SOLUTION :) '

  1. Simply follow the instruction below.
  2. Open your Firefox tab, Write this ( about:config ) in search bar for open website (example www.google.com)
  3. Now it will ask you for promise, Simple click on " I'll be careful, I promise! "
  4. it will bring you on new page, at the top you can see a Search Bar ( for search any content )
  5. Click on that bar and write this " mystart " and hit enter
  6. it will bring round about 5 to 6 configuration lines '(BOLD TEXT )''''
  7. Double right click on that first line and delete all text is written inside that,
  8. Do this same thing on all listed configuration lines.
  1. Now, you should happy.
  1. mystart has gone from your Firefox for forever until you dnt install it again :)
  1. '''''''''''''''''''Let's Dance, ( MUSIC ) A_A_A_ Balck and yellow , Black yellow :) Everything i do, i do big lol :)'''''''''''''''''''

Modified by hussy-ameer

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6640 answers

For those of you who are infected By MyStart, these steps should help you remove it fully:

  1. Open Firefox. Type about:addons into your address bar, press Enter. Click on Extensions, then Remove any MyStart or other unwanted toolbars and extensions. Restart Firefox.
  2. Install https://addons.mozilla.org/en-US/firefox/addon/searchreset/
  3. Download and Install MalwareBytes Anti-Malware, run a full Scan. http://www.malwarebytes.org/. This helps check that there are no viruses on your computer causing issues. You can uninstall this program after you clean off any infections.

This should help fully remove MyStart. Another technique that you can do is to do a Full Firefox Reset. Reset Firefox – easily fix most problems