X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 13 SLOW to load pages

Posted

just updated to Firefox 13.0 on my mac last night (no plugins so don't blame them!).. man its SLOW SLOW SLOW. Slow loading pages, Slow to load, and slow to open java (even more so then before!) I have an i5 CPU and 8 GB of 1333 Mhz ram in my macbook pro... whats going on.. seems every new release is slower and slower!

P.S. I switched to chrome because of this.. works lightning fast in comparison!

Chosen solution

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:


Read this answer in context 4

Additional System Details

This happened

Every time Firefox opened

This started when...

After firefox 13 update

Installed Plug-ins

NOT A ONE!

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

every site. no matter what.. no plugins 8 GB ram i5 CPU with NOTHING else running!

Rosana
  • Administrator
  • Moderator
7 solutions 38 answers

Hey scottyontarion,

I'm sorry you're having trouble with Firefox. So we know it's not your plugins, but a couple of other factors could be slowing Firefox down. Check this list to see: Firefox is slow - How to make it faster Firefox uses too much memory (RAM) - How to fix

Do you have any additional information?

We would also thank you if you can submit us the performance data to get better.

gregorys 1 solutions 15 answers

Hi Rosana, I have the same problem Firefox 13 is extremely slow there are many web sites with not loaded images/css/ and even can't load entire web sites. I tried to disable/enable plugins/extensions/ SPDY but nothing changed. My CPU usage is below 20% and my RAM usage is only 1 GB from all 4GB. My OS is WinXP + SP3 with latest updates.

I checked inaccessible sites/urls with other web browsers and all works perfectly even in Internet Explorer 6 works fine !?

This is for example one url can't be loaded correctly I'm forced to wait and see only white blank window and after 10-15 min page is loaded http://www.adobe.com/software/flash/about/

I'm forced to use another browser and I'll try soon to go back to the FF3.6 and re-import my profile. Sorry but I have no more reasons to use FF13 :-(

Modified by gregorys

yemonyime 0 solutions 1 answers

Helpful Reply

(iMac, i7) Firefox 13 runs just fine when booted. However, if I sit idle and allow my screen to dim, or enter sleep mode...all other programs return to full speed after wake-up except for FF13. Typing text, switching windows, and even quitting the program lags horribly and does not recover to speed. I must force quit and re-open FF13 to get back to functionality, losing anything in shopping carts or text boxes. This is simply not usable, so please solve this quickly. I love Firefox, and it's a pain to export bookmarks. But under the circumstances, I've really got no choice but to start the process of switching to another browser.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Try to disable IPv6 in Firefox:

gregorys 1 solutions 15 answers

I tried to disable IPv6 in Firefox 13, there is some improvement in speed, but it doesn't solve problems. There are still inaccessible and partially loaded web sites.

For partially loaded web sites I need to do 5-6 reloads and wait between each reload until entire page is loaded and fully cached. Cache size is automatic. Page load speed is extremely slow for all web sites that I visit and a lot of images left not loaded with empty place holders. I've checked missing images in about:cache and they are cached but not displayed it's necessary to do many page reloads and wait. All of this makes impossible normal work with FF13.

Example url -> http://www.adobe.com/software/flash/about/ I see this "Transferring data from wwwimages.adobe.com ..." and nothing more.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

If there are any network.http prefs that are user set then try to reset them.

  • Open the about:config page via the location bar and do a search for network.http via the Search bar at the top of the about:config page.
  • Reset all network.http related prefs that appear bold (user set) via the right-click context menu to their default values.
Im_iLLiN 1 solutions 9 answers

Helpful Reply

my firefox froze up for 25 minutes. i let it sit there just to see how long it would stay frozen. it seems with each update this browser gets worse and worse

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Chosen Solution

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:


gregorys 1 solutions 15 answers

Great ! It works and finally I discovered the cause of problems. Many thanks to Cor-el ! Yesterday I decide to go from FF3.6 to FF13 keeping old profile. I checked prefs for network.http and the reason is that Fasterfox Lite 3.9.6 Lite actually breaks all things. All settings and optimizations are fine only for FF3.6 but no more compatible with FF13.

Thanks again Co-rel. Author of Fasterfox Lite must be informed about this issue! This makes unusable FF13.

I only just opened this file (prefs.js) and discover a lot of garbage from old and even uninstalled / removed addons. Not sure but I hope that I shouldn't have more problems from my old Profile.

Modified by gregorys

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

It is best to delete the prefs.js file and redo all the option settings to clear out old settings and obsolete prefs.

cem07 0 solutions 10 answers

My notebook uses Windows7 home basic and has no activex or ext. None of solutions solved my problems, I can't watch video, slow, frozen. uninstall - install programs firefox and flash player several times and I'am tired. Solutions are giving new problems. And I wonder how it's written it solved. I am using Firefox for years with pleasure but now I'll begin to use Chrome till problems solved.

paulljames 0 solutions 5 answers

What version of Flash are you running? Flash 11.3 does not play well with FF13. If this is what you have (and you just might, it is the "recommended" version for FF13), try to uninstall and install v.11.2. This worked beautifully for me.

jsm1963 0 solutions 10 answers

After spending the past hour trying to load Google Calendar without getting close, I went back to version 12. Not a problem now.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

You can check the network.http.* prefs (network.http.proxy.keep-alive -> true) and reset all bold user set network.http prefs to the default value via the right-click context menu > Reset.

rainhorse1 0 solutions 2 answers

Here's my solution:

1. Install Firefox add-on "Toolbar Buttons." https://addons.mozilla.org/en-US/firefox/addon/toolbar-buttons/ [It's a great add-on to have anyway]

2. Insert the Toggle Flash button on one of your toolbars. This will allow you to switch Flash on and off very quickly.

3. Keep Flash switched off except when you really need it.

4. Switch it off again immediately when you no longer need it.

It's really easy and it solves the problem.

However, the slowdown IS A HUGE ISSUE and Firefox and Adobe need to sit down and solve it immediately, or tons of people will switch to Chrome and they won't come back.

Modified by rainhorse1

firefoxfaithful 0 solutions 1 answers

After about 18 hours of struggling with pages loading slowly line-by line each time my pointer moved on the scrollbar, uninstalling and re-installing Firefox (and even Safari, which was very slow), the solution worked perfectly, it was EASY, and now my Firefox is blazing fast and retained my personal bookmarks, passwords too.

I downloaded the Firefox 13 inst. package on my desktop. Then,

I used the free program Revo Uninstaller Pro, to both uninstall, AND install Firefox.

I'm so happy it responds now so fast, loads pages correctly!!!! I added the Ad Block Plus, and the FT DeepDark theme, and I'm almost in tears from being so grateful everything works so well.

I also used Revo to get rid of many left-over files from my previous un-installations, and it did an incredible job. Great, user-friendly interface too, so good for a non-techie like me.

As a side note, I had THE most horrible time trying to uninstall Lavasoft's Ad-Aware program:

They have re-tooled it and now it behaves like those malware programs that get everywhere in your computer, and their uninstaller does not remove it. Plus it downloaded the free preview of the paid program, instead of the free Ad-aware one. It had crept into my anti-virus program, and into Firefox, the computer was crashing trying to uninstall it, but finally Revo got rid of it.

Never again Ad-Aware.

Modified by firefoxfaithful

rainhorse1 0 solutions 2 answers

The above workaround by me (two posts up from here) does not always work.

Here's an extra step that makes it work all the time and is easy

1. Install add-on Toolbar Buttons as above.

2. Add the flash button to your menubar and then disable Flash (color turns from red to grey.)

3. Install IE Tab 2 for Firefox.

4. When you reach a site where you want the flash to play, right click on the tab and choose "Switch rendering engine." It will switch that tab alone to Internet Explorer and Flash will work in that Tab and be disabled elsewhere. Firefox works nice and fast with this workaround.

Modified by rainhorse1

dckrl 0 solutions 1 answers

Turn off hardware acceleration (Options-Advanced-General/Browsing). Most of the issues revolving around a browser or a video being sluggish originate with hardware acceleration, as far as I can tell from my experiences

mikhailt 0 solutions 1 answers

I have same problem on Windows 7 x64. After upgrade to FF13 browser is frosen for some minutes! before open almost every page.

I tried to disable addons, then uninstall all addons and plugins. I cleared cache and remove all Mozilla folders. Then tried a totally fresh FF install. I removed hardware acceleration, I removed IPv6 support. Nothing helpes.

FF 13 is slow when opening pages. No other browser is slow at all. And it has nothing to do with Flash. I do not have Flash installed at all.

Modified by mikhailt

rplotner 0 solutions 2 answers

The reason Firefox takes soooooo long to load up is because it's loading your HUGE browsing history. I cured this problem by configuring the Privacy section in Options. I did the following:

1.From the menu bar, open Tools>Options>Privacy

2.Under History/Firefox will: select "Use custom settings for history"

3.Un-check "Remember my browsing and download history". Leave the cookie settings (until they expire) and "Search and form" settings - you don't want to lose that important info, or you'll have to relogin every time you open your email, or go to payment checkout at Amazon, etc...  ;-)