X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 13 SLOW to load pages

Posted

just updated to Firefox 13.0 on my mac last night (no plugins so don't blame them!).. man its SLOW SLOW SLOW. Slow loading pages, Slow to load, and slow to open java (even more so then before!) I have an i5 CPU and 8 GB of 1333 Mhz ram in my macbook pro... whats going on.. seems every new release is slower and slower!

P.S. I switched to chrome because of this.. works lightning fast in comparison!

Chosen solution

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:


Read this answer in context 4

Additional System Details

This happened

Every time Firefox opened

This started when...

After firefox 13 update

Installed Plug-ins

NOT A ONE!

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

every site. no matter what.. no plugins 8 GB ram i5 CPU with NOTHING else running!

lapkopdung 0 solutions 3 answers

check your conect internet.

Modified by cor-el

gokugirl 0 solutions 1 answers

I also had this problem, but I managed to resolve it. I tried the possible solutions posted by rard and cor-el (both the IPv6 and the about:config property resetting), but FF 13 was still slow. I'd previously used Fasterfox (or the Lite version, I can't remember which) for FF 3.6 so I assumed that resetting the network config properties would fix the slowness, but it didn't. Feeling desperate, I installed Fasterfox Lite for FF 13 and now websites load almost as fast as they do in Chrome even when the site uses Flash. I use the "Courteous" setting and I disabled both link prefetching and IPv6 lookups.

By the way, I tend to keep browsing history for months at a time, I have more than 15 add-ons enabled and over 10 plugins enabled, and I'm a heavy tab user (43 tabs are open currently, but not all of them are loaded due to BarTab Lite).

My system: Win 7 Pro x64, 4 GB of RAM, 2.2 GHz dual-core CPU

smcguinness 0 solutions 2 answers

Using Firefox 14.0.1 and it's so slow I thought I had a problem with my ISP provider. When I could break away from having to actually work I decided that I had to test the connection and it didn't seem to be hardware. So I started testing firefox, chrome, IE 9 with speedtest.net -- or I should say many speed test, but the image is from speedtest.

I reset Firefox and re-ran the speed test with the same results.

I need firefox for some web work that I do -- the back-end scripts work better in Firefox, but it's making the time to do the work crazy

Any suggestions would be great, but in the meantime I think I have to switch to IE9 until there is a resolution at least for the things I can.

The preview reply doesn't show the attached image so let me get the numbers.

FireFox -- ping = 438, upload = 1.81 download = 0.90 Chrome -- ping = 184, upload = 9.53, download 4.39 IE 9 -- ping = 57, upload = 25.88, download 13.84

These numbers are crazy -- I should be getting numbers similar to IE 9 as that matches the service I purchased. Additionally, it isn't just the test. IE9 is faster when I am working noticeable faster.

smcguinness 0 solutions 2 answers

problem fixed by clearing the cache under the network tab.

After I did that I received the correct speedtest results.

I am happy now.

Thanks

Jean Hohnstein 0 solutions 2 answers

Gee, there's a lot of us frustrated with this! I've found one trick that seems to work although I have no clue why. When a page doesn't load quickly, I do one of two things and either one seems to fix it. One, I simply "go back one page," then forward -- and usually it's there. Two, I left-click the rendering icon to send me to (urk) IE, which sad to say always opens the page, then back up again.

It would be great if anybody gets a lightbulb-flash out of that weird "solution," but I will not hold my breath. Thanks, all.

wedebugyou 0 solutions 2 answers

I have the answer for you all.

It will work for Mac/Windows/Linux

Windows,

click on tools, options, click on the big advanced icon, then click on encryption tab, then click on validation button.

Still following?

Uncheck "check use online...OCSP"

The problem is ocsp are not ipv6 ready yet. Then firefox timeouts many time before the ssl certificate can be fully validated and it makes ipv6 "slow".

Mozilla can you add an ipv6 ocsp server please?

For mac,

click on the firefox menu, then preferences and follow the sames steps as for windows. Click on the big advanced buttton, then encryption tab, then validation button..

Sounds familiar?

For linux, I guess the steps are similar.

Contact me if you need more help with this issue and or have other ipv6 issues.

John

wedebugyou 0 solutions 2 answers

I did more research and it's not necessary to disable ocsp.

Instead go to about:config and search for this key:

network.dns.ipv4OnlyDomains

Double-click on it and input this list of ocsp servers I found so far. It means query in ipv4 for these addresses.

Let me know if it improves your browsing speed. If not I can post the technical details on how to find out by yourself if it's hanging because of slow ipv6 dns timeout .

Jean