X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Adobe flash player does not work in ff browser. Works in IE, operating Win 7, Firefox 4, Flash 11 . . ?

Posted

I recently upgraded to ff beta and upgraded my adobe flash player and can no longer view flash in browser. Have tried every combination of installing/uninstalling. Everything is running on 64 bit - most up-to-date downloads. What am I missing?

When I open IE, flash works - ruling out problems with flash, and graphics card. So ff, you're on.

Chosen solution

So I figured out that one of my extensions was causing the problem. I've disabled it and now everything works. Thanks for the help with this extremely frustrating issue.

Read this answer in context 0

Additional System Details

Installed Plug-ins

Adobe Flash 11

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

Question owner

Correction: ff 13 and I have tried both the IE and non-IE flash downloads from Adobe. Super frustrating.

SafeBrowser 550 solutions 2392 answers

There are 2 versions of Adobe Flash:

  • an ActiveX version for IE only
  • a Plugin version for most other browsers including Firefox
    • IMPORTANT: Firefox requires the 32-bit version of Flash even if installed on a 64-bit OS -- See NOTE: below
  • On a Windows system, you should always update both individually.

If you do not see, in Add-ons > Plugins > "Shockwave Flash (version)" in Firefox, then you do not have the 32-bit Plugin version of Flash installed for Firefox. If "Shockwave Flash" is there and is disabled, click the "Enable" button.

Check your Plugins often --> http://www.mozilla.org/en-US/plugincheck/

  • only the most popular/used Plugins are known by this page
  • page will detect only installed, enabled Plugins

Install or update Adobe Flash

  1. Using Firefox, go to the following link and SAVE the download to your desktop so you can find it later. Un-check any items on that page that you do not want to download (i.e., "McAfee Security Scan Plus":
  2. When the download is finished, close Firefox (File > Exit OR Firefox button > Exit)
  3. Click or double-click on the file you just saved to your desktop
    • In the installation window that appears, click the box to the left of "I have read and...." to place a check mark in the box
    • The "Install" button in the lower right corner will now be highlighted, click it.
    • The installation is quick.
  4. Start Firefox and test your installation here: https://www.adobe.com/software/flash/about/
  5. To update/install the ActiveX version for IE only, repeat the process, but use IE to go to the above website.


NOTE: Some users of 64-bit systems have found it necessary to download, Save and install (with Firefox closed) the 32-bit Plugin for Firefox manually from the following (4th link labeled "32 bit Flash Player Plug-in (All other browsers)"):


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Modified by SafeBrowser

Question owner

So I installed and ran the 32-bit version of flash and still I get a blank. I have tried disabling graphics acceleration (which I've read may help). Shockwave flash v. 11.2.202.235 is enabled in my plugins. I have no interest in using IE so I'd like to get ff to work in ff. Any other ideas?

Helpful Reply

No still no success with the reset.

vito88 0 solutions 3 answers

Helpful Reply

Last week I installed the FF update and a few days later, the new Flash update. I immediately started having audio 'stuttering' problems when listening to an audio feed, (Minimized in a separate window or not), and simultaneously scrolling on another web page or even just moving the cursor around. (Remember Max Headroom? That's what everything sounded like.)

I tried everything FF said to do to solve Flash problems all the way up to resetting FF. I uninstalled and re-installed the new Flash. No good.

Out of desperation, I switched back to the old Flash 10. and that solved the problem!

However, now I'm stuck with an outdated version of Flash.

So the problem seems to be with Flash, not FF.

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

Make sure you have Windows Service Pack 1 installed. Also, if that does not work, try disabling protected mode in Flash, http://forums.adobe.com/message/4468493#4468493

vito88 0 solutions 3 answers

Whoops - Sorry, I'm running XP not 7. I'll post a new question.

Question owner

Disabled protected mode, tried older version of flash, tried 32-bit plugin, still nothing. Running year old ASUS laptop with extended display onto new ASUS monitor. More help needed.

dfrost909 0 solutions 16 answers

Nor for me.

dfrost909 0 solutions 16 answers

With the cfg file edit suggested elsewhere (turn off flash protected mode), starting FF in safe mode (Help>restart with add-ons disabled) takes care of most of my problems, but this can't be permanent fix.

SafeBrowser 550 solutions 2392 answers

dfrost909:

Protected mode in Flash only applies to Flash version 11.3.300.257 (and later, when released) which was released on 06/08/2012. The owner of this thread, rvanderm, indicated that "flash v. 11.2.202.235 is enabled in my plugins" earlier in this thread.

If everything works in Firefox Safe Mode, then you have a conflict with an Extension or another plugin. It should be understood without saying, but if you have the NoScript or FlashBlock extension (or a similar extension) installed, you need to take that into consideration. The ActiveX plugin, no longer used by Firefox, has been indicated as a problem with the current version of Flash. and possibly RealPlayer could be interfering with the newest version of Flash. Both Mozilla and Adobe are reportedly looking into the problems with the current Flash version.

Modified by SafeBrowser

Chosen Solution

So I figured out that one of my extensions was causing the problem. I've disabled it and now everything works. Thanks for the help with this extremely frustrating issue.

Trevor_George 0 solutions 2 answers

@rvanderm . . . . It would probably help if you could tell what extension you disabled. I've tried everything and still getting nowhere. I can see either YouTube or Facebook videos, but not without disabling things for one the Enabling it for the other.

Modified by Trevor_George

SafeBrowser 550 solutions 2392 answers

rvanderm:

Was the problem with the Active X plugin, or the RealPlayer add-on, or NoScript or Flashblock as I indicted in my post above?

Knowing which Add-on caused your problem may help us to solve the same problem being experienced by other users.

Updated article on the issue: https://support.mozilla.org/en-US/kb/flash-crashes-or-does-not-load-firefox-13


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Modified by SafeBrowser

arryla40 0 solutions 3 answers

I got flash to work by disabling shockwave 11.xx. I have no idea why this worked but it did and I am using FireFox again.

Trevor_George 0 solutions 2 answers

I looked for ages on Google, and someone said it would work if you disabled any video recording software, so I had to disable the video-recording facility in RealPlayer (which I was annoyed about), so when I disabled it, the videos worked again, but I cannot record any on to my hard-drive, because when I enable it to record, I can't view the ****** video !!!!

vito88 0 solutions 3 answers

I don't even have Realplayer on my machine anymore! What I finally did was to download a previous version of Flash, (10.3), from the Adobe downloads page. (Sorry I don't have the link, I just Googled "Download an older version of flash")

Adobe says the older player comes with all the up-to-date patches but doesn't have all the features of the newest release. This works fine for me, but I don't really like being stuck with obsolescence. Very frustrating.

arryla40 0 solutions 3 answers

I didn't have RealPlayer on my machine to begin with. When I disabled Shockwave 11.3.XX something, I was than told I have an older version of FF. But I don't care, it now works and I don't have to use IE

arryla40 0 solutions 3 answers

Well, after I said FF with flash was working again I discovered it was not on some other sites. Then I noticed I was being told that I had a version of FF that was no longer supported and advised to download the most recent version, which I did, and now everything is working again, with shockwave enabled (when it was disabled I was being told on some sites that I did not have flash installed). Anyway, my problem now seems resolved with the most recent versions of FF (12-1.0) and the latest version of flash/shockwave (13.3.300.265) installed. Hope that helps someone else because I sure spent a lot of time on this.

Modified by arryla40