X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Flash doesn't work in Firefox 13

Posted

Installed Firefox 13 yesterday. Now flash doesn't work. Have done all the supposed fixes to no avail. Have uninstalled and reinstalled flash. I'm at my wits end with this issue. I'm a web designer who uses flash in a number of my sites. VERY IRRITATING when my sites don't display properly. Anyone have a solution other than the pat Mozilla "fixes"?

Chosen solution

I've found the solution for shockwave not working.

1. Go into about:addons

2. Make sure "Shockwave for Director" is present

3. find "Mozilla ActiveX Control and Plugin Support"

4. disable it

5. refresh the page


This worked for me to get shockwave flash stuff working again.

Edit: shockwave flash worked perfectly fine for me with my old set up until i updated to 13, so it is definitely Mozilla's problem, and after finding this solution I'm sure of it.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

jscher2000
  • Top 10 Contributor
2367 solutions 20957 answers

Flash doesn't work anywhere, even on Adobe's test page? http://www.adobe.com/software/flash/about/

I assume you have verified that the Flash plugin is enabled, but you could double-check here for "Shockwave Flash":

orange Firefox button or classic Tools menu > Add-ons > Plugins

Do you have any add-ons that might block Flash, either directly or indirectly? For example, ad blockers, or NoScript. If so, try disabling them and see whether that makes any difference.

Do you have any SWF files saved locally? If you drag and drop one on a Firefox tab, does it run?

I'm not sure what else you tried, so to avoid duplicating suggestions, could you describe that in more detail?

seb1234 0 solutions 1 answers

This is how I got mine working, I hope someone else will find it useful... 1. Install flash from here: http://get.adobe.com/flashplayer/ (follow the instructions) 2. Restart firefox 3. Goto the abode flash test page: http://www.adobe.com/software/flash/about/ 4. Look for a yellow message at the top saying plugin required. 5. Click the button and install this plugin. The install will fail stating you already have this version installed, however, flash worked for me after this.

Question owner

Thanks y'all. I've done all you mentioned not once, not twice, but several times. Still no joy. All flash applications work in Google Chrome, and IE and they work on my husband's older version of Firefox so I'm assuming this is a Firefox 13 shortcoming. I even tried uninstalling then reinstalling Firefox. Then I tried to find an older version to install.......nope can't do that either. That's what I get for accepting Firefox updates. Again, VERY irritating. So I'll be using Google Chrome from here on out.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello, is shockwave flash showing up as enabled in firefox > addons > plugins?

Barbossa 2 solutions 5 answers

If it is working on sites like youtube, or here: http://www.adobe.com/software/flash/about/

but not here: http://www.adobe.com/shockwave/welcome/

Then it is a shockwave player issue, not a flash player issue. If that is the case, then i have the same problem.

Question owner

Yep, shockwave flash shows as enabled.............but it doesn't work.


I don't deal with youtube much so don't know about what's flash there and what's mp3 etc. so am not sure where to check. The Adobe test page does show an Adobe block that is animated. However other flash test pages do not work nor do the flash applications on my website or any of my client's sites.

I still maintain it's a Mozilla problem since all flash applications work fine everywhere but Mozilla. And my flash applications worked fine in Mozilla till I made the mistake of installing 13.

jscher2000
  • Top 10 Contributor
2367 solutions 20957 answers

Hi bobcattexas, Flash runs on Firefox 13 on every site I've tried. Even if Firefox isn't your primary browser any more, I'm sure you want to see what your sites look like in Firefox. There's a good chance you have a conflict with another add-on. Have you tried to rule that out by disabling all your other add-ons? The simplest way to do that is disable all add-ons using Firefox's Safe Mode dialog and then re-enabling the Shockwave Flash plugin.

Troubleshoot Firefox issues using Safe Mode

Barbossa 2 solutions 5 answers

Chosen Solution

I've found the solution for shockwave not working.

1. Go into about:addons

2. Make sure "Shockwave for Director" is present

3. find "Mozilla ActiveX Control and Plugin Support"

4. disable it

5. refresh the page


This worked for me to get shockwave flash stuff working again.

Edit: shockwave flash worked perfectly fine for me with my old set up until i updated to 13, so it is definitely Mozilla's problem, and after finding this solution I'm sure of it.

Modified by Barbossa

Question owner

THANK YOU BARBOSSA!!!!!!!!! That fixed it.

Stupid Mozilla. Why should I have to do that just because they "updated"? I'm a designer, not a geek. My dear spouse is a geek and he couldn't figure it out either. If there are going to be strange hoops to jump through Mozilla should provide disclaimers. I will not be updating again any time soon. Now, how do I explain all this to the clients we've talked into using Mozilla instead of IE (rhetorical question)? Again, VERY irritating.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

For instructions on how to remove the Mozilla ActiveX plugin see:

jscher2000
  • Top 10 Contributor
2367 solutions 20957 answers

Stupid Mozilla. Why should I have to do that just because they "updated"?

Hi bobcattexas, the Mozilla ActiveX plugin was obsoleted with the release of Firefox 2 and volunteers have been warning on support sites for years that it should be removed. It has consistently been on lists of add-ons that cause problems in Firefox (for example: http://kb.mozillazine.org/Issues_related_to_plugins#Problemati...). It's remarkable that it didn't cause you any pain during the past 5 years -- or perhaps you just lived with the problems not knowing the cause? Anyway, please spread the word to your clients and anyone else using that old plugin to uninstall it once and for all.

Barbossa 2 solutions 5 answers

I didn't notice any problems so I never really bothered with it.

If you want to entirely remove it by the way, there was a nice post I found.

by AliceWyman:

For help uninstalling the ActiveX plugin see:

   http://kb.mozillazine.org/ActiveX#Uninstalling_the_ActiveX_plugin_on_Windows


edit: didn't see cor-el's post before I posted.

Modified by Barbossa

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

For the record (and in case MozillaZine's KB is unavailable) here are the instructions to remove the Mozilla ActiveX plugin, copied from http://kb.mozillazine.org/ActiveX#Uninstalling_the_ActiveX_plugin_on_Windows


Uninstalling the ActiveX plugin on Windows

  • Close all instances of your browser.
  • Go to the installation directory (e.g., C:\Program Files\Mozilla Firefox).
  • Go into the "plugins" folder and delete the file "npmozax.dll".
  • Go back to the installation directory, and then go into the "components" folder, and delete the files "nsIMozAxPlugin.xpt" and "nsAxSecurityPolicy.js".
  • Go back to the installation directory, open the "defaults" folder, then open the "pref" folder and delete the file "activex.js".
AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

P.S. The Mozilla ActiveX plugin was added to the Mozilla Blocklist today and it will soon be automatically disabled for any Firefox users who may still have it installed.

aegugka 0 solutions 1 answers

I updated to Firefox 13 today from Firefox 12. I'm running Windows 7 Home Premium 64-bit SP1 AMD Athlon 64 X2 Dual Core Processor 4800+, 6.0 GB RAM, NVIDIA GeForce 8600 GT. I too experienced problems with site running Flash after the update to 13. I restarted in Firefox safe mode and Flash started to work again; therefore, it had to be one of the add-ons or extensions, but which one. Through the process of elimination my issue was due to the RealPlayer Browser Record Plugin 15.0.4. Once I disabled it and restarted Firefox 13, Flash started to work on all affected sites (i.e. speedtest.net, youtube.com, imdb.com, cnn.com, msnbc.com). I don't know if my issue & resolution is unique to me, but I am guessing there is a compatibility issue with the RealPlayer plugin with Firefox 13 that is affecting any Flash video to play which the plugin will allow to download if working. If this works for others, please verify.

Modified by aegugka

bhungue 0 solutions 1 answers

I'm also having this problem. Videos on YouTube and ESPN are not working and Pandora won't load. I checked out my plug-ins and noticed that I have two Shockwave Flash plug-ins listed. One of them is 11.3.300.257 and the other one is 9.0.45.0. I'm not sure why the old Flash 9 version is still listed since I thought it would have been replaced with Flash 11.3. The Flash 9 plug-in also has an alert on it that says:

"An important update is available for Shockwave Flash...Update Now."

However, I've tried clicking on the "Update Now" link multiple times and it keeps asking me to install Flash 11.3 which is already installed and enabled. Even so, I've tried to continue with the download and restarted Firefox when prompted to no avail.

If I disable Flash 11.3 videos on YouTube work again, but when I try to use ESPN and Pandora a ribbon appears at the top of the browser and a box appears inside the video that indicates that I need to update my Flash Player to version 11.3.

When both of them are enabled videos just don't show up on ESPN, Pandora just spins, and YouTube videos display the following message:

"An error occurred. Please try again later."

I've tried all of the solutions on this page and none of them have helped and it's not an ActiveX problem.

Does anyone else show two versions of Shockwave Flash on the Plugins tab of their Add-Ons Manager?

Modified by bhungue

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

bhungue, Try uninstalling all versions of Flash and then reinstall the latest version. See Flash Plugin - Keep it up to date and troubleshoot problems and http://kb.mozillazine.org/Flash#Windows_uninstall

aegugka (and anyone else with RealPlayer installed) The "Real Player Browser Record Plug-in" (actually a Firefox extension, not a plugin) is known to cause problems. See Fix problems with RealPlayer add-ons

sv3nd3r 0 solutions 1 answers

HI all I was having this issue specifically the two plugins showing up I managed to remove to 9.0 45 version via a link on this forum. However that did not work what did was following this post on adobe.com

http://forums.adobe.com/message/4477773#4477773

after reading this i followed the link to the following guidance

http://forums.adobe.com/thread/1018071?tstart=0

on completion and restart flash worked again. I assume that some how flash is acting in private mode for Firefox

hope this helps .

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

sv3nd3r, Thanks for posting those links to Adobe's forum.

For anyone else having problems with Firefox and Adobe Flash Player 11.3:

Problems with the new Flash Player 11.3 may due to the new Flash Player protected mode for Firefox, for example, see these threads on Adobe's forum:

These Adobe forum threads link to the following instructions (note that disabling Flash Player's protected mode is considered a troubleshooting step, not a permanent solution):

Since this thread was started about a different problem (the Mozilla ActiveX plugin which has now been blocklisted) and has morphed to other issues, I'm going to lock this thread. If anyone else needs help with Flash problems, please ask a new question. You can use this link: https://support.mozilla.org/questions/new

Modified by AliceWyman

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

I received a PM from CheckMate about this thread. Since this is something that I think should be discussed openly I'll reply here.

The ActiveX plugin (npmozax.dll) issue is now fixed via the Mozilla blocklist, which automatically disables it. For some background on the ActiveX plugin issue, see Blocking the old ActiveX plugin in the contributor's forum thread.

The Flash 11.3 Firefox protected mode problem is a separate issue and one related bug is 747683 So, if you did have the ActiveX plugin installed and it is now disabled, AND you have Flash 11.3 installed, then the issue is no longer the ActiveX plugin.

If the problem is Flash 11.3 protected mode (or other issues with Flash 11.3) it's not a good idea to suggest downgrading to 11.2.202.235. The reason why uninstalling Flash and going to a page that requires Flash installs an older version is because the Plugin Finder Service hasn't been updated yet! This is from http://kb.mozillazine.org/Flash#Installing_Flash_on_Windows
Quote:
If the Flash plugin is not installed and you visit a page that has Flash content that requires the plugin, the Plug-in Finder Service can download and install Flash for you (see Installing the Flash plugin (Firefox Support) for more information). If you want to try this method and Flash is already installed, you can uninstall Flash and then visit Adobe's Flash test page to launch the Plugin Finder Service ; however, it may offer you an outdated version.

The alternative (disabling Flash 11.3 protected mode by editing an obscure file) is not good either. I don't know what to suggest in those cases. I think it would be a good idea if you could bring this up in the SUMO Community Discussions forum. There's already a topic started on Flash 11.3 issues, here:

Here is your original message, for reference:


Hi, Alice- You locked the thread on the Adobe Flash Plugin update 11.300.257 not working question but you really shouldn't have for the following reasons. First, although I too found today that the Active X has been blocked as of June 7, the problem persists and the instruction is to contact the manufacturer. How about contacting Adobe and straightening this out on the Developer level instead of closing the thread because there's another temporary but much simpler solution that I found. Second, the instructions on how to disable Protected Mode are nuts. I'm pretty advanced, but my common sensed tells me this is too complicated to bother with and shouldn't be necessary and you yourself say this isn't a permanent fix. Third, I found a much simpler solution, at least until this bug is fixed. Completely uninstall the Plugin from the Add and Remove Programs list. Then, when you try to access any video on YouTube which uses the Plugin, Firefox reports that it needs an additional Plugin to play the video (look specifically for the FF blue plugin icon). When you click on it, it automatically downloads the PREVIOUS VERSION, 11.2.202.235 which works perfectly. But if you click on the warning below it that Adobe Flash is needed, the buggy 11.3.300.257 version will be installed again! This has to be fixed by the Developers. Until it is, the fix is simply to roll back the faulty update, which could have also been done with a restore point but I wanted to find the cause. FF apparently knows automatically that this plugin is faulty and installs the previous version, but the other instruction is contradictory and installs the 11.3.300.257 Nice!?!?