X
Tap here to go to the mobile version of the site.

Support Forum

With default SPDY enabled in FF13.0 cannot connect to Gmail

Posted

With the default setting of SPDY enabled in FF13.0 I cannot connect to Gmail. With SPDY disabled I can connect to Gmail as normal.

With the default setting of SPDY enabled in FF13.0 I cannot connect to Gmail. With SPDY disabled I can connect to Gmail as normal.

Additional System Details

Sites Affected

https://mail.google.com/mail/?tab=wm

Installed Plug-ins

Google Earth, Google Update, Java SE7, PDF-Exchange Viewer, Shockwave Flash, Shockwave for Director, Windows media plugin DLL, Windows Presentation Foundation, Adblock Plus, Download Helper, Element Hiding for Adblock Plus, Google Sharing, Mozilla Archive Format, No Script, Reminder Fox, Scrapbook.

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

With SPDY enabled FF just stalls on Gmail link and the tab icon turns slowly anticlockwise.

jscher2000
  • Top 10 Contributor
6426 solutions 52630 answers

I wonder whether the scripts or other components change in some manner when using SPDY? To flush old files, you could log out of Gmail and empty your browser cache to see whether that makes any difference. You might also delete your google.com cookies (I don't know whether any other hostname is relevant).

I assume you are familiar with these operations, but for anyone else visiting this thread...

1. Clear Firefox's Cache

orange Firefox button or Tools menu > Options > Advanced

On the Network mini-tab > Offline Storage : "Clear Now"

2. If needed, delete the site's cookies here

While viewing a page on google.com, right-click and choose View Page Info > Security > "View Cookies"

I wonder whether the scripts or other components change in some manner when using SPDY? To flush old files, you could log out of Gmail and empty your browser cache to see whether that makes any difference. You might also delete your google.com cookies (I don't know whether any other hostname is relevant). I assume you are familiar with these operations, but for anyone else visiting this thread... 1. Clear Firefox's Cache orange Firefox button ''or'' Tools menu > Options > Advanced On the Network mini-tab > Offline Storage : "Clear Now" 2. If needed, delete the site's cookies here While viewing a page on google.com, right-click and choose View Page Info > Security > "View Cookies"

Question owner

Thank you jscher200 but that made no difference. I deleted the cache and removed all google cookies but I still cannot connect to Gmail or sign in to my Google account with SPDY enabled. It seems very few users have this same problem, which is strange as I don't think there is anything unusual about my setup.

I have found a problem connecting with another imap server using https so this looks like the issue but I can't figure out why.

Thank you jscher200 but that made no difference. I deleted the cache and removed all google cookies but I still cannot connect to Gmail or sign in to my Google account with SPDY enabled. It seems very few users have this same problem, which is strange as I don't think there is anything unusual about my setup. I have found a problem connecting with another imap server using https so this looks like the issue but I can't figure out why.

Modified by Roger73

cor-el
  • Top 10 Contributor
  • Moderator
15451 solutions 139943 answers

No problems here with Gmail and SPDY enabled in Firefox 13.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).


You can also check for problems with other prefs.

No problems here with Gmail and SPDY enabled in Firefox 13. Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- You can also check for problems with other prefs. *http://kb.mozillazine.org/Preferences_not_saved *https://support.mozilla.org/kb/Preferences+are+not+saved

Question owner

Thanks cor-el but running in Safe Mode with the default theme did not correct the problem. I still could not connect to Gmail with SPDY enabled.

I have tried another https address and I can connect to that, so at this stage the problem only seems to be with connecting to mail servers.

Chrome will connect to Gmail so I have also tried using the Chrome useragent string in FF about:config under "general.useragent.override" but this did not fix the problem.

Thanks cor-el but running in Safe Mode with the default theme did not correct the problem. I still could not connect to Gmail with SPDY enabled. I have tried another https address and I can connect to that, so at this stage the problem only seems to be with connecting to mail servers. Chrome will connect to Gmail so I have also tried using the Chrome useragent string in FF about:config under "general.useragent.override" but this did not fix the problem.

Modified by Roger73

Question owner

I have now discovered that the problem seems to be only with Windows XP SP3. I have upgraded a Vista system with FF 13.0 and this connects to Gmail with SPDY enabled without any problem.

I have now discovered that the problem seems to be only with Windows XP SP3. I have upgraded a Vista system with FF 13.0 and this connects to Gmail with SPDY enabled without any problem.

Question owner

I found a solution in an earlier thread. My problem was caused by having network.http.keep-alive disabled. When I enabled this, I can connect to Gmail etc. with SPDY enabled. I also enabled network.http.proxy.keep-alive but since I don't use a proxy, that was probably not an issue. Keep-alive is not something I would have thought could cause this problem. Very strange.

I found a solution in an earlier thread. My problem was caused by having network.http.keep-alive disabled. When I enabled this, I can connect to Gmail etc. with SPDY enabled. I also enabled network.http.proxy.keep-alive but since I don't use a proxy, that was probably not an issue. Keep-alive is not something I would have thought could cause this problem. Very strange.

Modified by Roger73

Ian.F 1 solutions 62 answers

Roger, hi. Having enabled 'network.http.keep-alive' and with 'network.http.spdy.enabled' also set to 'true' (enabled) did you have any problems loading attachments in Gmail? I am using Windows XP SP3 and whilst on upgrading to FF 13.0 I had no problem opening my Gmail or typing an e-mail I was unable to attach any files, receiving instead an immediate 'Attachment Failure' message. At this point the network configurations were set as above, but only by disabling 'network.http.spdy.enabled' (setting it to 'false') was I able to again use Gmail attachments. (This is being discussed in the thread 'After Firefox 13 update Gmail and Twitter won't load'.)

Roger, hi. Having enabled ''''network.http.keep-alive'''' and with ''''network.http.spdy.enabled'''' also set to 'true' (enabled) did you have any problems loading attachments in Gmail? I am using Windows XP SP3 and whilst on upgrading to FF 13.0 I had no problem opening my Gmail or typing an e-mail I was unable to attach any files, receiving instead an immediate 'Attachment Failure' message. At this point the network configurations were set as above, but only by disabling ''''network.http.spdy.enabled'''' (setting it to 'false') was I able to again use Gmail attachments. (This is being discussed in the thread 'After Firefox 13 update Gmail and Twitter won't load'.)

Question owner

Ian.F no, I do not have that problem. However, to "View" attachments, I have to let FF redirect to another page. I also have the NoScript addon and that can prevent me from downloading an attachment if I don't have the page fully permitted. The SPDY/ keep-alive seems to be a problem in FF13.0, which appears to be corrected in FF14.0. You can follow the discussion here: https://bugzilla.mozilla.org/show_bug.cgi?id=762650

Ian.F no, I do not have that problem. However, to "View" attachments, I have to let FF redirect to another page. I also have the NoScript addon and that can prevent me from downloading an attachment if I don't have the page fully permitted. The SPDY/ keep-alive seems to be a problem in FF13.0, which appears to be corrected in FF14.0. You can follow the discussion here: https://bugzilla.mozilla.org/show_bug.cgi?id=762650