X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why won't Links open from e-mail if Firefox is default browser

Posted

I still have this problem and now it is starting to affect the browsers functionality and useability. When Firefox is my default browser any link outside of Firefox (like in my e-mail) won't open which is becoming a nuisance. I am running Windows 7 which may be the cause of the problem via a setting but I can't locate the needle in the haystack or it may have happened at a Firefox update. Firefox has been my favorite and only browser since Netscape 1.0 but if I can't resolve this problem I will have to switch to another which I really don't want to do. Help!!!

Chosen solution

Tip: If you feel adventurous, try downloading FireFox 13.0.1 from:

ftp://ftp.osuosl.org/pub/mozilla.org/firefox/releases/13.0.1/win32/en-US/

This site is an official Mozilla Mirror, and has the GpG signature file in the folder with the executable.

I had to revert to 13.0.1 to get my links to open correctly.

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

I bought a a new computer with Windows 7 installed.

Installed Plug-ins

Firefox accepted ones.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

Everything I can possibly think of.

jscher2000
  • Top 10 Contributor
2347 solutions 20796 answers

Do you get an error dialog, such as "Locate Link Browser" or "General Failure"? The causes and solutions are described in this article: Windows error opening Internet shortcut or local HTML file - Firefox - MozillaZine Knowledge Base.

Does it make any difference whether Firefox is already running? Usually that helps.

Do you start up to the Profile Manager and choose a profile manually? Shortcuts and external links generally do not work in that scenario (unless something has changed recently).

Question owner

No I don't get an error dialog but When I click on the link the border ot the e-mail highlites for just a second.

I have tried it both ways but usually I have Firefox running in the task bar.

I'm not familiar with the profile manager or quite understand your question but when I start Firefox I just double click the desktop icon.

Thanks for your response jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Does it make a difference whether Firefox is currently running (i.e. a browser window is open) or Firefox is closed and doesn't show in the Task Manager?

You can try to redo the default browser and temporarily make another browser like IE the default browser.

Question owner

cor-el

No, I have tried those those things and it doesn't matter whether Firefox is open or not links still will not open Firefox when it is my default browser. Actually IE is my default browser at the moment so I can open links in e-mails, etc.

Thanks for responding.

jk080 0 solutions 1 answers

This quick registry edit fixed it for me.

(Note: These instructions apply to Windows Vista and 7 only.)

1. Click Start, type regedit, and then press Enter.

2. Navigate to the following entry: HKEY_CLASSES_ROOT\FirefoxURL\shell\open\ddeexec

3. In the center pane, double-click the Default entry, then remove whatever value is there (it'll probably be a weird string of numbers and commas).

4. Click OK, then exit Regedit.

5. If Outlook and/or Firefox are open, close them, then restart them.

Question owner

I want to thank you all for your responses and help with my problem. Eureka! I have found the answer (mostly by accident, I might add). It has to do with protocols in Windows 7, something different from XP. In order to open links in e-mails, etc., when Firefox or browsers other than the default browser, Internet Explorer (thanks Bil Gates), you must, in addition to selecting Firefox as your default browser, also change your Windows 7 'program protocols'. This is accomplished by going to "Control Panel", select "Programs", select "Default Programs" and select "Associate a file type or protocol with a specific program". When the list of file extensions appears scroll to the end of the list to "Protocols" and change the FTP, HTTP and HTTPS protocols from Internet Explorer to Firefox or what ever browser you are using or want. You may also change the default programs for the other protocols also if you want. I hope this puts this issue to bed for good. Thanks again, koehlerle

jscher2000
  • Top 10 Contributor
2347 solutions 20796 answers

Thanks for posting that. Firefox is supposed to take care of that for you when you make it the default browser, so I'm sorry to hear it didn't work for you. Perhaps it's a permission-related problem?

dokeckip 0 solutions 4 answers

I have the latest version of Firefox and use Windows 7 (64 bit). I have tried every solution suggested on this page, and none of them has worked. I have very reluctantly abandoned Firefox after many years of use.

jscher2000
  • Top 10 Contributor
2347 solutions 20796 answers

Helpful Reply

Hi dokeckip, I also use Win7x64. I am able to launch links from Microsoft Outlook, Microsoft Excel, Adobe Reader, and various other programs in Firefox 13 -- it can be achieved! However, if you've reached the end of your troubleshooting rope and prefer to make a different browser your default, of course you can still use Firefox for regular browsing through its program icon. If you want to explore other suggestions, please post back.

dokeckip 0 solutions 4 answers

I would LOVE to return to Firefox if I could find a fix for opening links, especially from Outlook 2010.

jscher2000
  • Top 10 Contributor
2347 solutions 20796 answers

The first thing I generally recommend is the "double-switch." Open Internet Options (either from IE's Tools menu or from the Control Panel) to the Applications tab and make IE the default browser. You can confirm that it worked by clicking a link in Outlook or by checking the Associations list in the control panel.

(Associations list: You can paste this path into a Windows Explorer window to jump to the control panel. Because it does a registry scan, it takes some time to load.

Control Panel\All Control Panel Items\Default Programs\Set Associations

Scroll all the way to the bottom to the Protocols section to see which program is set to handle http and https links are handled.)

The second step in the double-switch is to have Firefox make itself the default browser again.

orange Firefox button or classic Tools menu > Options > Advanced > General > Check Now button

Again, you can test by clicking a link in Outlook. Any change in behavior?

Normally you either get a new Firefox window or tab loading the page, or you sometimes may get an error dialog. The error dialogs usually are associated with "DDE" settings and you can manually edit the setting as described by jk080 earlier in this thread.

dokeckip 0 solutions 4 answers

Did all that. When I tried link in Outlook, no error message. No nothing. No link opens in Firefox.

jscher2000
  • Top 10 Contributor
2347 solutions 20796 answers

After experimenting around for my last post, I managed to generate an error for myself -- a link I clicked didn't load and after about 60 seconds I got a message that it couldn't find my proxy. Thankfully, it worked on the second try. But enough about me.

If you return to the registry editor, could you check the path here:

HKEY_CLASSES_ROOT\FirefoxURL\shell\open\command

I have this:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -requestPending -osint -url "%1"

Is yours the same?

If you have a few minutes to experiment, you could try deleting one or both of the first two command line switches, neither of which is essential:

-requestPending informs Firefox and it will receive the URL via Windows' DDE feature. In case DDE is not working, try removing this.

After removing this, if DDE is working, when you click a link with Firefox closed, Firefox will open the link twice. In that case, you can either live with it or put this command line switch back. Does it make any difference?

-osint is a bit of a mystery to me (Command Line Options > osinit). However, links seem to open normally without it. Does removing it make any difference for you?

dokeckip 0 solutions 4 answers

Here is my entry:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -requestPending -osint -url "%1"

Same as yours. The other things you are saying/suggesting are beyond my pay grade. I thank you for your effort, but I think I'll punt at this point an go either with IE or Chrome.

goldfever 0 solutions 1 answers

Helpful Reply

Thanks for your solution jsher. After updating firefox my links stopped working. I checked all settings and associations but nothing fixed the problem. I had to go into Firefox, options, advanced, and use "check now" that firefox is the default browser. Fixed problem and I can carry on using firefox.

Modified by goldfever

Question owner

Well as of yesterday this problem is back and what fixed it last time doesn't fix it now. For no reason and all of a sudden I can't open links from my e-mail when Firefox is my default browser. I have no idea why this should just happen all of a sudden, it is just mind boggling. Below was my last post when I had the problem before, HELP!!! I still have this problem and now it is starting to affect the browsers functionality and useability. When Firefox is my default browser any link outside of Firefox (like in my e-mail) won't open which is becoming a nuisance. I am running Windows 7 which may be the cause of the problem via a setting but I can't locate the needle in the haystack or it may have happened at a Firefox update. Firefox has been my favorite and only browser since Netscape 1.0 but if I can't resolve this problem I will have to switch to another which I really don't want to do. Help!!!

jscher2000
  • Top 10 Contributor
2347 solutions 20796 answers

I have no idea why this should just happen all of a sudden

Perhaps it was the update to Firefox 14.0.1 from 13.0.1? Or if you haven't updated, go ahead and do the update (you can do it from the Help > About Firefox dialog).

In addition to the various techniques to try to get your default browser settings to be complete and to stick, which you should try first, could you check your Connection settings here:

orange Firefox button or classic Tools menu > Options > Advanced

On the "Network" mini-tab, click the Settings button. The two settings that seem to involve the least problems are:

  • No proxy
  • Use system proxy settings

Does it make any difference?

bobber269 1 solutions 5 answers

Chosen Solution

Tip: If you feel adventurous, try downloading FireFox 13.0.1 from:

ftp://ftp.osuosl.org/pub/mozilla.org/firefox/releases/13.0.1/win32/en-US/

This site is an official Mozilla Mirror, and has the GpG signature file in the folder with the executable.

I had to revert to 13.0.1 to get my links to open correctly.

Modified by bobber269

Question owner

Thanks Bobber269, this fixed the problem but does this mean that I can't update Firefox again or will they fix this problem?????

Question owner

jscher2000, I have checked these settings and they are as you suggest. My problem is now fixed by doing bobber269's suggestion but thanks for your response.