Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't open multiple links from inside a Thunderbird e-mail.

  • 4 replies
  • 1 has this problem
  • 151 views
  • Last reply by Annoyed47

more options

I use Firefox as my default browser and Thunderbird for my e-mail. I received an e-mail with 3 links in it. The 1st link opens in Firefox but when I attempt to open the next link I get a message "Firefox is already running, but not responding. The old Firefox must be closed to open a new window." I changed my default browser to Microsoft Edge and the 3 links opened into 3 separate windows. I have tried adding a profile and uninstalling FF and reinstalling (getting a new profile). Same problem. I am able to open multiple links/tabs on FF but not via Thunderbird e-mail. I am running Win 10.

Chosen solution

The 1st time I uninstalled and re-installed Firefox and Thunderbird, I did them one at a time hoping to figure out which program was causing the problem. Problem still existed. This time I uninstalled them both at the same time. I installed FF 1st, then Thunderbird. I have no idea what the problem was, but it has been resolved and both programs work as they should.

Read this answer in context 👍 0

All Replies (4)

more options

Since this seems to initiate with Thunderbird have you looked into it's forum to see if there is a issue the same as yours ?

http://forums.mozillazine.org/viewforum.php?f=39

more options

Seems I missed something and a link was brought to my attention by Happy112 suggesting that you check this out. https://support.mozilla.org/en-US/products/thunderbird

more options

Pkshadow said

Since this seems to initiate with Thunderbird have you looked into it's forum to see if there is a issue the same as yours ? http://forums.mozillazine.org/viewforum.php?f=39

I searched Firefox and Thunderbird forums before I posted and could find no similar problem listed in either. I also tried the typical search engines...Google, Yahoo etc. with no luck. As stated above: I suspected it was a Firefox problem because changing my default browser to Microsoft Edge allowed me to open all 3 of the links inside the e-mail. Firefox allowed me to open the 1st link, but when I attempted to open the 2nd link I got this error. "Firefox is already running, but not responding. The old Firefox must be closed to open a new window."

I was hoping there was a "simple" fix to this that others may have discovered. Perhaps not.

Modified by Annoyed47

more options

Chosen Solution

The 1st time I uninstalled and re-installed Firefox and Thunderbird, I did them one at a time hoping to figure out which program was causing the problem. Problem still existed. This time I uninstalled them both at the same time. I installed FF 1st, then Thunderbird. I have no idea what the problem was, but it has been resolved and both programs work as they should.