Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Authentication prompt keeps coming back when parent page is refreshed

more options

I have sharepoint 2010 site with modal dialogs. One of the custom web parts i have implemented has link to a modal dialog page. The modal dialog is programmed to refresh the parent page on close. I get windows authentication prompt when i close the dialog. Internet explorer doesnt give me this problem. Firefox does. Need a work around for this.

All Replies (5)

more options

Do you generally get a prompt for that server? You can enable Firefox to use NTLM authentication automatically if you have not already done so. I believe this old article still has the correct procedure: Firefox asks for user name and password on internal sites (in the filter box, if you type ntlm you will get the relevant preferences).

more options

I tried the fix in the article you sent. It doesn't work for me. The first time i access the site i get the prompt, yes. When this popup closes it refreshes the parent page programmatically, Thats when i get the authetication required prompt. Also when the prompt appears i see that some images are not loaded yet. When i supply credentials again, the images load. This happens for every image in the page. I checked the authentication on images. It is fine. If it is a problem with authentication on images, IE should also prompt for credentials, but it doesn't. :(

more options

I think I have seen the each-image-authentication problem very occasionally when reloading an intranet page after making a lot of revisions. I think it might be related to Firefox checking the freshness of (or updating) cached images, but since I see it so rarely I haven't tried to track down what's happening.

If you have the patience to install an HTTP proxy such as Fiddler (http://www.fiddler2.com/fiddler2/), you could get a closer look at the specific traffic generating the prompts and how it differs from successfully authenticated requests.

If I run into the problem again, I will take a closer look.

more options

Is a proxy server in the mix? I noticed the following bug and workaround. It's an old bug that seems at times to have gone into remission but then returned. Also, one of the comments links to a workaround. Does that make any difference?

318253 – NTLM Proxy authentification dialog pops up over and over

Automatically enter password - mozillaZine Forums

more options

There is no proxy configured. I found a work around for this issue. Instead of reloading, i redirected to the same page. Instead of location.reload(), i used location.href = "url";. Firefox is not asking for credentials now.

Could find the root cause of the issue? Still analyzing...