X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

New tabs open with 'mystart by incredibar.com', an app I never heard of until this started. How do I get tabs to open to a blank page again?

Posted

I had a similar problem previously, and was able to find a setting under 'tools' that allowed me to set it back to 'blank page' but I can no longer seem to find that setting and this incredibar.com thing is really obnoxious. I can't find a cookie or any sort of data stored anywhere that will allow me to remove this ad-on.

Chosen solution

I had already cleared out all 'incredibar' related files I could find, and it hadn't done anything to stall them. I did use 'malwarebytes' as eddyc suggested, and while it apparently caught a different problem, incredibar was not foiled. I ended up going under the 'help' tab and choosing the option 'restart with add-ons disabled' and while I would much rather have the thing eliminated entirely, I haven't seen it since.

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Google Talk Plugin Video Accelerator version:0.1.44.15
  • Version 2.9.8.7308
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • 4.1.10329.0
  • Google Update
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Plugin for Wacom tablets.
  • Wacom Dynamic Link Library
  • NPWLPG
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

Ed 95 solutions 596 answers

Helpful Reply

You can reset the page that a new tab opens by doing the following:

  • Open a new tab
  • Type 'about:config' into the address bar
  • Go past the warning
  • Search for 'browser.newtab.url'
  • Right click and choose reset
  • The value should change to 'about:blank'

This should work. However if you have malware on your system which is hijacking the new tab page it will most likely change the setting back again as soon as you restart firefox or your computer.

Do a full virus scan. Also I recommend downloading Malwarebytes Anti Malware and running a full scan. Also view your complete list of installed programs and see if there is anything that mentions incredibar.com. Uninstall it.

Hope that helps.

Modified by Ed

nobullets 0 solutions 2 answers

Incredibar is a stubborn toolbar/browser hijacker. Usually spybot + antirootkit + hijackthis may point you ways to take it off but you'll still have to fix FF settings yourself. You do this by going to the about:config, and clear all entries that have incredibar.com, like keyword.url. Then to clear your computer, try this: http://forums.spybot.info/showthread.php?t=65768

Modified by nobullets

Chosen Solution

I had already cleared out all 'incredibar' related files I could find, and it hadn't done anything to stall them. I did use 'malwarebytes' as eddyc suggested, and while it apparently caught a different problem, incredibar was not foiled. I ended up going under the 'help' tab and choosing the option 'restart with add-ons disabled' and while I would much rather have the thing eliminated entirely, I haven't seen it since.

nobullets 0 solutions 2 answers

yeah in my case I just found faster to do a fresh reinstall of firefox after cleaning the registry entries (ccleaner, regedit). different programs will catch different pieces of the BHO. HijackThis will find some; Spybot will find others. My antivirus never got anything b/c itś not considered a virus, but it did find a rootkit.

Modified by nobullets

Ed 95 solutions 596 answers

Glad to hear it is solved. The best thing generally is to first get rid of the software causing the problem - by uninstalling and then manually deleting anything that is left and doing a virus/malware scan.

Then you can reset the firefox settings that have been changed in about:config. As nobullets says it can be faster to reinstall or reset (FF 13 and above) rather than trying to track down each setting individually.

Modified by Ed

ugniuskiguolis 0 solutions 5 answers

The most annoying thing with Incredibar is that it hijacks your search. when you search something in Firefox, the results gets redirected to http://mystart.incredibar.com/. Even of you delete the plugin, you still can get these redirects. Some registry edits are needed to fix that and It is not always an Incredibar fault. These days redirect viruses are spreading with the enormous rate and if you scan the system with reputable anti-spyware program like MalwareBytes anti-malware it might find the parasite which causes the redirect problem and usually it has other name, not the incredibar. If the program identifies the problem, it can fix it.. that is how redirects stops even if the program finds them under different name than incredibar.

here is a list of the programs that might help fixing this problem automatically. Incredibar redirects

MalwareBytes is on the list, Some other need to be purchased before they will fix the problem, but they have a free scans. so At least you can check if they identify the problem. SpyHunter for example has a free component which can kill active processes if needed.

Also it is a good idea to set a restore point on the system. that might help with the future infections. then you can simple restore your system and remove any virus for free.

creating a system restore point

senthilrainbowl 0 solutions 1 answers

Thank you very much, This solution works fine. I got my problem solved

hussy-ameer 0 solutions 2 answers

Helpful Reply


  1. Simply follow the instruction below.
  2. Open your Firefox tab, Write this ( about:config ) in search bar for open website (www.google.com)
  3. Now it will ask you for promise, Simple click on " I'll be careful, I promise! "
  4. it will bring you on new page, at the top you can see a Search Bar ( for search any content )
  5. Click on that bar and write this " mystart " and hit enter
  6. it will bring round about 5 to 6 configuration lines (BOLD TEXT )
  7. Double right click on that first line a\nd delete all text is written inside that,
  8. Do this same thing on all listed configuration lines.
  1. Now, you should happy.
  1. mystart has gone from your Firefox for forever until you dnt install it again :)
  1. Let's Dance, ( MUSIC ) A_A_A_ Balck and yellow , Black yellow :) Everything i do, i do big lol :)


fuhad 0 solutions 1 answers

thanks. it worked....

Dylans26 0 solutions 1 answers

Thank you so much for your reply, it really saves me a lot of time. I used to really get frustrated, that I'd restore to the default settings. I would have to go back and set my Firefox skins, bookmarks and all that other stuff. It was such a bother but thanks to your method I get to keep my firefox and only remove the nasty bug without having to reset.

Dsgurliegurl 0 solutions 1 answers

You are my heroes! Thank you!