Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't check if plugins are up to date

  • 12 replies
  • 19 have this problem
  • 956 views
  • Last reply by lastavatar

more options

since Friday 5-4-2012 around 6pm est,(on 3 separate computers) i have been getting "sorry we couldn't find the page or file you were looking for" when i click on the link "check to see if your plugins are up to date" through the add-ons page. it's the first time i have ever encountered this problem.....can any one help me with this? i have tried, restarting Firefox, restarting the computers, shutting off the firewall, uninstalling Firefox and reinstalling and so far none of these have worked. it is now Sunday 5-6-2012 around 10:30 am est and i have been clicking that link several times each day to see if anything new happens or gets fixed and so far it has not.....I'm still seeing the same page. i would appreciate it if someone could help me solve this very quickly.....thanks for any help.

Chosen solution

That function appears to be broken in (Windows, MAC, Linux) Firefox 12 (Release), Firefox 13 (Beta) and Firefox 14 (Aurora). A bug has been filed. You may look at the bug discussion but please do not post there --> https://bugzilla.mozilla.org/show_bug.cgi?id=752073

Temporarily, you can go directly to the Plugin Check page by entering the following in your Location/Address bar --> https://www.mozilla.org/en-US/plugincheck/ (you might consider Bookmarking that link)

You can also change a hidden preference in about:config to correct the problem:

  1. See --> http://kb.mozillazine.org/About:config
  2. type about:config in your Location Bar, like typing a web site address, and press the Enter key
  3. ignore warning and choose to continue
  4. Search = plugins.update.url
  5. in lower part of screen, right-click the preference name and choose "Modify"
  6. change the value to --> https://www.mozilla.org/%LOCALE%/plugincheck/ . OR in that value change
    • the http to https
    • the mozilla.com to mozilla.org
  7. close about:config tab


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

Read this answer in context 👍 5

All Replies (12)

more options

Chosen Solution

That function appears to be broken in (Windows, MAC, Linux) Firefox 12 (Release), Firefox 13 (Beta) and Firefox 14 (Aurora). A bug has been filed. You may look at the bug discussion but please do not post there --> https://bugzilla.mozilla.org/show_bug.cgi?id=752073

Temporarily, you can go directly to the Plugin Check page by entering the following in your Location/Address bar --> https://www.mozilla.org/en-US/plugincheck/ (you might consider Bookmarking that link)

You can also change a hidden preference in about:config to correct the problem:

  1. See --> http://kb.mozillazine.org/About:config
  2. type about:config in your Location Bar, like typing a web site address, and press the Enter key
  3. ignore warning and choose to continue
  4. Search = plugins.update.url
  5. in lower part of screen, right-click the preference name and choose "Modify"
  6. change the value to --> https://www.mozilla.org/%LOCALE%/plugincheck/ . OR in that value change
    • the http to https
    • the mozilla.com to mozilla.org
  7. close about:config tab


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

Modified by SafeBrowser

more options

any idea when this will be fixed?

more options

Since it is not a security or stability issue, I doubt that a special sub-version release will be created for that item. Probably will be corrected when Firefox 13 is released (on or about 2012-06-05).

You can correct the preference as outlined in the 7 steps in my previous answer, then you can click the link in the Add-ons tab to get to the Plugin Check page.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

more options

the problem is a redirection error on the mozilla website - it can be fixed on the server side, hopefully in the next fex days (see bug 752232)

more options

It may be noted in the bug report as a "redirect issue", but since the actual address to the page in the pref should be https://www.mozilla.org/%LOCALE%/plugincheck/ NOT http://www.mozilla.com/%LOCALE%/plugincheck/ in Firefox and Thunderbird and no redirect should be necessary. Fixing on the server side is a temporary fix, IMO, to fix a fault with the pref value.

Developers need to find a way to change the default prefs (an there are others) during the update process to mozilla.org and to https for those that apply, so that users do not bear the brunt of the problem.

Modified by SafeBrowser

more options

plugins.update.url has always been set to "https://www.mozilla.com/%LOCALE%/plugincheck/" so far - https://mozilla.com seems to be generally broken at the moment (again, bug 752232) & the problem of plugin check showing a 404 from inside firefox is just a byproduct of that

more options

A bit of history. Some time ago, Mozilla decided to move everything from mozilla.com to mozilla.org. To keep from breaking links, server-side redirection was set up to direct users going to mozilla.com addresses to mozilla.org addresses (in KB and links on Firefox/Thunderbird panels).

The link on the Add-ons tab to check plugins appears to be directed to the value for the pref plugins.update.url. The default value for that pref is mozilla.com and should be mozilla.org . Yes, the value for the pref in question has always been mozilla.com and worked fine as long as the page was a mozilla.com page, and worked after the change to mozilla.org because of a server-side redirect. That redirect does not seem to be working suddenly and is causing problems for users.

There are default prefs still showing mozilla.com that should be mozilla.org. Developers need to find a way to change those default addresses from .com to .org in the users' prefs so that this kind of "redirect problem" does not cause users a problem in the future.

Modified by SafeBrowser

more options

lastavatar:

Did one of the solutions that I presented help to solve your original question?

Sorry about all the other discussion concerning the history and what is occurring to cause the problem. This is not really the proper place for that discussion, but another contributor started that discussion in your thread.

To help other users find solutions, please return and sign-in to the forum with your user name and password:

  • click on "Solved It" next to the reply ABOVE that BEST solved your question
  • DO NOT click "Solved It" next to this reply

Thanks

Modified by SafeBrowser

more options

yes......having the direct link to the plugin check page, helped a lot......i don't know enough about computers to do the other solution work around, so i will leave it as is. thank you for your quick and detailed answer. as of right now I'm waiting to see if anyone else has any more info on this subject before marking it solved/closed. but so far you have the best answer, thanks for that. again thank you and in a day or so i will mark it as closed.

more options

lastavatar:

The redirection to the Plugin Check page from the Add-on tab link is likely to be working again shortly. My preceding comments describing the cause of the problem being experienced by some users were made in the spirit of being an advocate for the users of Firefox and Thunderbird.

I am sure that those making the decisions as to using the server-side redirection after moving sites from the .com domain to the .org domain were certain that this kind of problem would never occur. But a problem has occurred, affecting the users of Firefox and Thunderbird. And, the same problem could occur again in the future.

My comments to developers to find a way to change a few users' prefs (so that the redirection to the .org domain would not be necessary) would correct the problem so that server-side redirection would not be necessary and, therefore, users would not experience this kind of inconvenience in the future.

Modified by SafeBrowser

more options

thanks for the info.....i just checked it and it seems to be working for now. thanks again for all your help.

more options

it seems to be working for now, thank you to all that posted to this thread. now closed. no more help is needed.